Fixing microphone for Skype in Peppermint 2

I’ve read the tutorial for fixing the microphone in Skype. However that fix doesn’t work for me sadly. I do see a bunch of options for the microphone in the Options > Sound devices menu.

Currently the built-in mic is just recording static, but if I plug my headphones in with a microphone, I hear nothing from that mic.
I’m supposed to be helping a guy fix his Windoze machine atm, haha so some assistance would help here.

Everything I can list is below:

sudo lshw -C *-multimedia
*-multimedia description: Audio device product: 82801H (ICH8 Family) HD Audio Controller vendor: Intel Corporation physical id: 1b bus info: pci@0000:00:1b.0 version: 04 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: driver=HDA Intel latency=0 resources: irq:48 memory:fc300000-fc303fff
alsamixer
Sound Card: 0 HDA Intel Chip: Realtek ALC889
Profile options in Skype
Default device (default)

HDA Intel, ALC889 Analog Default Audio Device (default:CARD=Intel)

  "                 "               "       Front Speakers (front:CARD=Intel, DEV=0)

  "                 "               "      4.0 Surround output to Front and Rear speakers (surround40:CARD=Intel, DEV=0)

  "                 "               "       5.1 Surround output to Front, Center, Rear and Subwoofer speakers (surround51:CARD=Intel, DEV=0)

  "                 "               "       7.1 Surround output to Front, Center, Side, Rear & Woofer speakers (surround71:CARD=Intel, DEV=0)

  "                 "               "       Direct sample snooping device (dsnoop:CARD=Intel, DEV=0)

  "                 "               "       Direct sample snooping device (dsnoop:CARD=Intel, DEV=2)

  "                 "               "       Direct hardware device without any conversions (hw:CARD=Intel, DEV=0)

  "                 "               "       Direct hardware device without any conversions (hw:CARD=Intel, DEV=2)

  "                 "               "       Hardware device with all software conversions (plughw:CARD=Intel, DEV=0)

  "                 "               "       Hardware device with all software conversions (plughw:CARD=Intel, DEV=2)

HDA Intel, ALC889 Analog (hw:0,0)

HDA Intel, ALC889 Analog (hw0.2)

hdmi (unkown)

Do you remember doing this:
http://linuxforums.org.uk/index.php?topic=9543.msg67390#msg67390

I can’t say which one you settled on as you never said :wink:

I do, and I never replied because it somehow managed to magically fix itself. This is the reason I resorted to this thread. I did use that search bar before I made it. :wink:

Does the mic not work at all, or does it give static (white noise) ?


I know these are for a different Acer than yours (Acer Aspire 6920 - LF1) but I’m posting the links for future reference:
http://www.linlap.com/wiki/acer+aspire+6930
and
http://www.linlap.com/wiki/acer+aspire+6935g
and
http://www.linlap.com/wiki/acer+aspire+6920g
and
http://forumubuntusoftware.info/viewtopic.php?f=7&t=3398

Built in mic gives white noise, my headphones mic doesn’t work at all.

EDIT: I’ve checked “Rec.” in all the capture boxes :confused:

Run this:

dmesg > ~/dmesg.txt

then attach the dmesg.txt file (in your Home directory) to your next post.


Question … did it fix itself last time after clearing the DMI pool in the BIOS ?

Nope it didn’t. It suddenly just worked one day after I switched to a profile. :confused:

Have you tried installing the proprietary Realtek HD Audio Codecs … which seem to have solved the issue for people with other Acer models ?

You can get them from here:
ftp://WebUser:[email protected]/pc/audio/LinuxPkg_5.17rc1.tar.bz2
or the bottom of this page
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

Would it be possibly to give some instructions on how to install?

From what I’ve learned I need to extract it to my home directory, then run:

cd ~/realtek-linux-audiopack-5.17
sudo ./install

Correct?

Yup … that’s what the Readme.txt says :slight_smile: … so give it a shot.

If you haven’t already, it would be best to install linux-headers-generic and build-essential first:

sudo apt-get install linux-headers-generic build-essential

Nope didn’t fix it. It’s also made the white noise on the built-in mic disappear. :-/

Damn … finding any info on the Acer Aspire 6920-LF1 is impossible … is it known by any other name ?

What’s the output from

arecord -l

and

aplay -l

and

lspci -v | grep -A7 -i "audio"

and

cat /proc/asound/card0/codec* | grep Codec

See if either of these help …

sudo gedit /etc/modprobe.d/alsa-base.conf

try adding a new line at the bottom that reads:

options snd-hda-intel model=acer

options snd-hda-intel position_fix=1

or

options snd-hda-intel position_fix=2

and REBOOT to test.

Nope, not that I know of. Always been Acer Aspire 6920. LF1 is just the model number.

[quote=Mark Greaves (PCNetSpec)]
What’s the output from

arecord -l
**** List of CAPTURE Hardware Devices **** card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 2: ALC889 Analog [ALC889 Analog] Subdevices: 2/2 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1
aplay -l
*** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital] Subdevices: 1/1 Subdevice #0: subdevice #0
lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04) Subsystem: Acer Incorporated [ALI] Device 0146 Flags: bus master, fast devsel, latency 0, IRQ 48 Memory at fc300000 (64-bit, non-prefetchable) [size=16K] Capabilities: Kernel driver in use: HDA Intel Kernel modules: snd-hda-intel
cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC889 Codec: LSI ID 1040

I’ll try out the other suggestions in a second. Also noticed that my “bass tube” doesn’t work either. :frowning:

I’ve come across info on 6920 and 6920g but I’m fairly sure we tried those fixes last time and the LF1 seemed to be a different model as a) the fixes didn’t work, and b) your system was reporting different hardware to those.

I could be wrong … that’s just how I remember it.

I’ll do some more searching tomorrow.

What were you running before PeppermintOS … Oneiric ? … so I can check on the ALSA versions.

And did everything work properly in that ?

From what I can work out, I’ve got the “G” model. So perhaps that’ll help a bit. I was on Natty before and everything worked fine. :slight_smile:

OK, I’ll have another look around tomorrow … off to bed now. → ZZZzzzzzz

Cool. Sleep well!

P.S. Those fixes in your previous, previous, post did not work.

So far I haven’t found a definite fix for the mic(s), and believe me I’ve spent hours looking … but you are not the only person that has had issues with Acer Aspires and mic’s, and particularly on the 69xxG models… actually by the amount of people with the same issue I’m surprised it ever worked on your Ubuntu install :o

I wonder if installing the latest version of ALSA (and maybe firmware), and/or a kernel update to say 3.1 would make a difference.

The good(ish) news … there DOES appear to be a fix for the “TUBA” bass doo-dad if you’re interested.

I’m still looking for a mic fix though :slight_smile:

Hahaha, killed myself laughing at this. :stuck_out_tongue: A fix for this would be excellent, and I’m surprised myself it worked on Natty.

If an updated ALSA version, firmware or kernel will help make it work, it’s fine by me. I’m far more comfortable with things like that now, although I still have much to learn.

Thing is, I don’t know whether an updated kernel/firmware/ALSA will make a difference … so it’s up to you whether you want to try … I don’t mind helping, but can’t guarantee it won’t be a waste of time.

Meanwhile, I’ll type up the BASS fix in a bit … but something else has sprung to mind that I want to check out first.

As you know Peppermint is based on Ubuntu 11.04 … so I would have expected the “sound” subsystems to have been similar if not the same … so I’m currently trying to work out what the differences are … what’s just sprang to mind is maybe there is a “quirks” file somewhere in Natty that differs from the one in Peppermint … I DO know that the Pulse Audio stuff differs a bit.


If you want a look at the hda-verb fix for the bass, see the last 9 lines of the first posting here:

(amongst other places)

or you can wait till I’ve checked them.

and/or google - “hda-verb /dev/snd/hwC0D0 0×15 SET_EAPD_BTLENABLE 2” and you’ll see what I mean :wink: