Fixing Sudoer

I am currently trying to fix sudoer after making some changes it seems i killed the sudoer list.

OS/ unbuntu 12.04

error/ sudo: must be setuid root

Guessing this happened when i made some permission changes to usr/bin

I have tried the following so far.

booted in to recovery mode

remounted the drive to read write using
mount -o rw,remount /

readded my user as sudo using

adduser makin sudo

replaced the sudo file with the backup and then edited it to confirm all info is correct.

sudo cp /etc/sudoers /etc/sudoers.backup
sudo nano /etc/sudoers

I have confirmed using that the user account is sudo upon logging back in to the user account using the following:

id makin

response output was as follows:

uid=1000(main) gid=1000(makin) groups=1000(makin),4(adm),20(dialout),24(cdrom),27(sudo),46(plugdev),116(lpadmin),118(admin),124(sambashare)

still getting this error after running through all of this.
note: this was done as root access as i do have the root password for this box.

Once again any help appreciated guys, thankyou in advance for your time.

Cheers Makin

What are you doing when that error crops up?
Is it on every use of ‘sudo’ ?

Try fixing the ownership and access rights:

chwon root:root /usr/bin/sudo


chmod 4755 /usr/bin/sudo

then reboot and see if makes any diference

Yes this was occuring on every time trying to use Sudo, guess it started when i changed the permissions to usr/bin.

I have now reinstalled using usb install i created and set to keep my files and ove3rwrite the system files to resolve the issue as i had tried the options you mentioned and it didnt seem to resolve the issue.

appreciate your help though.

Kicks himself for not setting up the backup feature.