Flash problems on linpus machine

Hi. I bought an Aspire Revo 3700 for my sister. It was cheap, came with mouse and mini keyboard, and Firefox was already installed. It runs Linpus, but as she just wants to chat and play games using facebook, she thought it wouldn’t matter that it wasn’t windows.

Unfortunately, facebook’s Flash games crash the computer every time she tries to play them. I think Flash and Firefox may need updating but everything is so strange. I can download the latest updates, but they expand on the desktop, and I can’t find a way to open the correct folder to drag and drop them into except using command line entries which don’t tell me if anything’s moved or not.

I used to work in DOS a long time ago, so the concept is undrstandable. It’s just not knowing the commands is really hindering me and putting her off using Linux.

I decided to download Mint 11 as I’ve heard it’s easier than Linpus. I downloaded it to cd using my own pc, but the Revo hasn’t got a cd player.
(I can install using a usb cd drive, but is it worth it?)

  1. If I install Mint 11, will she be able to easily download and install new Flash and Firefox updates, or does every Linux prog use command lines to move stuff?

  2. As she just wants facebook and their games, does every version of Linux have trouble with Flash so will it be easier if I install Windows 7 instead?

  3. Can I leave Linpus on this pc and use a virtual version of windows instead of overwriting linpus?


Is it Linpus Lite ? … does it look like this -


If so, you are stuck at Firefox 2 and a very old version of flashplayer… see here for instructions on updating to Firefox 6 in Linpus Lite:

instruction for flash are in a link at the bottom of the posting.

YES Linux Mint 11 or Ubuntu will automatically load the latest version of Firefox and Flashplayer for you, and will keep them up to date… it will also give you access to MUCH more software.

Installing from a LiveUSB stick is easy too… if you need instructions, just ask.

You could always “test drive” Linux Mint or Ubuntu by installing it to a LiveUSB and booting to that… A LiveUSB will NOT make any changes to your hard drive unless you tell it to

Can I leave Linpus on this pc and use a virtual version of windows instead of overwriting linpus?

Not if it is Linpus Lite as pictured above… AFAIK applications like Virtualbox aren’t available for Linpus Lite, but Virtualbox IS in the Linux Mint/Ubuntu repositories :slight_smile:

Personally I’d go for Ubuntu rather than Mint, but that’s a personal choice kind of thing… Mint is based on Ubuntu, but Mint has problems with some of the Ubuntu PPA’s (extra software repositories… Personal Package Archives) etc. and help is sometimes harder to come by… in reality Ubuntu help will work on Mint (with a few modifications) and the PPA’s can generally be “made” to work, it just means a little more work on your part.

Mark, thanks.

I don’t think it’s lite. It looks similar to a Mac desktop rather, but with icons on the left. I’ll try Mint \ Ubuntu anyway. I have a 2Gig usb drive which should be big enough to run from. I’d love some instructions though if you don’t mind posting a link?

Thanks again.

See the Instructions for creating a LiveUSB (from within Windows)

Once you’ve created the LiveUSB, boot to it and select “Try Ubuntu” or Mint, rather than “Install Ubuntu” or Mint

Obviously if you want to try Mint, you’ll need to download a Mint ISO rather than an Ubuntu one, but the rest of the instructions are pretty much the same :slight_smile:

Don’t forget to include the persistence file (largest your USB stick can manage, probably 1GB) if you want to be able to save changes to the LiveUSB… see the mouse pointer in the picture.

What makes you think it’s Linpus ?

Does it look like any of the pics here:

The reason I ask is that “icons down the left hard side”, and “it looks lie Mac” is making me think more of Ubuntu… pic of Ubuntu 11.04 desktop here:


We got it here:

When it boots it definitely says Linpus. Is there a way to find the version?

OK, I guess it’s the newer version of Linpus Lite 1.6 (Desktop Edition) as pictured here:
(click the Screenshots tab)


If you give me a day or so, I’ll see if I can get hold of a copy and load it in a VM, and work out how to update Firefox and the flashplayer.

Can you answer 2 questions for me…

If you open Firefox and go to Help > About Firefox … Which version of Firefox does it say you have ?
In Firefox, go to Tools > Add-Ons > Plugins … Which version of Shockwave Flash does it say you have ?

Hmm… it’s impoissible to download Linpus Lite 1.6 at the moment… they only allow downloading of 1.4 and that’s completely different.

From the look of the desktop, and the fact that all previous Linpus distributions have been based on Fedora… I’m going to guess 1.6 is based on a recent(ish) version of Fedora…

Is there any mention of the YUM Package manager in any of your menu’s ?

Also, can you open a terminal and enter:

uname -a

hit enter, and post back the output.

I can’t tell you HOW to open a terminal, as I don’t know the interface, but it will be in the menu’s somewhere … or Ctrl+Alt+T might open a terminal.

Mark - thanks for all the help. I’m trying Mint 11 as I type.

Firefox = 4.0.1 (and then) Firefox for linux mint 1.0

Flash = 10.3.d180

About to try Facebook flash games - I think she plays Farmville, but she’s out at the moment.

No … it was the Firefox and flash versions on Linpus that I was interested in.

It should be easy enough to update the flashplayer on Linpus as long as you answer my questions.

Firefox version
Shockwave Flash version
and output from:

uname -a

BTW, if you included the persistence file on the Mint LiveUSB… run the Update Manager, it should (along with a lot of other updates) update Firefox to version 7 and the flashplayer to version 11

Removed the usb drive and restarted. Verbose mode showed Linpus Linus 95.

Desktop shows stretched hexagonal shapes in light blue on dark blue background fading as they go upwards.

Firefox now says "Minefield version 3.0b5pre

Flash plugin was disabled! Enabled it.

Cannot access wireless router. Enter password for default keyring to unlock? Mint accepted the router password, but Linpus won’t.

(ps Mint ran farmville fine. No crashes at all).

I clicked ‘Deny’ and it connected to the router…!

Hmm … Linpus 9.5 is VERY old … the Firefox version it runs is version 3 again very old … and as far as I’m aware Linpus 9.5 was based on Fedora core 8 so there will be no available updates (fedora 8 is discontinued now)

The only way to be sure would be if you opened a terminal and send the output from

uname -a

But if it IS Linpus 9.5 … I’d install Mint or Ubuntu as soon as you can :wink:

It WOULD be possible to update Firefox and Flashplayer to later versions on Linpus 9.5, but any updates are going to be a “shoe horn them in” affair as the software repositories for fedora 8 are no longer being maintained.

Mark, It was Linpus linux 9.5

I tried installing Mint 11 but the install failed when the Revo tried to restart. Apparently it’s a common problem with this pc. You have to update the wireless driver and tell it to blacklist the old driver.

Now when the pc boots, I get a list of os’s, none of which work properly… and the background picture is the Mint desktop !
GNU GRUB version 1.99~rc1-13ubuntu3-1mint1

Linux Mint 11 2.6.38-8-generic (/dev/sda5)
Linux Mint 11 2.6.38-8-generic (/dev/sda5) – recovery mode
Memory test (memtest86+)
Memory test (memtest86+, serial console 115200)
Linpus Linux (on /dev/sda2)
Linpus Recovery System (on /dev/sda2)

If I don’t choose any, after 5-10 seconds the monitor shows an odd graphic, as if the lead isn’t plugged in properly (some garbled, coloured, thin lines of pixels).

It will boot from the usb drive. That was Mint, but I’m dl’ing Ubuntu 11 now.

I did Acer’s recovery steps (Alt + F10 etc.) but that had no effect on what I see when I boot. Is there a way to remove the failed Mint install please?

I don’t want to remove Linpus if possible in case she sends the pc back.


OK, that sounds more like a graphics card driver issue rather than a wireless issue (wireless shouldn’t stop it from booting)…

What happens if you select the second option (with the arrow keys) -
Linux Mint 11 2.6.38-8-generic (/dev/sda5) – recovery mode
then hit enter

Then when you are offered the options … select
and hit enter

Then when asked, leave the option as low graphics mode for one session.



How is the monitor connected, VGA or HDMI ?

I see…

Welcome to linuxmint etc.

then 4 columns : Documentation \ Support \ Project \ Community

But it booted to a desktop ? … if so we need to get the correct drivers loaded…

Look for Additional Drivers in the menu’s and see if it’s offering to install any drivers for you.

If not, tell me what’s listed in Additional Drivers.

Also, open a terminal, and enter:

sudo lshw -C display

Hit enter, and your password when asked

and post the output.

Hint - Linux commands ARE case sensitive, so that’s a CAPITAL C
When you enter your password you won’t see anything echoed to the screen, but it IS going in… just type your password, and hit enter.

Sorry for all the questions. I do search first but it seems linux help is hard to find!

Booted fine. Desktop shows Computer and nina’s Home (my sister’s name) plus that Welcome splash.

I clicked Additional Drivers. After a search, it says: No proprietary drivers are in use on this system.

It found 2 though. Nvidia (version current) [recommended] and experimental 3d support for Nvidia.

At the bottom : This driver (the recommended nvidia one) is not activated.
I clicked ‘activate’ and it’s installing now (could be a while).

If this is about the shut down failure, the post I found regarding that \ the wireless is here:

It’s the fourth reply down from Timgood

sudo lshw -C display shows (I’m having to read off the revo’s monitor and type it here so excuse any mistakes)

description: VGA compatible controllr
product : gt218 (ion)
vendor: nvidia corp
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33mhz
capabilities: pmmsi pciexpress vga controller bus_mastr cap_list rom
configuration: driver=nouveau latency=0
resources: irq:16 memoryLfd000000-fdffffff…etc.

No, at the moment we’re just working on the graphics issue… we’ll get round to the wireless after we’ve fixed the graphics.

Once the NVIDIA drivers are installed, reboot and see if it boots properly (without the need for intervention).

and let me know.

BTW, you’ll need an active internet connection to install (activate) the graphics driver… so if you haven’t got wireless at the moment, you’ll need to connect to your router with an ethernet cable.

I clicked Quit then Restart.
All the menus \ taskbars disappeared but it’s just showing the Mint desktop background and won’t restart.

Before, I used to click Quit then Shut down, and a page of white text on black (like DOS) use to appear, then just sit there. That’s why I searched for freeze issues and found that wireless post.

I’ve just held the power button in to shut down, restarted and got the menu showing mint \ mint recovery \ memtest \ memtest serial console \ linpus linux \ linpus recovery.

Ok, you’re now into the wireless issue you mentioned that seems to stop the Revo 3700 from rebooting properly…

Let it boot normally, by either waiting, or selecting the top item (Linux Mint 11 2.6.38-8-generic (/dev/sda5)) and hitting enter.

When it gets to the desktop, open a terminal and enter these 3 commands

sudo modprobe -rf rt2860sta


sudo modprobe rt2860sta


sudo sh -c "echo blacklist rt2800pci >> /etc/modprobe.d/blacklist.conf"

Now reboot.

To reboot, try holding AltGr+SysRq and whilst holding them type r, e, i, s, u, b
(ignore the commas)

Or in a terminal, shutdown with:

sudo shutdown -P now

If those don’t work… reboot by any method you need to.

Once the system comes back up… test if it will reboot normally now.