Force Thunderbird mail to open doc and docx files in Winword mint 13 64bit Fixed

With regard to this issue.

The problem was solved by the following script under Ubuntu 11.10 32 bit-

However there is another line to test: Code: [Select]

wine “C:\Program Files\Microsoft Office\Office12\WINWORD.EXE” “winepath -w "$@"

(The solution above is taken from Mazin’s post in the following page:

However under mint I am having to use play on linux to run office 12 so created a script -

/usr/share/playonlinux/playonlinux --run “Microsoft Word 2007” “winepath -w "$@"

This results in file not found error message and if I run in a terminal get the following readout-

userone@office2 ~ $ #!/bin/bash
userone@office2 ~ $ /usr/share/playonlinux/playonlinux --run “Microsoft Word 2007” “winepath -w "$@"
[POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.2.3, x86
[POL_Wine_SetVersionEnv] Message: “/home/userone/.PlayOnLinux//wine/linux-x86/1.2.3” exists
[POL_Wine] Message: Running wine-1.2.3 WINWORD.EXE
rm: cannot remove `*': No such file or directory
wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
[POL_Wine] Message: Wine return: 0
userone@office2 ~ $

Is there an issue because I am now using a 64bit system?

I doubt if it’s architecture related.

I must say, spending all that energy getting it running under Ubuntu, just to change to Mint a bit odd.

I’ll have a look back through this topic in a bit and see if I can spot anything relevant … kidding about the Mint thing BTW :wink:

Thanks couple of reasons for mint Ubuntu 11.10 32bit seemed to be taking as much time as my wife’s vista to open and close and programs seemed to be braking.

I wanted a LTS version and to stay away from UNITY and Grom3 and mint offer alternate desktop solutions.

Only draw back so far has been that office will not install in wine directly have to use play on linux but then it is working fab but presents the issue of opening attachments in the mail client.

Why won’t it install in WINE directly ? … which version of WINE is in Mint 13 ?

Office 12 (2007) will install in Wine however when in use there is an error code because something is not installed fully you are told to reinstall.

This could be corrected by installing ie6 or newer but ie will not install directly in wine. The missing file can not be installed separately as it was made only for this version of office. Wine 1.4 is installed as standard I also have 1.2, 1.3 and 1.5 on the system.

I also have office 14 available but this requires the newest version of wine and fails to install.

I think you may be better of working on getting Office to install in WINE proper, rather than POL … can you elaborate on the problem with installing in WINE.

The program opens and works OK but when you change the layout or try to close the programs you are told MSXML 5 is required for this to work properly reinstall to install MSXML 5.

Now I have MSXML 4 and MSXML 6 on the Wine system but it wants MSXML 5 on the net I am told MSXML is part of office 12 and not available separately.

This issue dose not happen if office is installed in POL…

OK, seems you may have bee right about the 64bit, at least as far as installing Office in WINE goes … see here:

Now try this … rename your ~/.wine directory:

mv -v ~/.wine ~/.wine.backup

Now run:

WINEARCH=win32 winecfg

set up the config how you want it … and save it.

Hopefully you now have a 32bit WINE environment.

NOW try installing Office.

Yes that sorts out the office install now back to the issue of opening attachments will now try the previous fix and report…Thanks.

Reinstalled the script and all working OK.

No problem … using WINEARCH to set up a 32/64 bit environment was something I hadn’t seen before either … you learn something every day :slight_smile:

Glad it’s working again.