Formatting an SSD for system use

I bought a very cheap Asus with Mint on it and when visiting my local PC emporium I got the chap to swap the HDD for a 256GB SSD. He checked out the system with windows (he’s a Windows only man). Months later I get back to the Asus for the first time and it won’t let me boot a Live USB (despite changing the boot priority) and demanded that I register Windows.

I extracted the device to a carrier and plugged it into a USB port on my Lenovo T500 laptop. The response was:
Unable to mount 255 GB Volume
Error mounting /dev/sdb2 at /media/keith/FA24921C2491DC47: Command-line `mount -t “ntfs” -o “uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000” “/dev/sdb2” “/media/keith/FA24921C2491DC47”’ exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount ‘/dev/sdb2’: Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the ‘ro’ mount option.

Not understanding all this and impetuous as ever I decided to reformat it, not thinking that I would need a boot sector, etc. So I now have a single Ext4 partition on it. Plugging it back into the ASUS I tried to boot from an Ubuntu 18 live USB but the system just hung with a black screen.

I’ve looked on line for how to partition the SSD but the instructions imply some knowledge that I don’t have.
I’ve been very foolish but would be grateful for help in formatting it correctly (in a carrier USB’d to my Laptop) so that I can return it to the ASUS and Install Ubuntu 18.

[Laptop: Lenovo T500 64 bit and Ubuntu 16.04]

Forget about mounting/formatting the SSD for now, that’s a separate minor issue that’s easily fixed.

First we should try get you booted to a LiveUSB (ON THE ASUS).

When you say:-

I tried to boot from an Ubuntu 18 live USB but the system just hung with a black screen.

Are you saying that’s ALL that happened … ie. nothing displayed to screen AT ALL ?

Have you tried booting the LiveUSB with the nomodeset kernel boot parameter applied ? … do you know how ?

Have you got the model of the ASUS ?

Thanks, Mark.

All the usual POST messages appear but then at the point when one would expect it to boot from the USB the screen goes blank with a flashing cursor (I ought to have been more accurate!).
No, I don’t know about nomodeset - how does one do that?

Have you got the ASUS model ?

Do you know if it’s UEFI capable, and if it’s set to UEFI in the BIOS ?

How did you create the LiveUSB ?

The external label says: A5 P6-P5G41E BLA and the board label says: PQ5PL10T/P6-P5G41E/DP_MB. There is nothing else.

The BIOS makes no mention of UEFI that I recall.

I made the Live USB on my Lenovo T500 laptop by downloading the ISO then using “USB Stick Writer” to create it. It works fine on other machines and I’ve also tried a Mint 18 Live USB with the same, null result.


Okay I’m not 100% sure the ASUS is capable of booting a LiveUSB … though the BIOS does mention “Removeablve dev”

So you’re right, it may be easier to preinstall on the Lenovo T500, which can.

Which OS is currently on the T500 ?

And I’m not aware of any application that presents itself as “USB Stick Writer” … on Ubuntu there’s normally “Startup Disk Creator” which IIRC is broken.
On Mint there is “USB Image Writer”

You say you’ve tested the LiveUSB on another PC and it booted ?

If that’s the case, when you hit F12 on the T500 is the USB stick listed as a bootable device ?

So you managed to install Ubuntu onto the SSD whilst it was connected (externally) to the T500 … but you think you didn’t install a bootloader ?

Okay can you put the SSD back into the external case … attach it to the T500 … then boot the T500 … and post the output from:

sudo fdisk -l



Err, no: The SSD has nothing on it. Now don’t laugh, but I formatted it using what’s listed in System Tools as “USB Stick Formatter” which I think is Mintstick that you recommended. And Gparted shows, as expected, that it has just the one partition.

(By the way: the original HHD works fine in the ASUS - Ubuntu 18 - so the machine is OK)

With the SSD in the carrier and USB’d to the T500:
fdisk -l
keith@T500:~$ sudo fdisk -l
[sudo] password for keith:
Disk /dev/loop0: 88.5 MiB, 92778496 bytes, 181208 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 88.4 MiB, 92692480 bytes, 181040 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 477 GiB, 512110190592 bytes, 1000215216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000f3af0

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 996167679 996165632 475G 83 Linux
/dev/sda2 996169726 1000214527 4044802 2G 5 Extended
/dev/sda5 996169728 1000214527 4044800 2G 82 Linux swap / Solaris

Disk /dev/sdb: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
Disklabel type: dos
Disk identifier: 0xeee79879

Device Boot Start End Sectors Size Id Type
/dev/sdb1 1953 500118191 500116239 238.5G 83 Linux

Partition 1 does not start on physical sector boundary.

keith@T500:~$ sudo blkid
/dev/loop0: TYPE=“squashfs”
/dev/loop1: TYPE=“squashfs”
/dev/sda1: UUID=“31cb07c7-a993-4e3c-b548-6d3ddff0e413” TYPE=“ext4” PARTUUID=“000f3af0-01”
/dev/sda5: UUID=“121cbe20-2477-4919-9ed4-dc20871c8cd5” TYPE=“swap” PARTUUID=“000f3af0-05”
/dev/sdb1: LABEL=“ASUS_SSD” UUID=“32b85ac2-4540-4be3-ae38-4b9c73f589a3” TYPE=“ext4” PARTUUID=“eee79879-01”

Your other questions:
The T500 is running Ubuntu 16.04
I used Mintstick to format the SSD (listed as “USB Stick Formatter” in the menu)
The Ubuntu 18 and Mint 18 Live USBs work fine on my T500
Hitting F12 with the Ubuntu 18 USB inserted in the T500 has no response - or do you mean doing this while booting the T500?

Looking at how easy it is to remove the HDD from a T500

Wouldn’t the easiest way to do this be to simply

  1. take out the HDD from the T500 and place it safely aside.

  2. Insert the SSD into the T500

  3. Boot the T500 from an Ubuntu/Mint LiveUSB

  4. Install Ubuntu/Mint onto the SSD using the automated defaults (overwrite entire drive).
    (BTW, probably best NOT to select “download updates during the install”)

  5. when done shut down

  6. move the SSD to the ASUS

  7. replace the HDD into the T500

No having to do any manual partitioning, and no putting the T500 drive at risk if you get anything wrong.

Wonderful! That worked a treat.
Just for interest: Is there a way of formatting a disk so it can be used as a system disk i.e. with boot sector etc, without swapping discs.

Very many thank, Mark.

You don’t need to ‘format’ a drive in a particular way to add the bootsector (on Legacy BIOS systems)… but if you’re installing to a second HDD (as you were), you’d need to tell the installer (Ubiquity) to place the bootloader on the MBR of the second HDD, otherwise it’d get written to the first.

…and is that easy to do, or have just used the best method?

It’s easy enough to do, but different for different distros/versions.

I mean I could explain how to do it for say Ubuntu 18.04, but that aint gonna apply to Manjaro (or even Ubuntu 16.04 which uses a swap partition as opposed to a swap file in 18.04).

Basically choose “Something Else” at the partitioning section of Ubiquity, then it will ask you to set up the partitions, and where you want the bootloader (which in your case would LIKELY have been /dev/sdb … note sdb NOT sdb1)

I’ve crossed that out, not because it’s ‘wrong’, but because it’d be specific to a users system, and I don’t want to post something that if misunderstood could make their other OS’s unbootable.

The reason I suggested the method I did was because it was the SAFEST method :wink:

I’m all for safe - after all, youv’e seen how I can screw up!

My thanks once more, Mark.

As always, you’re welcome Keith :slight_smile: