Foxit as an alternative to Adobe

Hmm … dunno what happened there, that one didn’t work on my system either, must have been corrupt.

OK, run these commands in sequence:

rm ~/.mozilla/plugins/


cd ~/.mozilla/plugins




tar -xvf flashplayer-

Now close ALL web browsers … reopen Firefox … test Flash.

Still no Flashplayer.

With regards to the follwing,

tanya@VGN-NS30E-S ~ $ uname -a
Linux VGN-NS30E-S 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686 i686 i386 GNU/Linux
tanya@VGN-NS30E-S ~ $ ls -a ~/.mozilla/plugins
ls: cannot access /home/tanya/.mozilla/plugins: No such file or directory
tanya@VGN-NS30E-S ~ $

It may be best to copy the commands form this webpage, and paste them one at a time into the terminal … something went wrong, as the plugins directory never got created.

OK … lets try again (but with FULL paths), run:

mkdir -p /home/tanya/.mozilla/plugins

Now run:

ls /home/tanya/.mozilla

If “plugins” is in the output … carry on, otherwise let me know.

Now run:

cd /home/tanya/.mozilla/plugins




tar -xvf flashplayer-

Now close ALL web browsers … reopen … test flash.

Flashplayer is back but still jerky!

How do you fancy installing Google Chrome … which has its own built in flashplayer ?

I’ll give it a go

OK, go to this page:

Click “Download Chrome”

Select the 32bit .deb

Click “Accept and Install”

Save the google-chrome-stable_current_i386.deb file to your PC.

Then just double-click it to install.

I downloaded Chrome and you wont believe this Mark but, its still not working properly!

Are you testing this on a webpage with a TON of running flash content ?

BBC news website?

I also tried a youtube video.

I don’t know what else to suggest … I suppose you could try a “lighter” distro than Mint

Do you know how to create and boot from a LiveUSB (with persistence) ?

I suppose we could try adjusting the amount of disk cache the flashplayer uses ?
(though I doubt this is the issue … more likely it’s maxing out your CPU’s)

Is the video any smoother in full screen ?

No difference in full screen.

I don’t understand this though. Until a couple of weeks ago I had no problems. It was only when I tried to update Adobe Flashplayer that I’ve had all these problems.

I’ve posted on Adobe forum, I have had 200+ views but no reply!

Is there an alternative to Flashplayer?

I don’t know how to use a LiveUSB. If I change distro which one would you suggest?


But now you’ve said an older flashplayer worked … can you remember which one ?
(so we can try it and see if that works)

I think it was 10.3.

On the link below is a list of ‘Debuggers’, would that be of any use? Or should I just download the older version?

Let’s check how well 10.3 does first … run:

cd ~/.mozilla/plugins




tar -xvf flashplayer10.3-32bit.tar.gz

Now close ALL web browsers and reopen Firefox.

How is flash now ?

Yay!! It works.

Many thanks Mark you’re a star! And very patient too :wink:

You may come across some sites that require a more recent version of flash.

I’m just wondering if disabling hardware acceleration in flashplayer 11 would have made a difference ?

Let me know if you want to give it a try … you can always go back to 10.3 if necessary :wink:

Are you not fed up with me by now? :wink:

Yes I would like to try what you have suggested.

OK, to go back to the latest flashplayer, run:

cd ~/.mozilla/plugins


tar -xvf flashplayer-

Now close ALL web browsers … restart Firefox … now go to youtube and start watching a video … jerky ? … if so, right-click the video, and select “Settings”, then select the little monitor icon, then remove the tick from “Enable hardware acceleration” and click Close.

Now (if necessary) reload the page, or restart Firefox … is the video still jerky ?

If that makes no difference, to go back to 10.3 run:

cd ~/.mozilla/plugins


tar -xvf flashplayer10.3-32bit.tar.gz

The close ALL browsers, and reopen Firefox … you should be back to 10.3 again :slight_smile:

Oh I don’t believe this!

I ran the first codes…didn’t work. Went back to 10.3 and now that’s not working either! :frowning: