Fresh install of Natty Narwhal (11.04)

Ok due to some sort of superblock corruption/break-down, I’ve decided it was best to just do a complete reinstall of Natty. (2nd time install)

So far, I’ve talked to Mark and we came up with the idea that, splitting my drive would eliminate this happening again (well that’s the idea anyway). I have a 250gb installed in this laptop (I have many XD) so, we thought 2x 121GiB partitions, the main one mounted to “/home” instead of “/” and the second mounted to “/”. That would leave 8gb for a Linux-swap. So just to confirm I’ve done this right, here’s a screenshot.

Yep looks OK to me.

I take it you managed to copy your music across then ?

Installation finished just under an hour ago. Everything went smooth, now this is the part where I have fun. How can I recieve my backed-up files from my Win7 box? I’ve got my files in a shared folder, but anytime I try ping the address of the Win box, I get no response and I can’t even access the files using smb:// which is the IPv4 IP of the Win box…

Have you set up networking from your 11.4 box? System/Preferences/Network connections

I am running the classic desktop.

Share a folder on your Linux box, make it writeable by anyone, and push the files from the Win7 box.

Once you’ve got them, you can remove the share.

Yes, ofcourse I have.

I’ve got them now, I worked it out earlier on. Seems Win7 doesn’t like being recognised by other computers on the same Workgroup though, I guess that’s MS for you though. Not to worry, there is one thing I do still have to solve and that’s the folder permissions… My files I transfered over from my Linux box to the Win7 box, and then back again to the Linux box, they seem to block my user from moving files either out of/into the folders. So I ran:

sudo nautilus

to use temporary root privileges.

I’m able to move, rename and do what I wish with the folder, where as with my “custom” account, I didn’t have that sort of permission. Before I entered the terminal command, I checked the permissions for the folders and it said, “Owner: nobody” so with the root privileges I changed the permissions back to my home folder, however, the files inside are still saying that the permission is “Owner: nobody”. I don’t feel like going through 300+ files, one by one to change all of them. Anyway I could change all of these so I have full control over them with my non super-user account?

Make sure ALL of your music files and directories are inside the Music directory in your Home directory, open a terminal and enter:

sudo chown -R : ~/Music

so if your username is bally

sudo chown -R bally:bally ~/Music

Then the Music directory, and ALL its contents will be :-
Owner: bally
Group: bally

You can get your current username by looking at your terminal prompt line

Explained -

sudo = needed because you don’t own the files
chown = change owner
-R = recursive (ie. do it to all files and directories that are contained inside the target directory)
bally:bally = user:group
~/Music = target directory or file. (in this case directory)

Thanks Mark! it’s worked :).

Heh…Did you doubt it would ? :stuck_out_tongue:

Maybe :stuck_out_tongue:

Na, course not :slight_smile: