Getting the number key pad to work

On my laptop I cannot get my numbers key pad to work. I have read all the info on keyboard configuration and tried various ‘keyboards types’ but cannot get the num lock key to stay alight and hence key pad to work.
Am I missing the obvious or does anyone know what I might be doing wrong? Any help appreciated.

Can you give us the make and model of the laptop.

Does the numlock key work in Windows, or have you only got Linux installed?

Are you sure the numlock isn’t ON, but the light not showing?

If you’re SURE the numlock key isn’t working… you could try this…

Open a terminal and enter:

sudo apt-get install numlockx

Now navigate to System>Preferences>Keyboard, then click the Layouts tab, then the Options button.

Scroll down till you find Miscellaneous compatability options, and click the little arrow at the beginning of that line to display the options.

Put a tick in the Default numeric keypad keys option.

Reboot, and see if the numeric keypad is now enabled by default.

You could also see if you have any BIOS options to enable the numeric keypad by default.

Thanks for the advice unfortunately didnt work, but at least the num lock led come on now. I have an acer laptop. I have tried various combinations on the keyboard set up menu but none seem to enable the numeric keys. But did notice that the keys 4, 8, 6, & 2 act like arrow keys with the mouse pointer! i havent ( as far as I can tell) got any sticky keys, etc enabled which would do this?? At least I know the keys are working somehow!
I really want to get them working again as I use them a lot with numbers. Any other advice eagerly accepted bearing in mind I am a ubunto novice :slight_smile:

OK, try this (See the EDIT first)…

Navigate to System>Preferences>Keyboard, then click the Layouts tab, then the Keyboard model button.

(make a note of how your keyboard is set before you make any changes)

In the top window, select Acer… in the bottom window, select Acer Laptop… click OK

now (still in keyboard preferences) go to the Mouse Keys tab, and make sure there ISN’T a tick in Pointer can be controlled using the keypad

After a bit of experimentation, I’m gonna guess it’s the “Pointer can be controlled using the keypad” setting… so you may want to check/untick that first.

There is a keyboard shortcut for turning on/off “Pointer can be controlled using the keypad”… so try these first -


Then see if the NumLock key/Numeric keypad works properly.

It appears to be a known bug (“mouse keys turns on randomly”):

that has been going on for some time… though this is the first time I’ve come across it.

Thanks Mark. It seems to have fixed it ( sort of ) but numbers only work when the num lock led is NOT lit!

Thanks for all