Getting tightvnc to work from windows to opensuse 13.2

Hi all
I have only just installed linux on a clean PC to see if i can switch away from windows. it’s in an awkward position so for now I want to control it from my windows pc.
I installed Tightvnc on windows and setup remote desktop in suse . Rebooted suse and it worked perfectly - I was very pleased :wink:

so this morning I tried and got an error “No connection could be made because the target machine actively refused it.”
I googled and tried changing the ip address to specify a different port like this
this got me to the login on Suse so I thought i had cracked it but after logon I get a “Failed to recv data from socket” error

I tried port 5900 which i believe is the default but I get the original fault with that.
I have spent hours looking at forums but I can’t get past this error.
In the end I tried to install teamviewer 10 which I have used for years on my windows network but this was a nightmare to install and I have given up for now.
I did like the tightvnc when it worked so would like some advice on what to try next if someone could help please.