Glitch with Xorg?

I took this screenshot literally a couple of minutes ago, because I was going to show off my latest capture XD However, if you notice, there is a nice big duplicated part of the screen to the right. Is this an Xorg server issue? I’ve tried taking programs with, “Take Screenshot” and “Shutter” both which give the same result. Any guesses on how to fix this? Could it be a problem with Docky?

Have you tried closing Docky before taking the screenshot ?

sudo killall docky

You can always restart it with Ctrl+Alt+T to open a terminal, then

screen docky

The “screen” part will allow you to close the terminal without closing docky.

Which desktop are you using … Unity or GNOME ?

I’m running Unity, you wouldn’t be able to tell because the autohide feature for windows next to the launcher is active, due to me using Conky. The whole point of the screenshot I was gonna take was too include Docky & the desktops :stuck_out_tongue: to show off… hehe.

I’d still like you to try it without docky running… at least I’ll know if the issue is caused by docky, and where to start looking.

I’ll get a screenshot in a minute or two, need to go do something first.

Doesn’t seem to be Docky causing the problem… I’m pretty sure this is an Xorg glitch.

I take it you have dual monitors ?

What are the monitors resolutions/refresh rates set to ?

Which graphics card do you have ?

Which drivers are you running ?

What’s the contents of your xorg.conf ?

have you tried playing with resolutions, refresh rates, and/or different drivers ?

Have you tried renaming ~/.config/monitors.xml and setting up your monitors again in the monitors preferences ?

I think you’re likely to need to play with these thing mainly on your own, as there is no way for me to duplicate this issue… but I’ll look around the web and see if I can find anything similar… but I’ll need the above info :wink:

Don’t worry, seemed to have sorted it for the time being. I just restarted X server.

Weird… but hey, whatever works :wink:

Do you still have no /etc/X11/xorg.conf ? … I thought the nvidia drivers created one.

Nope. I suddenly seem to have one again… take a look. (Attachments)