Going over to Linux

I have looked at Peppermint7, Linux Mint, Ubuntu and Ubuntu MATE. And although I'm beginning to understand the differences between Linux systems and MS, references to things like: SSB?s, gedit, pluma and Vbox tend to muddy the waters a bit for me, but I'm sure I'll get to grips with them in time.

Other than SSB’s" they’re just application names … I’m sure you didn’t know what notepad and wordpad were when you first heard the names, you’ll soon ‘get’ them … as for SSB’s (Site Specific Browsers … or … Single Site Browsers) we’ll get to those in the future :slight_smile:

Up to you if you’d prefer a new PC of HDD…

So are you ready to create a LiveUSB and use it to install Peppermint then ?

I take it you’ve got
a) a 1GB or larger USB stick
b) the Peppermint ISO (preferably 64bit)
c) the Rufus application … or Win32 DiskImager ?

Hi Mark and everybody else who has helped with this discussion or like me, is learning greatly from it,

I have forked out so much for new hard/software or updates to programmes over the years that I was prepared to invest in a new machine as future expense under Linux would appear to be a drop-in-the-ocean compared to continuing with MS. However, I will keep that in reserve for the moment.

Yes, I am ready to go and have (a) and (b) but not (c). Is (c) a programme for burning the ISO? I suspect it is, if so I have ISO Image Burner. However, if the Rufus application or Win32 Disk Imager is essential to the operation I will hunt it down while waiting for further instructions.


Yes “c” is two applications specifically designed for writing the ISO file to a USB stick (because you have to remember the ISO is really meant to be burned to a CD/DVD)

Okay download Either Rufus

or Win32 Disk Imager

And see if you can figure out how to use either of them to write the ISO to the USB stick
(there are youtube videos on how to use Rufus)

Also … do you know how to change the boot order in your BIOS if it turns out to be necessary ?

Thanks Mark, I’m onto all that stuff now; and yes, I can change boot order.

Give me a little while to get comfortable with what I need to do and I’ll get back to you asap.


No problem Ed :slight_smile:

Okay Mark, I think I am ready to move on. I have Rufus and have looked at a couple of Youtube videos and have had a go at creating a LiveUSB to install Peppermint from, but I must be doing something wrong because the video stated to change the file system to NTFS, which I’m sure I did, but the finished item stated it was in FAT32. :-

I would have expected it to be FAT32 … have you tried booting from the USB stick yet ?

No, I wasn’t sure that was the end of the process, or as I said whether or not I’d done things right and thought to check in with the forum first.

You now need to try booting to the LiveUSB

Do you know how to select the USB stick as the boot device ?

If you get to this screen (or similar … I think the 64bit version looks slightly different, but with the same options)

Select “Try Peppermint OS Live” … and hit enter to boot.

As long as you select “Try Peppermint” and NOT “Install Peppermint”, you will make NO changes to your system at this point.

I just want to know whether you can boot to the LiveUSB at this point … once we know you can I’ll post installation instructions.

Is Peppermint to be the ONLY OS on this system (ie. are we wiping the hard drive), or are you planning on keeping Windows too (dual boot) ?

I have bought a new HDD for Linux so I’ll just go right ahead and install it Mark. I’ll be back soon to let you know what happened and hopefully that will be a no-nonsense install of Peppermint 7.


Cool … good luck Ed, not that you should need it :slight_smile:

You’re right about it being FAT32 as opposed to NTFS. The chap was talking about booting from a disk when he stated NTFS. My mistake and I will pay particular attention in future to what’s being said when the guy’s first language isn’t English.

With the above in mind and in regard to actually booting to the LiveUSB. Just to make absolutely sure the flash drive has been prepared correctly and I do things right, could you briefly run over the steps to boot from the USB please?

Cheers Mark,


This question is awkward to answer … depending on the make/model of laptop you’ll either have to

a) Find the key that rings up the boot device selection screen
b) Set the USB stick as the first boot device in the BIOS ← this may already be the case, what happens if you just shut down the PC, insert the LiveUSB and turn on the PC … does it show “Try Peppermint / Install Peppermint” or does it boot straight into Windows ? (if it offers “Try Peppermint / Install Peppermint”, select “Try Peppermint” and let me know)

If it boots straight into Windows, let me know the make/model of your PC.

Hi again folks, sorry for delay, but I haven’t been idle (makes a change says my wife), yes well… err, hmn!

Okay Mark, I have been having fun and games with the installation of Peppermint 7 and the following took place over the last few days…

Initially, I inserted the flash drive, pen drive, whatever - I never know what to call those things - and ran up the new HDD and selected: boot from USB. The first few attempts seemed to ignore my instructions and I discovered the machine had reverted to boot from Sata; however, it did eventually recognise the USB stick and presented me with the installer boot menu splash screen. I selected ‘install Peppermint O/S’ and my first attempt was rewarded with rows of figures and advice such as: “[3.143055] sd 8:0:0:0 [sdb] no catching mode page found”, and then the machine froze.

On the second attempt I had similar numbers and thought: “oh no, here we go again”, but then a reddish screen appeared with a moving circle, a globe, the words Peppermint and starting up - then I was presented with 5 rows of fuzzy, horizontal black and white lines and the machine seemed to crash again. I did this a few times and each time I got the same result - not because I’m an idiot (although some would give me an argument there) no, because I thought I might have been doing something slightly different each time. Eventually I recognise that I had done exactly the same thing each time and so it was time for a re-think.

This time I selected: ‘try Peppermint live’ and the system seemed to load up. Various screens appeared advising of the merits of Peppermint and then I was shown the programme selection buttons and all seemd okay apart from constant flashes over the screen. After the loading had completed I was advised to reboot, which I did, expecting the Peppermint screen to reappear - but nothing. And I mean nothing, I was just presented with a blanc screen. I tried rebooting a few more times, but the result was the same and that’s where I am now.

I have thought long and hard about the experiences I have had and I feel that…

(1) the USB stick with the programme is working
(2) my machine seems to have recognised same
(3) the computer appears to have loaded Peppermint
(4) so all seems fine as regards Peppermint

So my thoughts return to the fuzzy screen and flashing and I am minded to think that my shiny new, 500 GiG, Hard Drive might be going gangster on me. So, before you and the other good people on this site begin to scrath your heads trying to figure out what might be wrong, let me test the HDD and determine it’s state of health first.


Sounds like a graphics driver issue.

If you can boot Peppermint from the USB stick by selecting “Try Peppermint” … do so … once at the desktop, open a terminal (Ctrl+Alt+T) and run this command

inxi -F

(note the capital F)

and post back here what’s returned in the terminal.

I’m afraid to report that the above procedure was an unmitigated disaster, for which both me and my computer accept full responsibility. :frowning: I booted into ‘Try Peppermint’ a few times and this is what happened:

First Boot. All seemed well, the reddish screen appeared with the revolving circle and the starting up dialogue, then the black and white lines appeared and the screen went fuzzy again.

Second Boot: As above, but then the computer froze.

Third Boot: As above, and in each of these scenarios I lost the use of the mouse and keyboard - disconnecting and reconnecting made no difference - the computer would not recognise them.

Finally I loaded P7 as a dual boot with Win10, but on re-booting I was advised I had no ‘Boot Mgr’ - so now I could not access any O/S at all, not even MS. Still, in a way this did me a favour as I spent yesterday and today re-installing Win7 and my programmes and that is how I am now writing to this thread.

After much deliberation it seems to me that for some reason my computer will not accept Linux. Well I’m not beaten yet and I will emigrate to Linux and P7, but via a new computer and to that end I have been looking on the Internet.

I spent some time building a contemporary PC, online with PC Specialists, at the end of which I was advised that it was not advisable to put a Linux operating system on the particular configuration I had chosen. I suspect this is because they want to sell the MS O/S. Anyhow I have written asking them why Linux would be a bad choice; meanwhile could you Mark or anybody reading this thread recommend where I could get a good Linux ready Desktop PC, for not too many pennies? :wink:


If you can post the specs maybe we can check the hardware for known issues.

Hi again,

Please find below the information requested, I have included as much as I could to help you to help me, which as ever I value and I am grateful for.

Do you have any ideas re: a new computer? I would particularly like to buy a used one from a private individual, not because I am a mean t**t, but because I hate paying VAT, generally known as Value Added Tax (value, what value?) and which I call Vile Autocratic Theft, which I feel is a more accurate description of the scam.

Although it is virtually impossible not to pay VAT - as all of our big spends are covered, such as power and water, fuel etc - it is not necessary to pay it for everything and some years ago I began selling/buying and swapping my stuff to avoid the nasty thing, and for the most part I am successful as I will go out of my way to avoid it; I even have a website dedicated to avoiding paying it at: http://swappy.simplesite.com if anybody is interested.

Anyhow, here is the data requested:

Security Benchmark Score 0.63 of 10
Virus Protection OK Up-to-date
Computer Profile Summary
Computer Name: Edd-PC (in WORKGROUP)
Operating System Windows 7 Home Premium (x64) (build 7600)
Install Language: English (United States)
System Locale: English (United Kingdom)
Boot Mode: BIOS (Secure Boot not supported)
Enclosure Type: Desktop
Processor a
Main Circuit Board b3.20 gigahertz AMD Phenom II X6 1090T
768 kilobyte primary memory cache
3072 kilobyte secondary memory cache
64-bit ready
Multi-core (6 total)
Not hyper-threaded
Board: ASRock 770 Extreme3
Bus Clock: 200 megahertz
BIOS: American Megatrends Inc. P1.80 10/18/2010
Drives Memory Modules c,d
1233.04 Gigabytes Usable Hard Drive Capacity
1122.12 Gigabytes Hard Drive Free Space

LITE-ON DVDRW SOHW-1673S ATA Device [Optical drive]
SAMSUNG HD103SJ [Hard drive] (1000.20 GB) – drive 0, s/n S246J9AZC08395, rev 1AJ10001, SMART Status: Healthy
WDC WD2500JS-00MHB0 [Hard drive] (250.06 GB) – drive 1, s/n WD-WCANK3096225, rev 02.01C03, SMART Status: Healthy 8192 Megabytes Usable Installed Memory

Slot ‘DIMM0’ has 2048 MB
Slot ‘DIMM1’ has 2048 MB
Slot ‘DIMM2’ has 2048 MB
Slot ‘DIMM3’ has 2048 MB
Local Drive Volumes

c: (NTFS on drive 1) * 239.25 GB 172.60 GB free
d: (NTFS on drive 0) 248.08 GB 235.30 GB free
e: (NTFS on drive 0) 239.69 GB 238.28 GB free
f: (NTFS on drive 0) 247.50 GB 235.21 GB free
g: (NTFS on drive 0) 247.82 GB 230.26 GB free
h: (NTFS on drive 1) 10.70 GB 10.47 GB free

ATA Channel 0 [Controller] (3x)
ATA Channel 1 [Controller] (3x)
Standard Dual Channel PCI IDE Controller (3x)
ATI Radeon HD 4350 (Microsoft Corporation WDDM 1.1) [Display adapter]
NVIDIA GeForce 6200 (Microsoft Corporation - WDDM) [Display adapter]
Acer AL1916 [Monitor] (19.3"vis, s/n 1695605694, December 2006)
Acer AL1916 [Monitor] (19.1"vis, s/n ETL490863470702251424F, February 2007)
HP 2311x [Monitor] (23.1"vis, s/n 3CQ220014C, May 2012)
Bus Adapters
Microsoft - .NET Framework Version 2.0.50727.4927 (32/64-bit)
Microsoft - .NET Framework Version 3.0.6920.4902 (32/64-bit)
Thanks again,


Sorry, I must have hit POST by mistake and seem to have posted the same message twice. I have removed it from this space and inserted this text.

So you have 2 graphics cards and 3 monitors ?

Just as an experiment, what happens if you set either the ATI or nVidia adapter as the primary graphics adapter, then only have a single monitor connected ?

We can get around to the multi-monitor setup later, but at this point it would probably be a good idea to see if it’s one of the graphics cards in particular that’s causing the issue.