Google-Chrome blinks and after that closes abruptly.

Guys, I installed Google-Chrome in my notebook and while I was not booting with proprietary drivers, Google-Chrome was working fine. After I chose to use the proprietary drivers from Nvidia (Nvidia Performance Mode) or Intel (Intel Power Saving), Google-Chrome suddenly blinks the screen and then closes abruptly. This does not happen with Firefox browser. Would someone have a suggestion to offer me?

1 - how did you install Chrome? From Synaptic or as a download from elsewhere?
2 - is there any compelling reason why you need proprietary drivers? If Chrome was working fine with the native driver, why change it?
3 - are you saying that, when testing with either the NVidia or Intel driver you get the same issue? And where did you download those drivers from?
4 - have you had a recent kernel update? Sometimes this can cause previously working software to play up. If so, try reverting to an older kernel and test again.

Proprietary drivers have been an issue for a long time and the ‘solutions’ offered compare to the numbers of stars in the heavens and each one dependent upon the individual set-up! Without knowledge of full system specs etc it is nigh impossible to offer any relevant advice. If it was me, I would revert to the native driver unless, as I say, there is a compelling reason not to. :wink:


Rich has made various very good points, but I’d add one more. Launch Chrome from the command line — often when there’s a problem, you get a useful error message displayed.

  1. I Installed via the google-chrome-stable_current_amd64.deb file downloaded from the Google website;
  2. Because I bought the notebook with graphics cards to have a better screen resolution and I thought that Linux Mint would work well with the proprietary drivers, which would allow me a better screen resolution. But apparently, I spent extra money for nothing;
  3. The drivers came with Linux Mint 19.3. I didn’t install the Operating System. I paid a qualified technician to do the installation for me, since the boot was via UEFI and I was not getting it installed;
  4. The problem occurred with the same kernell that was working before I boot with the proprietary drivers. I wonder that the problem does not happen with Firefox browser which is working perfectly. It is a pity because I was using the Fifefox Browser to browse the various sites and using google-chrome exclusively for me to access my current account at Banco do Brasil;
  5. I would like to post here the messages that are returned when I start google-chrome via console, but the messages are sparse and would take up a lot of space to be posted here;
  6. I am also wondering that a log file is not created in /var/log even if I start google-chrome with the command: “google-chrome-stable --enable-logging = stderr --v = 1”;
  7. I also tried to create an output file using the command “google-chrome-stable> saida.txt” and it is created but is empty.
  8. How do I boot without using proprietary drivers (boot without UEFI I imagine)?;
  9. Or I have to accept to use Firefox even to access my Banco do Brasil account for a while until a solution appears, even why I already posted this problem in the Google community.

I’m a bit out of my depth with this one but it seems to me that as Firefox must be using the same drivers as Google-Chrome, and FF is working OK, then the problem lies with Google-Chrome, not your system.

My limited experience of Google-Chrome has not been a happy one.

Is there a particular reason why you don’t want to use FF for accessing your bank account?

Keith makes a good point - Firefox is a very secure browser and has a ‘New Private Window’ facility that doesn’t save your history if security is your concern. And, of course, there are those who have problems with Google’s privacy policies…

I’ve been online banking for years using Firefox and never had an issue :wink:


Ok, I liked Keith’s answer and I’m also more relieved when Rich says that Firefox is a secure browser in order to access internet-bank. Therefore, as long as Google support does not solve the problem, I will start using Firefox as a browser to access my account at Banco do Brasil.

Taking advantage of the post, I would like to take the opportunity to ask if there is like in Google-Chrome, a way to mirror my noteook screen on the LG webOS LJ5550 TV. Using Google-Chromecast, in Google-Chrome I have the option to “Cast”. I was wondering if in Firefox there is the possibility for me to do this, It seems that there is an option called “Fire TV”, but I was not able to find out if this is a physical device (like Google-Chromecast) or an application that is installed on TV or Notebook. I installed a fx_cast Extension that after a few re-installs it worked properly and make me able to mirror the Firefox screen on the TV screen. But I would like to mirror the laptop screen in any situations.