Having problems with Peppermint Two and Truecrypt

Just upgraded to Peppermint Two and having a couple of teething problems.

My works database and customer quotes are kept in a Truecrypt file. I keep getting a wrong password warning and sometimes not! Worst still when it does accept my password I get this when trying to access the file.

Command “nautilus” returned error 1

Help! I have quotes and sales to do…I will be taken to the dogs by my Boss. :frowning:

Peppermint doesn’t actually contain the nautilus file manager by default, it just has a shell script that points at pcmanfm (its own file manager).

So try this …

First let’s backup the /usr/bin/nautilus shell script -

Open a terminal and run:

sudo cp -v /usr/bin/nautilus /usr/bin/nautilus-original

Now open the /usr/bin/nautilus shell script for editing:

sudo gedit /usr/bin/nautilus

a file should open that reads

#!/bin/bash pcmanfm $1 $2 $3 $4 $5 $6

edit it to read:-

#!/bin/bash exec pcmanfm $3 exit 0

SAVE the file … try Truecrypt now.

The above explained …

Truecrypt calls the Nautilus file manager with this:
/usr/bin/nautilus --no-default-window --no-desktop /path/to/truecrypt-file-or-volume

But Peppermint doesn’t contain the Nautilus file manger, it just has a shell script that point to pcmanfm (the LXDE file manger)

The --no-default-window and --no-desktop options are specific to Nautilus so pcmanfm doesn’t understand them, so we need to loose them … which means (at least) dropping the $1 and $2 from the original shell script.

Now it must be pointed out that there is a small chance this will break something else that attempts to call the Nautilus file manager by default … but we’ll have to wait and see, as I have no idea if there’s anything else in Peppermint that’s liable to call the Nautilus file manger and use command line options.

Unless of course, there’s any programmers or script junkies that would like to jump in with a better solution ?

That saved my life!

Just a genius. :slight_smile:

Thanks very much.

Ok, here’s the alternative;

Visit: TrueCrypt
Download the .tar.gz for your architecture. (32 or 64 bit)
Run it, choose install etc.

Now run the GUI that’s installed itself from the menu, select your file, click “Mount”.
Now in Nautilus goto “Computer” and your volume should appear there …

Nice one. I would try it but it’s working now so I’m leaving well alone. :wink:

@ Mad Penguin … I’m testing it now … thanks.

@ Toonman … if this works with pcmanfm, it’ll be a better solution, as editing the nautilus shell script may introduce problems for other applications.

I’ll post back how it works in a bit


Nope, doesn’t work … it still expects “nautilus” to be installed and fails with the same error :frowning:

Well at least you had a go.

Running truecrypt with no nautilus or additional stuff in peppermint-2. Pretty sure I installed it from here:

Did that work WITHOUT nautilus (ie. with pcmanfm, and no editing)?

Yes, - no nautilus - no editing - truecrypt 7 - am 90% sure it was from link in my last comment.


Cool, that’s another method people can try then … the required edits are above anyway, just in case :slight_smile: