HELP needed to install Epson XP-355 wireless printer AGAIN

I had to purchase a new printer today and it is an Epson XP-355. I have setup the printer with ink etc and it works. I have installed it on my Windows 10 machine as the drivers are for Windows and it is working well.
My problem is I want it working on this Linux computer in Peppermint and I need help to do this.
I have the drivers (I think) from the Epson site, epson-inkjet-printer-escpr_1.6.22-1lsb3.2_amd64.deb and epson-printer-utility-1.0.2-1lsb3.2.x86_64.rpm.
Are these the correct drivers and how do I install them ?? Can anyone help please ??

take care
Don W
EDIT I have got the printer working with this computer via USB. I have downloaded the Linux drivers but don’t know the best way to install them. When I print from the computer I have horizontal banding across my colour pictures I may get rid of this by using the correct drivers. Can anyone help with installing the drivers. ??

Are you still having problems with this … sorry, only just noticed the post (for some reason it wasn’t on the front page).

Hi Mark,
I have this printer set up now using USB. I can print, scan etc. without problem.
I also have it set up to print wirelessly so I can print from the workshop but I still have to come in and retrieve the printout :wink: :wink:
Thanks again

Don W

Yeah the first manufacturer to find a way of hand delivering the print to me at a remote location is gonna get my money :slight_smile:

Damn, mankind gets lazier by the day :))

:wink: :wink:

Hi Mark,
I have lost the Epson printer from my system ??
I can scan from the computer using ‘Simple Scan’ connected via USB cable.
I have the printer setup (I think), and I have checked the Network Connection using the printer and have printed the results and they all Pass, but it does not appear in the list of printers.
Could you help again please ??

Can anyone help ?? Any ideas about how to get this sorted ?? Please

Don W

Are we talking about Peppermint 9 64bit ?

Yes Mark. I am sure it is Peppermint 9 64 bit.

Don W

Hi Mark,
I have just replaced the cartridges in the printer but will need to wait until Monday to try it as my Grandson is here for the weekend.
I did try but got some sort of message about ’ printing was stopped at the printer’. I will see what happens in the morning.
Don W

Hi Mark,
I have replaced 3 of the 4 cartridges in the printer with genuine Epson cartridges (the Yellow still has some ink in it).
I printed the Ubuntu self test page and it looks OK. The driver is given as drvless.ppd and the version as 1.20.2.
I ran the network connection check from the printer and it connected ok and I have printed the details and saved them.
I went into ‘Text Editor’ and typed a line of text and asked it to print. Nothing happens, when I go to Printers>localhost and select the Epson> properties there is a line that reads ‘Printer State’ and it says “Idle - Print job cancelled at printer”.
Any ideas

Don W

Go to
Menu > Settings > Printers

right-click on any listed printers and click “Delete”

When you have NO printers left, go here
and search for

you now need to download the files
and double-click them to install them.

Once installed, go back to
Menu > Settings > Printers
and click “Add”

Step through the installation … when it prompts you to choose a driver, select

Epson > XP-352 355 > Epson XP-352 355 Series - epson-inkjet-printer-escpr 1.6.31-1lsb3.2 (Seiko Epson Corporation LSB 3.2) [en] (recommended)

Thanks Mark,
I carried out your suggestions as above. When complete I asked for the Network Connection Report and it printed it out, everything passed and the signal strength was Excellent. I then chose ‘Print Test Page’ but the printer then hangs and I have to shut it down and restart. The printer hangs with a ‘Processing’.
I am at a loss here to what is happening I hope you have some ideas ??

Don W

a) does it work connected via USB ?en set it
(will probably require you delete the printer, th up again)

b) in your web browser, go to
go to Administration (tab) … then “Manage Printers” button.

Is there only one printer listed ?

and if you select it, does it say it’s active ?

is there anything stuck in the print queue (you can access this either via the CUPS web interface, or by right-clicking the printer in “Printers”)

Hi Mark,
a) It works connected via USB

b) I have 2 printers listed,
the Brother MFC-J5910DW A3 printer that works wirelessly with both the Win 10 computer and this Pep 9 computer,
and this Epson XP-355 that works wirelessly with the Win 10 computer but only works via the USB cable with this Pep 9 computer.
The status of both printers is ‘idle’
The Brother printer is set as ‘Default’ but I change that when I want to use the Epson.

There is nothing in the print queue and there is a history page with what has been printed/cancelled.

When I plugged the USB cable in this morning and switched the printer on,the printer screen lit up and asked me to accept the defaults (as usual) it then printed part of what looks like the start of the Ubuntu Test Page, it only printed the top horizontal line and about 1 1/2" of the vertical border line before spitting it out

Hi Mark,
I have tried to use this printer today and get ‘funny’ results.
I logged on to the computer and and switched the printer on, I tried to print a 1k .jpg and nothing happened.
I checked the print queue status and it said it was ‘compiling’ or something, I don’t really know as I am getting pretty turned off with this.
I will give it up for the day
EDIT I have closed down the printer access and am sitting on the computer home page, I plug in the USB to the printer and it prints the page I was asking for ???

So it works via USB but not via wireless ?

Try this in Peppermint 9,7086.msg72516.html#msg72516

Thanks Mark,
I tried that suggestion but with no luck.
I went to Printers and selected the Epson > ‘Print test page’. The box now shows ‘Printer State’ Processing-Rendering complete. When I look in the print queue it says ‘Processing’. I went for lunch.
After lunch I checked again and it was still ‘Processing’. I cancelled the job after 50 minutes.
So it looks as I have no success with that ??