Help Required to Restore Ubuntu Dual Boot Option

I am a Ubuntu novice having only got involved recently in an attempt to make x-plane 11 run quicker.

Whilst investigating some software the other day I annoyingly and mistakenly changed the Grub2 boot options for my PC so that my PC boot at all, it just gave a grub error (can’t remember what it said).

After some time I managed to get it back to the point where I can boot into W10 but my Ubuntu boot option (through Windows 10 MBR) doesn’t exist or rather points to a non existent file.

EasyBCD shows the the boot options as below

There are a total of 2 entries listed in the bootloader.

Default: Windows 10
Timeout: 17 seconds
Boot Drive: D:\

Entry #1
Name: Windows 10
BCD ID: {current}
Drive: C:
Bootloader Path: \WINDOWS\system32\winload.exe

Entry #2
Name: Grub 2 For Windows
BCD ID: {a0ffb549-1824-11e9-8ad8-8236e31b4d39}
Drive: C:
Bootloader Path: \grub2\g2bootmgr\gnugrub.kernel.bios

Having messed things up yesterday I am loathe just to go blindly ahead in case I mess things up agaiin.

I would appreciate help in getting my Ubuntu boot option back.

I am due a hardware upgrade next week and intend to dual boot Ubuntu & W10 from the same SSD. I don’t want to reinstall Ubuntu as I have it setup to use with x-plane 11 and it took some effort to get it working properly thanks to x-plane 11 Ubuntu users help.

At a least resort I need at least to be able to access Ubuntu as I believe there is a way to copy over the necessary files to the new install. I have a Ubuntu CD which I have used before to access Ubuntu without installing.

I have posted this question on another site previously


Hi - and welcome to the Forums.

Can you boot from your Ubuntu CD and open a terminal? Enter these commands - one at a time!

sudo fdisk -l   
sudo blkid 

Press Enter after each command and post the results back here.

NB: You can copy/paste the commands into terminal and likewise the results into your reply.