Help - system tray missing at boot up and strange panel on screen

My son’s aspire one is working fine except the system (icon) tray at the bottom of the screen has gone missing. There is also a small vertical rectangular panel on screen with a “wheel” icon which can be moved around but I can’t get rid of. A hover over the icon says it’s an application that’s not been configured. Neither problem is solved by a rebooting.

Are these two connected? If so, or if not, how do I solve the problem (s) please?

Well before we can help a little more information would help.

What distro/version of Linux is your son running?

What computer/laptop is it?

How did you install the distro?

How long has this problem been going on for?

I take it your Acer Aspire One is running Linpus Lite (as pictured below) ?

Is it the whole bottom panel (taskbar) that’s missing, or just the icons on the right of it ?

Have you tried adding a new “system tray” ?

Right click the bottom panel, and select “Add New Items” … then add a new “Notification” area.

Let us know if this doesn’t work, and we’ll look into closing the panel and restarting it from a terminal which may give us a clue as to what is stalling.

@BkS … He already stated it was an Aspire One, which by default would be running Linpus Lite :wink:

He could’ve changed it, due to Linpus Lite’s “restricted” ways. :wink: Always nice to ask first. :slight_smile:

Thank you for prompt reply.

Yes the netbook is running linux - sorry, I mean linpus - lite as in the image you have posted.

The whole tray is missing not just some of the icons and a right click anywhere below the application boxes gives what I think might be called the xcfe menu but I couldn’t see the option you mentioned. Is this because the tray is missing, I can’t right click the actual tray itself?

Forgive me because I have little knowledge of the linux operating system although I have managed to sort a different problem before using terminal commands I found on the internet.

Hope this helps?

OK, first we need to fet the terminology right, so I’m sure we’re talking about the same thing…

This is the “Tray

This is the “Panel” (and includes the tray)

This is the “Panel show/hide button

Is the Panel show/hide button still there … if so, does the panel appear if it’s clicked ?

Is the whole Panel missing (including the tray) ?

Or just the Tray ?

If the WHOLE Panel is missing… open a terminal by hitting Alt+F2 … when a dialog box opens, enter terminal and click Run
When the terminal widow opens, enter:


and hit enter … does the panel appear ?

I doubt if these will work, I have a feeling the panel configuration files have become corrupt so you’re going to have to rename the ~/.config/xfce4 directory, and the ~/cache/sessions directory then reboot … but we’ll try that after you’ve tried the above first :wink:

Mark - thank you again (I see you are in Cornwall. So am I; the www is perhaps not so wide in this case)

This is very strange. Just got the machine to try the first bit of code you suggested and it has booted as normal, the panel is back and that funny box with the cog wheel icon has gone! Yet last night and this morning every time we rebooted the panel was missing and the funny box was there.

Really sorry to have bothered you with this.

Not a problem … Ubuntu runs a file system check every so many startups, maybe Linpus Lite does the same … but who cares how it fixed itself as long as it did :wink:

Give us a shout if we can ever help with anything.