Help with Shadow PC Install

Hey there,

I need help fixing my Shadow PC, I’ve been given a link to a post on how to do it but I’m really new to Linux and have no idea how to use the Terminal, is there anyone who can have a look at the link and put it into really detailed steps as I’m really confused.

Thank you so much for the help in advance! :slight_smile:

Hi, can I just clarify what it is we’re looking at …

You have an Ubuntu Linux system onto which you are trying to install what looks to be a commercial service (Shadow PC) which charges $32 a month … and they’ve pointed you at a community support site for help. Is this right, or am I looking at the wrong Shadow PC?

Either way, I’d need to see a download link for the client software and to know the version of Ubuntu you’re running. But you’re quite right, the link you’ve been given on it’s own isn’t all that helpful.

Hi madpenguin,

Thank you so much for replying!

Yes you’re right, I’ve installed the program and getting an error message, the customer support have pointed me to that article to fix the issue and I am SO new to Linux that I have no idea what it’s talking about.

That’s the link to download the app and I clicked on the .deb (Debian, Ubuntu) file and it installs and opens up but then I’m faced with the error explained in that original web link I posted.

Many thanks!

Ok, so what the link seems to be saying is that the error might be the result of missing dependencies.

When you download a package (like this) typically it’s not self-contained and may rely on other packages that may or may not be installed on your computer. Now there are two ways to install .deb packages, the first is;

dpkg -i shadow-amd64.deb

This will attempt to install the package, and just the package. The second option would be;

apt install ./shadow-amd64.deb

This will attempt to install the package and it’s associated dependencies. Typically the former only works if you already have all appropriate dependencies installed, so for example if you were installing a slightly newer version of the same package.

Which command did you use?

Note; this assumes you are logged in as root and the .deb file is in your current directory. If you are not root, prefix the command with sudo, in which case it may ask for your password.

So I tried those commands and attached a screenshot, not sure what’s happening, this terminal stuff is quite confusing to me as I’ve never used it before.

The whole reason for using Shadow is that I want to use Windows for certain games and stuff I can’t access on my Chromebook and thought it would be an easy method.

Do you know if I can use a USB Drive with a bootable install of windows will work? Or how I’d go about running windows?


Ok, so Linux has exactly the same concept of files and folders (directories) as Windows does. If you are in the same folder as your file, you can just reference the file name. If not you will need to reference the full file path.

As per above;

Note; this assumes you are logged in as root and the .deb file is in your current directory

If you are seeing an error that says;

No such file or directory

It would imply the file is not in your current directory. When you downloaded the file from the Internet, it will have stored it either in it’s default location, or it will have asked it where you want to store it. By default it will try to store in a folder called Downloads which is a sub-folder of where you are. So looking at what I can see so far, you would need;

sudo apt install ./Downloads/shadow-amd64.deb

If you want to list files in the current folders use;


If you want to see if the file is in Downloads, do;

ls Downloads

If you want to see where you are, use;


These commands pretty much mirror what you have under Windows with a DOS / Command shell.

So, I’m a little confused now, are you running Ubuntu or ChromeOS, as you’re referencing a Chromebook? Typically if you want to run Windows games on a Linux box you will need the WINE project.

Caveat; WINE can be tricky to get going and managed (although I’ve not used it recently). A less painful (albeit commercial) alternative is something called CrossOver. I’ve used it historically, essentially it’s a wrapper for Wine that takes away much of the setup and maintenance pain.

The other alternative is to run Windows on your machine inside a virtual machine. (or indeed you might be able to use ReactOS which is a free Windows Clone)

If you were looking to pay $30 a month for Shadow, I’m inclined to think CrossOver may be your best option.

Thank you for that.

When I download the .deb file, should I move it to the Linux files and then install it through there?

I typed in that command and it said the same thing as before, not sure what I’m doing wrong?

Also, I’ve tried crossover and can install programs but after I close them, they just never open again. I double click on the app and then nothing happens at all, so I’ve not enjoyed using crossover.

Yeah, I’m afraid you’re going to need to do a little more. You’ve not told me whether you’re running on a Chromebook or on Ubuntu, and if Ubuntu, which version.Start by trying to find your file, this is an example that will search your files for a given name, it might take a while if you have lots of files.

find . -name shadow-amd64.deb

On my machine the response is;


Re; Crossover, I know historically it works, if it’s not worked for you then this would be the place to go to get answers;

I’m using a chromebook with Linux Development Environment enabled.

Ok, so the only thing that’s telling me from the documentation is that you’re running Debian under the hood rather than Ubuntu. If you can’t use “find”, try downloading again from within your terminal session;


Then try the apt install command above.

I did the first step but what install command do I need to do?

sudo apt install shadow-amd64.deb

I have this message pop up?

Apologies, cut / paste issue on my part;

sudo apt install ./shadow-amd64.deb

apt is a bit fussy about local file paths and needs the leading dot + slash.

So I’ve got to this point, what next?

So what happens when you try to run it now?

The app isn’t even loading now, I’ve clicked on the app and nothing whatsoever…

Thinking; if you already had it installed via dpkg, try removing it and installing it again. It may not be installing the dependency list if it’s already installed.

sudo apt remove shadow-prod
sudo apt install ./shadow-amd64.deb

(it looks like the package name is shadow prod, if it can’t remove it by the name shadow-prod, search your packages and see if you can spot the name it’s using)

sudo apt search shadow