Hibernation on Aspire One 110 - Ubuntu


Is anyone able to help with this please?

I have struggled with my wifes AO110 failure to hibernate for some time - would dearly love to fix this - if the machine could hibernate it must surely speed up boot times, which seem to take longer with each new Ubuntu version. Previous attempts (I’ve left it alone for some time now) have resulted in a corrupted superblock in the left-hand card - a big issue with it being the /home directory.

The setup:
Ubuntu 11.04
8Gb SSD - 1Gb swap, 7 Gb Ext4 Root partition
8Gb SDHC Card Ext4 home partition

I have seen what might be a possible fix here


At this point, as it’s not my machine, I’m reluctant to simply try it as, if it goes wrong, I could wind up (again) with a corrupted home partition. Has anyone had any experience of this please or are you able to suggest a way around this.

I would be more inclined to follow the (similar but more robust) instructions here:

also mentioned here:

and comment #167 here:

and comment #31 here:

Make sure you have a backup of the SD card first though… just in case :wink:


Thanks for that

Unfortunately it didn’t work. It seemed to suspend to disk okay. On resume it takes an eternity, but ultimately results in a black screen, with some garbled artefacts in the top inch of the screen. Worryingly it doesn’t respond to the skinny elephant so I have to hold down the power button. The good news is that the card doesn’t seem corrupted any more.


You may want to wait before attempting the following fixes… the “resume” issue might be something else entirely, I’ll look for known bugs with resume on the AA1 and see if I can find anything.

Meanwhile, does the system suspend and resume properly if you unmount the SD card before suspending ?

What I mean is… Is this now a general “resume” issue, or still an issue with the SD card ?


If suspend/resume works with the SD card unmounted… try this

First get rid of the script you created in the last “fix” attempt.


gksudo gedit /etc/pm/config.d/suspend_modules

when gedit opens a blank text file, make it read:

SUSPEND_MODULES="sdhci sdhci_pci"
(obvioulsy without the word Quote)

and SAVE the file.

Now see if suspend works.

Again… make sure you have a backup of the SD card until you’ve tested this.

I haven’t got an AA1 so cannot test it myself.

BE AWARE - The following kernel boot parameter is only for kernels >= 2.6.35
(so will be OK in 10.10 or 11.04, but won’t work in Ubuntu versions prior to 10.10)

If the above workaround doesn’t work… get rid of the changes in /etc/pm/config.d/suspend_modules, and try this:



to the:


line in /etc/default/grub

so it reads:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash mmc_core.removable=0”

SAVE the file, then run:

sudo update-grub

Then REBOOT, before testing suspend.

This should force the system to treat the SD card as a non-removable drive.
(Try the other “fix” first though, as I have no idea how this will affect hotplugging of other SD cards)

Yet again… make sure you have a backup of the SD card until you’ve tested this.


My gut feeling has always been that the most likely cause is the significant changes I made to the system when I installed ubuntu. One is use of the sdhc card (which by default is for system expansion) as a dedicated home partition. I did that when I first installed ubuntu on the machine back in 1999. Also when running linpus the card was in fact formatted as FAT 32 (it’s now Ext 4 - another part of the problem?)

I’m not sure how I could manually unmount the card this nautilus does not actually show it as a card - it simply shows the home directory (in the filesystem pane). Is it possible/desirable to unmount the home directory from a running system?

One query on the script, so as to rule out user error - it refers to

for drive in $( /bin/ls /dev/mmcblk?p* ); do

gparted shows the drive to be known as mmcblk0p1

Putting that in the script has no effect. However, I wonder whether the * is a wildcard or is it something else?

Thanks for the help

I doubt if EXT4 is the problem.

Erm… NO it’s not desirable, I was thinking along the lines of temporarily creating /home on the HDD/SSD… just to test things.

Or whether you knew it worked with /home not on the SD card.

Yup, wildcard… Still looking BTW, I’ll post if I find anything that jumps out at me.

Meanwhile, IF you have an SD card backup, it won’t hurt for you to try the above “fixes” … Both of those are supposed to work… problem is I’m unsure how the earlier fix (from the AA1 Mic/SD fix thread) for your other slot will affect them, and I’m not even sure the issue is still connected to the SD card.

Let me know if you try them… and I’ll let you know if I come across “anything else” that might be causing the resume issue.

Wouldn’t hurt to have a look through the logs and see if anything jumps out at you.

Sorry with work etc I have been a bit strapped for time to work on this. Also, I’m having to be very careful as I’m having to do this when I have unfettered access to the machine.

I am now satisfied that card name in the first script you referred to is correct - mmcblk?p* is now mmcblk0p*. The effect changed quite significantly as on choosing hibernate suspend failed completely and I had to use the off switch. On restart, however, it booted straight into the desktop.

From the comments posted on that script it does suggest to me that if the OS (as opposed to an application?) is accessing something on the SDHC card it won’t shut down. That would seem to rule out suspend and resume working with the home partition on the sdhc card. I can think of no other reason given that the non-SSD AA1 is reported to suspend and resume with little issue.

I did hear some time back of 1 person (possibly using the script?) having success with this. IIRC he had the swap, root, and home (settings) on the SSD and all data on the SDHC drive. Do you know of any non-destructive way of achieving this?

I’d try those other 2 suggestions before going down that route… as both of those should sidestep the issue.

One of them tells the system to treat the SDHC as a hard drive, and the other removes the modules that drive the SDHC during the suspend.

From what I’m reading it seems to make no difference what is on the SDHC, just having one plugged in “at all” is stopping suspend, even if it’s just used as external storage.

As for swapping the / to the SDHC and /home to the SSD, you’d also want to keep GRUB and /boot on the SSD… see here:

Thanks, I really do appreciate the effort you are putting in to try and help me. I’ve been using Gnu/linux for several years as my OS of choice, and have rarely come across anything quite so irritating. From what I read it seems to be distro-agnostic too, so it’s not solved simply by switching from ubuntu. By all accounts it worked with linpus so I should be able to make it work with other distros.

I’ll try the other fixes you refer to , however I need to pick my moment as if something goes wrong I need sufficient time to put it right. As it’s not critical I would much rather tell my nearest and dearest “I’ve fixed it” rather than “I’ve broken it trying to fix it” ;D

I’ll post back when I have had the chance


Linpus uses the AUFS union file system which “kind of” merges/layers the SDHC rather than mounts it separately (although obviously it does get mounted)… but I’m no expert on AUFS or any other union file system… so I couldn’t comment (much) on its inner workings.

That said, it looks like it should be fixable.

Heh… I agree, don’t upset SWMBO… that would be a bad move indeed :wink:

When you have time, let us know if the other “solutions” work… but pick your moment wisely :slight_smile:

It looks like a “similar” thing happens in ubuntu. Even as it is set up now, the ubuntu disk manager appears to view both cards as one disk (although gparted sees them as 2).

Ubuntu disk manager ? … do you mean file manager (nautilus) ?

And when you say both cards… do you mean 2 SD cards, or the SD card and the SSD ?

Are you just commenting on the way the Linux “mounts” drives as branches of the file system which starts at /

or are you saying the 2 SD cards have a common mountpoint ?

AUFS (and any union file system) can mount 2 separate drives/partitions/directories both as say /home… one of which can be writeable whilst the other isn’t.

In all honesty I’m not entirely sure what I’m actually saying ???

In ubuntu there us a disk manager that can be used simply to demonstrate how much of the disk has been used. It excludes swap but amalgamates both the ssd (/) and the sd card (/home). Each are 8gb but it simply shows that 25% of a total of 13.7Gb are being used. I have attributed that to the fact that the left hand slot is specifically for “expansion” (it even says that on the case above the slot :)) although I can’t rule out the possibility that this is simply for “dumbing down” purposes.

Within nautilus, right clicking on a folder does indiate the remaining space on the partition, rather than the system.

I’m still not sure what you mean by “disk manager”… but I’m guessing the only reason the left slot is marked as “Expansion” is because either (or both):

  1. The right hand slot is PCIe so couldn’t be used for expansion, as it couldn’t be mounted early enough… kind of explains the “fix” needed for the right hand slot in Ubuntu.


  1. AUFS was set up to layer/merge the left hand slot, but not the right hand one.

Just as a matter of interest though… can you fire up the “disk manager” then click “About” in the menu’s and let me know what it’s called.

I’ve not got the ubuntu machine with me but after a little research it’s baobab (aka “disk usage analyser” - sorry for the earlier wrong description)


So on the machine in question both disks are represented as one. I don’t know if a desktop machine was to have more than 1 HDD whether it would do the same.

After a quick look at the “Disk” Usage Analyser, I’m of the opinion it has a very misleading name.

It appears to be more of a “Filesystem” Usage Analyser… so will include ALL drives/partitions that have been mounted as part of the file system tree.