How do I get Chromium to work with Chrome's Flash Player in Ubuntu? [SOLVED]

Hello Linux in the UK:

I discovered a clever little trick in Peppermint’s forum that allows one to run Adobe Flash in Chromium Browser by using the builtin Flash of Google Chrome if Chrome is already installed in the distribution. With a little help, I’d like to be able to do this for my Chromium browser in Ubuntu 16.04 also. I have already installed Google Chrome.

Here’s the link from Peppermint forum where PCNetSpec showed us how to do this in Peppermint 7.

https://forum.peppermintos.com/index.php/topic,4475.msg46329.html#msg46329

I’m not certain what I need to change here in order to do the same in Ubuntu.

Any suggestions would be appreciated. :wink:

Thank you,

perknh

Here’s the inxi -Fz for my computer if this is of any help at all:

perknh@xerus:~$ inxi -Fz
System:    Host: xerus Kernel: 4.4.0-47-generic x86_64 (64 bit)
           Desktop: Unity 7.4.0  Distro: Ubuntu 16.04 xenial
Machine:   System: TOSHIBA product: Satellite C70-A v: PSCE2U-03E00S
           Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version
           Bios: Insyde v: 1.30 date: 04/18/2014
CPU:       Dual core Intel Pentium 2020M (-MCP-) cache: 2048 KB 
           clock speeds: max: 2400 MHz 1: 1214 MHz 2: 1290 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: [email protected]
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-47-generic
Network:   Card-1: Realtek RTL8188EE Wireless Network Adapter
           driver: rtl8188ee
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR8162 Fast Ethernet driver: alx
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 240.1GB (4.9% used)
           ID-1: /dev/sda model: PNY_CS1311_240GB size: 240.1GB
Partition: ID-1: / size: 108G used: 5.4G (6%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 6.33GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 198 Uptime: 32 min Memory: 1437.0/5861.8MB
           Client: Shell (bash) inxi: 2.2.35 
perknh@xerus:~$ 

You shouldn’t need to change anything perknh … the instructions are exactly the same for Ubuntu/Mint/Peppermint/etc.

.

Hello PCNetSpec,

I’ll try it. I was anticipating that the gedit part of the process would throw me for a loop. But I’ll give it a whirl, and I’ll report back with the results.

[EDIT]

I had to change pluma to nano, use CTRL 0 and CTRL X, press ENTER, Log Out and In, and now I’m running the up-to-date version of Google Chrome’s Flash within Chromium.

Thank you, PCNetSpec. Yes, it worked! :wink:

Sorry I forgot Ubuntu doesn’t have pluma … swapping all instances of “pluma” to “gedit” would have worked too. :wink:

Hey, no problem. I learned the difference between pluma and nemo by installing Yandex through the terminal over in Peppermint. Also, I don’t remember having to log out and in with Peppermint, but Flash didn’t show up here for me until I logged out, and then in, to Ubuntu. Also, it’s good to know that one can swap out pluma, or nemo, for gedit too. That little trick will come in handy someday. :wink:

Thank you, PCNetSpec. It’s all good. :slight_smile:

Hi PCNetSpec,

I ended up installing Unity again, and this time, when I ran the commands you showed me from Peppermint forum, I had a big surprise. I can longer find libpepflashplayer.so. Yes, there’s a Pepperflash folder in Google Chrome, but when I open it, it’s empty! There no libpepflashplayer.so to be found.

Can we come up with another workaround, or is what I posted over at Peppermint from Google’s Blog coming true now? It’s almost December; maybe support for Flash really is being “de-dmphasized” in Chrome. :o

Whatever the reason, I can’t get Flash from Chrome to work for me any longer in Chromium. Of course, I can download Adobe Flash from Adobe itself, but that’s no fun having to agree to Adobe’s licence agreement,

Thank you,

perknh

You have to use chrome for a while before it downloads pepperflash (it’s not always immediate).

Try using Chrome for a while, and accessing some pages that have flash content … eventually libpepflashplayer.so should appear

Oh! I never knew that. No, you’re right, I haven’t been using it.

I’ll, again, marked the topic as solved. :wink:

Thank you, PCNetSpec.