how to compile , install something

been trying to compile and install mpg123-1.13.2 which i need to use to be able to run a game on wine, called eve online if that helps. ive been to to check out my game it has a gold rating but there are some fixes that need to be attended.

from wine:

Jukebox work perfect using the last mpg123 lib version (currently mpg123-1.13.2.tar.bz2 ) at mpg123 download | and later compile wine with the flag --with-mpg123 (if you make your own builds, Wine package already use it)

scrolling down it has a how to:

1st Solution (Recommended):

  1. Download, compile and install the last mpg123 lib version (currently mpg123-1.13.2.tar.bz2 ) at mpg123 download |
  2. Compile wine with the flag --with-mpg123

i managed to download it but i dont really understand what compiling is or how install, same with 2) comiling wine.

i did how ever give it a crack as i need to try learn these things so i used this site to understand compiling.

clicking copy paste into terminal only got me to part 3, current state is i have the downloaded file in a location and ive run a compile file in the terminal it then did something. i didnt get an error like the guide said so i got lost abit and i dont know how to ‘make’ or install as im not quite sure what im trying to install, i tried to install mpg123-1.13.2 but that didnt work.

i did the missing file in terminal it did something but i copied it directly from the guide so im thinking it didnt look for the mising file mpg123 as this guide is for general compiling not a guide for the file im trying to install.

so any help so i can finish the rest of this would be nice as im in deep water drowning :smiley:

When you extract the mpg123-1.13.2.tar.bz2 file, you should end up with a directory called mpg123-1.13.2… place this in your Home directory. (just so I know where it is)

Install some needed packages for compiling:

sudo apt-get install build-essential linux-headers-generic

When done, still in the terminal, enter:

cd ~/mpg123-1.13.2
sudo make install

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package headers
E: Unable to locate package generic
that was from the 1st line the ‘e:’ lines makes me think it didnt work?

My apologies, (typo) it should have read:
linux-headers-generic, not linux headers generic

Fixed in above post.

the command as stated above will have installed a package called linux then attempted to install a package called headers (which doesn’t exist), then attempted to install a package called generic (which doesn’t exist).

The package called linux can be safely ignored, or removed.

Just follow the instructions in my last (fixed) reply again.

it worked either way i guess, i looked somewhere else and found that installing beta version of wine helped ill still install the last thing aswel from you last post inacase it helps more. thanks again

i did the new line in terminal said everything was the latest version but it did say that something was installed that is no longer require wine1.2-gecko
told me to apt-get autoremove but i got some message saying am i the root? and it didnt do it.

sudo apt-get autoremove

or uninstall wine1.2-gecko from synaptic.