How to install "Wunderlist" task manager in PeppermintOS 2

How to install “Wunderlist” task manager in PeppermintOS (Two)

These instructions are for the 32bit version of Wunderlist in 32bit PeppermintOS, but they should also work for the 64bit version of Wunderlist in 64bit PeppermintOS… the tar command will need to be adjusted accordingly.

OK, here we go …

First make sure you have libcurl3 installed

sudo apt-get install --reinstall libcurl3

Then you’ll need to download the Linux 32bit version from their website:
or direct download of the 32bit version here:

Once done, place the downloaded archive (wunderlist-1.2.4-linux-32.tgz) in your Home directory.

Now to unpack the archive, open a terminal and run:

tar -xvf wunderlist-1.2.4-linux-32.tgz

Now move the extracted directory to /opt :

sudo mv -v ~/Wunderlist-1.2.4 /opt/

Now you need to create a wunderlist.desktop file to launch the application, and add it to the menu … so still in the terminal, run:

gedit ~/.local/share/applications/wunderlist.desktop

When gedit opens a blank file, make it read:-

[b][Desktop Entry] Name=Wunderlist Comment=Task Manager Icon=/opt/Wunderlist-1.2.4/Resources/wunderlist.png Exec=/opt/Wunderlist-1.2.4/Wunderlist Type=Application Categories=GTK;Network;[/b]

(obviously, don’t include the blue Quote in the above, just the Black text)

You should now find a new menu item at Internet>Wunderlist … just click it to launch :slight_smile:

To remove -

sudo rm -rv /opt/Wunderlist-1.2.4


rm -v ~/.local/share/applications/wunderlist.desktop

It extracted, built & installed fine, but just doesn’t seem to be executing itself to open. I’ve tried making it executable, but still doesn’t work.

I used the 64-bit version.

There’s no “building” and “installing” involved

What’s the output from:

ls -al /opt/Wunderlist-1.2.4


also, what’s returned if you try to run it from the command line:

bally@bally-laptop ~ $ ls -al /opt/Wunderlist-1.2.4 total 224 drwxr-xr-x 6 bally bally 4096 2012-03-14 00:53 . drwxr-xr-x 4 root root 4096 2012-03-14 00:54 .. -rw-r--r-- 1 bally bally 95 2011-09-08 11:25 CHANGELOG.txt drwxr-xr-x 2 bally bally 4096 2012-03-14 00:53 installer -rw-r--r-- 1 bally bally 577 2011-09-08 11:25 LICENSE.txt -rw-r--r-- 1 bally bally 477 2011-09-08 11:25 manifest drwxr-xr-x 13 bally bally 4096 2011-09-08 11:25 modules drwxr-xr-x 8 bally bally 4096 2012-03-14 00:53 Resources drwxr-xr-x 3 bally bally 4096 2011-09-08 11:25 runtime -rw-r--r-- 1 bally bally 901 2011-09-08 11:25 tiapp.xml -rw-r--r-- 1 bally bally 1178 2011-09-08 11:25 timanifest -rwxr-xr-x 1 bally bally 179537 2011-08-09 21:10 Wunderlist

bally@bally-laptop ~ $ /opt/Wunderlist-1.2.4/Wunderlist
/opt/Wunderlist-1.2.4/installer/installer: error while loading shared libraries: cannot open shared object file: No such file or directory

Have you got libcurl3 installed ?

sudo apt-get install --reinstall libcurl3

Also, what happens if you run:

cd /opt/Wunderlist-1.2.4




sudo ./Wunderlist

What is the output from:

ls -l /usr/lib/

This fixed it. Thanks Mark!

Also, could you check your PMs please. :slight_smile:

Added to original instructions :slight_smile:

Post the question you asked me in the PM to the forum please :wink: