HP 455 - Not connecting to WiFi [SOLVED]

This is a request to Mark Greaves TBH -

I bought the HP 455, as discussed, re-installed Mint 17.3 and tried to use the commands you sent me to connect it to WiFi (Re: Novatech Laptop Driver CD Only for Windows). When I paste the first command into Terminal nothing happens after I enter my PW. Also, whilst I’m on, where do I find ‘Additional Drivers’ , please?

OK first, can we confirm we’re talking about the right card network adapter, post the output from:

sudo lshw -C network

and the contents of

gedit /etc/modprobe.d/rtl8723be.conf

As for “Additional Drivers” … I think Mint renamed it to “Driver Manager” … so try here:-

Menu > Administration > Driver Manager

source:

Here:
graham@graham-HP-ProBook-455-G2 ~ $ sudo lshw -C network
[sudo] password for graham:
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:01:00.0
logical name: eth0
version: 10
serial: dc:4a:3e:d0:82:42
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=192.168.1.72 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
resources: irq:90 ioport:4000(size=256) memory:d5804000-d5804fff memory:d5800000-d5803fff
*-network UNCLAIMED
description: Network controller
product: RTL8723BE PCIe Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: ioport:3000(size=256) memory:d4800000-d4803fff
graham@graham-HP-ProBook-455-G2 ~ $ gedit /etc/modprobe.d/rtl8723be.conf
The program ‘gedit’ is currently not installed. You can install it by typing:
sudo apt-get install gedit
graham@graham-HP-ProBook-455-G2 ~ $ sudo apt-get install gedit
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
gedit-common
The following NEW packages will be installed
gedit gedit-common
0 to upgrade, 2 to newly install, 0 to remove and 44 not to upgrade.
Need to get 2,980 kB of archives.
After this operation, 15.8 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://packages.linuxmint.com/ rosa/upstream gedit-common all 2.30.5+qiana [2,528 kB]
Get:2 http://packages.linuxmint.com/ rosa/upstream gedit amd64 2.30.5+qiana [453 kB]
Fetched 2,980 kB in 4s (693 kB/s)
Selecting previously unselected package gedit-common.
(Reading database … 177611 files and directories currently installed.)
Preparing to unpack …/gedit-common_2.30.5+qiana_all.deb …
Unpacking gedit-common (2.30.5+qiana) …
Selecting previously unselected package gedit.
Preparing to unpack …/gedit_2.30.5+qiana_amd64.deb …
Unpacking gedit (2.30.5+qiana) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …
Processing triggers for gconf2 (3.2.6-0ubuntu2) …
Processing triggers for mime-support (3.54ubuntu1.1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu1) …
Setting up gedit-common (2.30.5+qiana) …
Setting up gedit (2.30.5+qiana) …
update-alternatives: using /usr/bin/gedit to provide /usr/bin/gnome-text-editor (gnome-text-editor) in auto mode
graham@graham-HP-ProBook-455-G2 ~ $ sudo touch /etc/modprobe.d/rtl8723be.conf

First whilst connected via an ethernet cable, do a full system by running these 3 commands insequence:

sudo apt-get update

then

sudo apt-get upgrade

then

sudo apt-get dist-upgrade

then REBOOT

Once rebooted, can you post the output from:

modinfo rtl8723be

and

lspci -vnn | grep -i net

and

uname -a

and the contents of

gedit /etc/modprobe.d/rtl8723be.conf

[EDIT]

I’m leaving this link here for my own reference
http://forums.linuxmint.com/viewtopic.php?t=204172&f=53
post the output asked for above … do not do anything mentioned at this link yet.

THIS:

graham@graham-HP-ProBook-455-G2 ~ $ modinfo rtl8723be
filename: /lib/modules/3.19.0-32-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware: rtlwifi/rtl8723befw.bin
description: Realtek 8723BE 802.11n PCI wireless
license: GPL
author: Realtek WlanFAE [email protected]
author: PageHe [email protected]
srcversion: B60F970654516A3D2F6FC24
alias: pci:v000010ECd0000B723svsdbcsci*
depends: rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree: Y
vermagic: 3.19.0-32-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 0C:8B:EF:E0:C1:E2:89:E4:D8:99:09:26:11:7A:DA:3B:DF:EB:41:9C
sig_hashalgo: sha512
parm: swlps:bool
parm: swenc:using hardware crypto (default 0 [hardware])
(bool)
parm: ips:using no link power save (default 1 is open)
(bool)
parm: fwlps:using linked fw control power save (default 1 is open)
(bool)
parm: msi:Set to 1 to use MSI interrupts mode (default 0)
(bool)
parm: debug:Set debug level (0-5) (default 0) (int)
parm: disable_watchdog:Set to 1 to disable the watchdog (default 0)
(bool)
graham@graham-HP-ProBook-455-G2 ~ $ lspci -vnn | grep -i net
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
graham@graham-HP-ProBook-455-G2 ~ $ uname -a
Linux graham-HP-ProBook-455-G2 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
graham@graham-HP-ProBook-455-G2 ~ $ gedit /etc/modprobe.d/rtl8723be.conf

AND THIS, MARK IN A DIFFERENT BOX:

options rtl8723be fwlps=0 ips=0

OK, does wireless spring to life if you run:

sudo modprobe rtl8723be

then check the networkmanager icon in the system tray for available wireless networks ?

If so does wireless survive a reboot without having to run that again ?

[EDIT]

And don’t panic we’ll get this working, it just looks like Mint are doing things slightly differently (they may be missing the firmware or udev rule)… not a problem :wink:

That worked! Thanks so much, again! Kind regards.

But does it survive a reboot ?

Oh yes, well pleased!

Great stuff :slight_smile: