HP C7280 wireless printer problem [Solved]

With the assistance of this Forum I have been very successful in using both the HPLIP Device Manager and the CUPS interface for installing HP printers on friends’ computers – until today.
I have a new (i.e. second hand) Toshiba A300D laptop running Ubuntu V12 that steadfastly declines to print print to my HP C7280 printer despite apparently having installed it:
Description: Keith’s wireless printer
Location: Appleton
Driver: HP Photosmart c7200 Series hpijs, 3.12.2 (color, 2-sided printing)
Connection: hp:/net/Photosmart_C7200_series?zc=HPB29F89
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=two-sided-long-edge

The CUPS message is “/usr/lib/cups/backend/hp failed".

I found a reference on the web in which the respondent found that the backend file permissions had been corrupted. I found the file at usr/lib/cups/backend and the file permissions are:
user@A300D:/$ ls -l usr/lib/cups/backend
total 696
-rwxr-xr-x 1 root root 7250 Jul 6 13:16 beh
-rwxr-xr-x 1 root root 138024 Mar 21 2012 bluetooth
-rwxr–r-- 3 root root 18976 Dec 4 15:22 dnssd
-rwxr-xr-x 1 root root 18864 Jul 10 09:37 hp
-rwxr-xr-x 1 root root 9042 Jul 10 09:37 hpfax
-rwxr–r-- 5 root root 64736 Dec 4 15:22 http
-rwxr–r-- 5 root root 64736 Dec 4 15:22 https
-rwxr–r-- 5 root root 64736 Dec 4 15:22 ipp
-rwxr–r-- 2 root root 48096 Dec 4 15:22 ipp14
-rwxr–r-- 5 root root 64736 Dec 4 15:22 ipps
-rwxr–r-- 2 root root 43856 Dec 4 15:22 lpd
-rwxr–r-- 3 root root 18976 Dec 4 15:22 mdns
-rwxr-xr-x 1 root root 18824 May 18 2012 parallel
-rwxr-xr-x 1 root root 14664 May 18 2012 serial
lrwxrwxrwx 1 root root 21 Dec 11 16:53 smb → …/…/…/bin/smbspool
-r-xr-xr-x 2 root root 27296 Dec 4 15:22 snmp
-r-xr-xr-x 2 root root 35536 Dec 4 15:22 socket
-r-xr–r-- 2 root root 31408 Dec 4 15:22 usb

I note Pooky2483’s posting but am still foxed and would be grateful for advice on how to proceed.


sudo apt-get install --reinstall avahi-daemon

and see if that makes a difference.

If not, attach a file with the contents of:
gedit /var/log/cups/error_log
to your next posting.

Sadly not. gedit /var/log/cups/error_log:

E [16/Dec/2012:10:05:12 +0000] Unknown directive SystemGroup on line 16 of /etc/cups/cupsd.conf.
W [16/Dec/2012:10:05:12 +0000] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id ‘C7200-Gray…’ already exists
W [16/Dec/2012:10:05:12 +0000] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id ‘C7200-RGB…’ already exists
W [16/Dec/2012:10:05:13 +0000] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id ‘cups-C7200’ already exists
E [16/Dec/2012:16:54:44 +0000] Avahi client failed, closing client to allow a clean restart

Can you post the contents of

gedit /etc/cups/cupsd.conf

and the output from:


gedit /etc/cups/cupsd.conf is attached

user@A300D:~$ groups
user adm cdrom sudo dip plugdev lpadmin sambashare

Reboot … then fire up the CUPS interface, delete all print queues, then try to print a test page from within the CUPS interface.

If you still get nothing … send the contents of:

gedit /var/log/cups/error_log


are you connecting wirelessly ?

does CUPS find the printer on its own … or are you having to manually add the printer address ?

Still no joy. I get the usual message windows telling me that printing has started then printing has finished, but it lies. And it keeps trying.
I am attempting to print wirelessly (it prints fine via USB).
It does find the printer by itself and I have also tried installing manually, once I’d found the URI.

is the printer in standy … try pressing some buttons on the printer to wake it up … then see if it will print … if that works, let us know as it may be a fixable bug.


Also try going to the CUPS printer “administration” page and click “Resume Printer”


A Dell laptop prints fine wirelessly, but the Toshiba still refuses to do so.
There is no “Resume Printer” command but in in the Jobs tab there is a “Release Job” which appeared to function (a job disappeared) but with no effect.

One thing: The Dell is listed as using “hpcups 3.11.7” whereas the Toshiba quotes " hpijs, 3.12.2" which is what I selected the last time I tried.
Might that be relevant?

Quite probably … there were quite a few changes to CUPS recently.

I’ll see what I can find.

In the meantime I shall have a play…

Is hpijs installed then ? … try uninstalling it:

sudo apt-get remove hpijs printer-driver-hpijs

then make sure hplip is installed:

sudo apt-get install hplip

the try deleting the printer, and setting it up again.

Before your post appeared I removed the printer in CUPS.
I tried searching for printers but it found nothing so then I added it manually using the IP address that appears on the Dell laptop.
A test print request produced a connection error message but the page printed anyway!
I then started HP Device Manager. It found the printer as usual, failed to connect, then the printer appeared in the list and I printed a test page from there too. Again, an error message appeared but the print was OK.

So there is still something wrong, but we’re getting closer.
Shall I continue with your suggestions?

If it’s printing, I wouldn’t bother.

It was only something to try as I noticed I don’t have those (hpijs) installed in Peppermint.

Then again, you could always add them back (though I don’t think they’re necessary) … so up to you.

I’ve just got a feeling you’re using the wrong driver hpijs as opposed to cups.


I did as you suggested. The error message still appears but, as you say, if it’s working that’s good enough.
Many thanks for your help, Mark. I feel I’m becoming a bit more proficient.

…later that evening…rebooted the laptop…printed a document, and there were no error messages.
The solution appears to be specifying manually the printer IP address.

Have you given the printer a static IP … you’ll want to if you’re entering it’s address as an IP, otherwise it will be lost the next time your routers DHCP server gives it a different IP.

Yes, it does have a static IP address. You recommended some time ago that I do that, though I can’t remember the reason.
I’m still not sure why the PC didn’t find the printer by itself, but it’s working well now and that’s the main thing.
Many thanks for your help and advice, which is helping me to become more familiar with the workings of Linux.

Speaking of which, I have another problem…to be continued another day.