HP Envy 7640 detected but won't print

Using ElementaryOS Loki

I used the default printer manager to add a printer. My HP Envy was detected correctly by name as a local USB-connected printer. However when I send it a print job the HP doesn’t print. The LED display on the printer’s control panel says “PRINTING” and a progress pinwheel spins, but no printed output is forthcoming. The printer works perfectly under Windows, however.

Well it should work in Loki as that printer was supported since hplip version 3.14 and Loki should have 3.16.

Anyway, I don’t know much about Elementary, but what GUI application are you using to connect the printer ?

Have you tried installing hplip-gui

sudo apt-get install hplip-gui

then using the menu item called HPLIP Toolbox to set up the printer ?

Elementary has a default printer manager. Clicking on +Add Printer caused Elementary to immediately see the printer and properly ID it. The manager gave me several choices of drivers, and I chose HPLIP since it the printer is a genuine HP. The printer receives some part of the job, but it never prints. I’m wondering if it’s a firmware issue with the printer rather than a driver issue in the OS. Elementary is persnickety about third-party apps. In fact, the repository command is disabled. If it’s not available with apt-get only then it’s not likely to work. Generally, they want you to confine your installs to stuff available through their fork of the Ubuntu app store. I’ll check there for an HPLIP gui.

I also faced a similar problem with my Hp Designjet T795 printer. I have been using it for a long time, suddenly, I have noticed my printer was not working like before. While I tried to print any papers my printer has been giving the unknown message. I tried to figure out the main reason why it happened, but did not get any point. If anyone has any type of idea please share it with me.

Hello Gerald.

I notice that your Hp Designjet T795 has been discontinued by HP and replaced by the DesignJet T1700 Printer series. So your problems might be age-related.
Can you tell us more precisely what the problems/symptoms are? And what tests you have done on your printer?
It would be helpful also if you mention the make/model of your computer and which operating system/version you are using.

I’m no expert on printers but the extra information might prompt others who are more experienced.


Have you checked with CUPS? If you’ve never used CUPS, you access it with a web-browser and the url
There you can look at jobs and often get an error message.

CUPS is a very powerful printer administration facility and David’s suggestion is a good one for the advanced user, but the unwary user can easily make things worse - I know from experience!

Reply #1 to your original post suggested that you install the HP LIP software - have you done that? It is very easy to use and I recommend that you do so.
I’m assuming you are using Linux(!), and details of your computer system would be helpful.