HPLIP in Peppermint 5

I am running Peppermint 5 on a 2001-vintage built-up PC (data attached). It’s running fine, if a bit slow, but it’s a play PC that I shall lend to a friend whilst fixing hers, so speed is not of the essence.

I installed HPLIP as it makes installing HP printers a breeze but fell at the first fence. HPLIP failed to find the Ethernet printer (the PC has no wireless card and I’m too mean to buy one) so I entered the printer network data from my laptop - no joy. Tried CUPS - still no joy. Then had a brainwave (rare these days) and in HP Tool box clicked on “Diagnose HPLIP Driver”. The first part of the output is:

[i]HP Linux Imaging and Printing System (ver. 3.14.3)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: peppermint distro is not found in AUTH_TYPES

Checking for Deprecated items…
error: This distro (i.e linuxmint 0.0) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):[/i]

…and it got worse when I opted to continue

Does this mean that I can’t run HPLIP in Peppermint? Of course I could always plug the printer into the PC, but as my emporium is rather small that would be inconvenient.
So, I would be grateful for advice on what s/w might allow Ethernet control of my printer, if any.


No HPLIP will work just fine … unless of course this is a new printer not covered by the HPLIP version, in which case you’ll need to get the newer version and install it … but you don’t mention the HP model, always a mistake when asking about printers don’t you think :wink:

Install smbclient and avahi-daemon:

sudo apt-get install smbclient avahi-daemon

(these are present by default in Peppermint 4 and 5, but I don’t think they were in 3)

then try again.

or see if “Printers” will auto detect it if you click the “+” (Add) > Network Printer > Windows Printer via SAMBA

Oops! Well spotted, Mark. :-[ The printer is an old HP Photosmart C7280 which works fine on my Peppermint 3 machine - both wireless and Ethernet - and installed via HP Toolbox without problems.
When installing the smbclient, the response is that I have already the newest version, though it did update a few files.

Printer install via HP Toolbox still doesn’t work.
Using Printers/Find Network Printer, entering the host name fails to find the printer.
Using the “Printers/add/network printer/Windows Printer via Samba” asks for an SMB pathname (at least server and printer) which I’m not sure what to put . (But why Windows when I am running Peppermint? )

The printer tells me that the host name is HPB29F89 and the URI is and I have tried these in all my various attempts.
As this is a play PC I don’t mind if you want to abandon it at this point. In the meantime I shall try to get the printer close enough to the PC to try a USB connection.

[EDIT] The printer added easily via a USB connection, but is not then available via Ethernet, of course.

How are youu connecting the ethernet cable

Printer <—> Router <—> PC


Printer <—> PC

and are you SURE this setup is the same as the Peppermint 3 PC’s ?

You might want to try
(maybe replace “lp” with the printer name)
(maybe replace “lp” with the printer name)

What is the PC’s IP address ?

This P5 PC is connected to the router (in the loft) via Ethernet cable. The printer is connected via wireless to the router.
i.e. Router is wireless to printer, Ethernet to P5 PC.

My P3 laptop will drive the wireless printer when I disable laptop wireless and plug in the Ethernet cable. i.e.just what I want to do with the P5 PC.

I tried smb://HPB29F89/lp amongst other things but when asked to select a maker (HP) I can’t go any further as either:

  • I am not able to highlight HP in the “Select manufacturer” screen, or
  • when it does let me select it, the “Forward” button does not do anything.

Network address: From Networks in the menu, my PC (named “dt0”) has an address of

Going into the user accounts to turn off my login password requirement, I discovered that I was not allowed to connect to wireless & ethernet devices! So I ticked that and tried again.
This time I got a bit further but was only allowed to select generic printer options, and the test print failed. I’m trying to get a screen shot.

When you enter the smb address … use the printers IP address, followed by the printer “name”
as in:

and test it with the “Verify” button.

Can you get a printout from the printer that will tell you it’s name.

  • note the edit to my previous post * not that It makes much difference.

The only printer name that the printer supplies is its host name: HPB29F89. I tried that again as per your suggestion, then “verify” but the response was “Print Share Inaccessible. Connection refused”.

[EDIT] I have got a bit further. In Add Printer, I selected “Enter URI” and this time added http:// prefix to the URL and got all the way to finding the right printer type (HP Photosmart c7200 Series, hpcups 3.14.3) but upon Print Test Page received the message: “Processing - The printer is not responding.”
[EDIT 2] Tried URI = hp://net/Photosmart_C7200_series?zc=HPB29F89 as shown on my P3 laptop.
Upon Print Test Page, the Printer State displayed: Idle - Rendering completed but there was no output.

Are you able to browse to other PC’s on the network

In file manager, go to
Go > Network

Are other PC able to see the Peppermint 5 one on the network ?

Go>Network: Both computers list only “Windows network” which doesn’t exist, of course.

I can ssh from the P5 PC (dt0) to my P3 laptop (D505) but when I try it the other way round I get:

keith@D505 ~ $ ssh keith@dt0 ls
ssh: connect to host dt0 port 22: Connection refused

Does the phrase “Connection refused” mean that the P5 PC (dt0) did receive the ssh request and returned a refusal, or simply that nothing came back?

Go>Network: Both computers list only "Windows network" which doesn't exist, of course.
If you are using samba instead of nfs then Windows network [b]IS[/b] the samba shared network :D

Thank you Sezo. I’m sorry to say I am in the dark about networks. Do I understand that Samba and nfs are both network software? If so, then why is Linux using a Microsoft product? Or have I got it quite wrong?

What happens if you double click the “Windows Network” icon ?

can you post the output from:

ping -c 5

P5 PC:
double-click Windows icon: two errors

[ol]- Specified location not mounted

  • Failed to retrieve share list from server: No such file or directory.[/ol]

Ping: Successful. 5 packets with ttl=64

P3 laptop:
double-click Windows icon:
Failed to open “Windows Network” Failed to retrieve share list from server.

Ping: successful.

Do you have anything shared in Windows?

Also, maybe I’m confused, but how is this relavent for fixing the printer?

I promise you I have nothing Windows-related in my home!
The issue began (hence the title) with not being able to run HPLIP. Yes, I could wire the printer to the PC but my small home is not easily reconfigured so I prefer to use wireless, and HPLIP is normally great for installing HP wireless printers. I could install another Ethernet point at the printer but the novelty of DIY is beginning to pall.

I feel we are getting too far off-topic, so here is an update:
This morning I tried to run Mint 17 from a live disc prior to installing it as a dual boot, in order to see if it worked any better than P5 on this elderly machine. This resulted in a message:
Running in software rendering mode
Cinnamon is currently running without video hardware acceleration…
There could be a problem with your drivers or some other issue. ……

I have a feeling that this machine is simply not an appropriate vehicle for modern software and that I am taking up everyone’s time unnecessarily. Since much of the peripheral kit is reasonably newish I shall look into obtaining another motherboard and start again.

Many thanks for everyone’s contribution,

When you say you installed “HPLIP”, did you install hplip-gui too ?

Oh, yes. And HPLIP appears to be working except for not finding the printer wirelessly. It finds it alright when I plug it into the USB port.

[EDIT] Perhaps this might be a clue. In an earlier post I said:
Going into the user accounts to turn off my login password requirement, I discovered that I was not allowed to connect to wireless & ethernet devices! So I ticked that and tried again.
And it turns out that I still have to enter my password at login - so if it’s ignoring the password bit it may be simply ignoring my selection of being able to connect to wireless & Ethernet devices. Except that I can use the Ethernet…oh, well, just a thought.



then select "Network/Ethernet/Wireless network connection (direct connection or jetdirect) … and hit “next” … is it discovered ?

if not, try connecting with a USB cable, then Run:


then select “Wireless/802.11” … then click next.

If there’s still an issue with not finding it, is it worth looking at the CUPS log? Or doesn’t anything get written there at this stage?

The Ethernet option is the one that I have been using (and tried it again without success) - I hadn’t tried the temporary USB method for this problem as as I had no success with previous PCs/printers.
However: The USB method did find the printer and the printer reported a very strong wireless signal - but it still declined to connect to it. I attach a screen shot of the message.