I can't seem to install a new bootloader...

Hi everyone,

On my netbook (Archos 10), I have installed Ubuntu 13.10, Meego 1.2, Joli OS 1.2 and Ubuntu 12.10 (don’t know why). They’re all pretty slow and I needed a fast OS, something that I can just quickly boot up to and get on with doing whatever needs to be done. So I stumbled across Tiny Core Linux. I put it on a LiveUSB and it is INSANELY quick. So I went to install it using the tc_install package that was there and, it installed. But when I went to restart the computer to load TC, an error message appeared saying ‘Missing operating system’. So I can’t access any of my files. Great. I can now only use my netbook from a LiveUSB (which I am doing). I thought that I would have to install a new bootloader, so i tried, and failed. Grub2 came up with an error which has been discussed by someone else on the TC forums and is hopefully being fixed, I have no idea how to install Grub 0.97, LILO is literally IMPOSSIBLE to install, I tried making the lilo.conf file but I couldn’t get my head round it, BURG isn’t even available, and grub4dos looks like it’s for Windows, I can’t find any Linux tutorials for it. After this, I tried installing another operating system that definetly does have a bootloader that will work, so I tried Linux Mint 14 (Cinnamon) and I installed this in place of Ubuntu 12.10. The installation went seemingly fine, until I restarted the computer and the dreaded message appeared : ‘Missing operating system’ I am still literally baffled by this and don’t know why it won’t work, and my brain just went into panic mode. I tried using the recovery option that was built in, I don’t know why I thought THAT would help, but still, it said ‘Missing operating system’. I have really no idea what to do now, is it possible to get my stuff back? (if it isn’t, then that’s not too much of a problem, my important files are in the cloud, but it’ll be a real bugger getting all my OSs back…) Please please please help me!! Sorry if there’s a really obvious answer, I’m still a bit of a Linux beginner. All replies are greatly appreciated, this is my only hope!!



Hi colorend, and welcome to the forum :

Boot to your LiveUSB, open a terminal, and post the output from:

sudo fdisk -l

or depending on the distro …

fdisk -l

run as root.

Sorry, I have no idea how to actually copy the text over in tiny core, so i took a screenshot instead.

And weren’t you in the Peppermint Forums as well? That avatar looks so familiar…

Yeh, I help out at Peppermint too :slight_smile:

Oh ****, I hate it when there are multiple Linux OS’s … makes fixing GRUB much harder

Don’t suppose you know which OS is on which partition ?

Or just where ONE of the Ubuntu ones is located and which version it is ?

If not we’ll have to mount them and try to work it out … rest assured though, it looks like your data is still there :slight_smile:

Argh, sorry!

Meego is on /dev/sda2, and I THINK that one of the Ubuntus is on sda5, but I could be wrong… Sorry about that…

Have you got an Ubuntu LiveUSB ?
(same version as one of the installed Ubuntu versions)

Not at the moment although I have three liveUSBs which all have different OSs to what I have installed. I do have the Ubuntu 13.10 iso on my computer at home, but I’m not home right now… So I’ll make a liveUSB with Ubuntu when I get home.

I have a LiveUSB with Ubuntu 13.10 on. What next?

Meego is on /dev/sda2, and I THINK that one of the [b]Ubuntus is on sda5[/b], but I could be wrong...
If it is indeed sda5 then you could try to reinstall the Ubuntu grub to sda: (as Mark indicated here) Boot to a LiveUSB of Ubuntu

When at the desktop run these commands in sequence:

sudo mount /dev/sda5 /mnt


for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done


sudo chroot /mnt


grub-install --recheck /dev/sda



now hit Ctrl+D to exit the chroot environment … now REBOOT to the HDD (not the LiveCD/LiveUSB) to test.

You may also need to check the bootable flag as it is set now to sda11 (is that intentional)

Firstly, are you sure you mean 13.10 … did you get it from daily builds ? (as 13.10 isn’t out yet)

OK, lets find out if sda5 is 13.10

Boot to the 13.10 LiveUSB and run:

sudo mount /dev/sda5 /mnt

now post the output from:

cat /mnt/etc/lsb-release

Thanks, your instructions worked, apart from the fact that Ubuntu is on /dev/sda10… (update-grub told me so) but there were no errors apparently, so I’ll test the HDD.

And it worked!!! (yay!) Although it seems that Ubuntu 12.10 is still installed when I thought I installed Linux Mint Nadia on top of it when in fact I installed it somewhere else. And Tiny Core isn’t there, but I’m not surprised, it was a pretty messed-up installation.

Thanks guys for your help!

And yes it was the Daily Build, or the ‘development branch’

And now I have the problem of installing Tiny Core. Do I use the tc-install package that is provided in the TC repos and if so, which features do I use? And which bootloader do I use and how to configure it?

[EDIT]: If it’s really difficult and pointless, I could just install DSL instead

Aint got a clue about TC … but install it without a booloader and let GRUB from Ubuntu pick it up by with:

sudo update-grub

run from within 13.10

Okay or I may just install DSL instead, it gives options to install with GRUB or LILO, but what’s the difference between a frugal and a full install?

So which partition did you use to install grub? was it sda5 or sda10?

Whichever you chosen then the distro installed on that partition controls the grub setup.
Whenever you install any new OS (just skip grub install) all you have to do is to update grub in your designated distro. :slight_smile:

As for a lightweight distro you could try #! CrunchBang and see how fast you can go…

Full install = A complete install where the hard drive is partitioned and the files extracted from the compressed ISO image to the hard drive.

Frugal install = Installations of a bootloader, and the copying of the compressed image to an already existing partition (even a windows one)

So a frugal install is more like a LiveUSB but running from the HDD … kinda thing.

Oh full sounds better then. And yes I have tried Crunchbang, quite a while ago, but I had no idea how to install it! Maybe Linux Mint will be replaced with Crunchbang; thanks for reminding me about it! All sorted now. Thanks for all your help! :slight_smile: