I made the bootable USB, but I have one issue.

My 4GB USB device arrived yesterday. 4 tries, and many programs later, I was able to actually burn the iso to the drive. I know a lot of people recommend Etcher, and it was the very first one I tried. What happened was it told me that the burn had ‘failed’ despite the fact it was a brand new USB device. So, I ended up downloading some programs, and discovered some were only able to do windows USB flashes, those that didn’t care what I was burning somehow failed. I eventually got to RMPrepUSB, by which time 200MB had inexplicably vanished from the maximum capacity of my device, don’t know how, I formatted the device between each attempt. Somehow it worked (despite saying that an extraction had failed). I now have an ubuntu USB bootable device.

It loaded just fine, and I took a look around, it looks great, feels fast and responsive, my computer fan isn’t going quickly like it normally does, so I don’t even have to know how to check CPU use, to know that much less CPU power is being used (my baseline in windows is 33% taken up before I so much as open firefox). Okay, it’s definitely nothing like Windows, but it doesn’t feel as alien as I thought it might. It would probably take me a good few days of exlusively working in Ubuntu to adjust to it, but once I know where everything is I’d probably be okay.

What worries me though is that it suddenly froze. I don’t know if this is because I was looking around without installing yet, or if it was because of the extraction failed message I got at the end of the burn, or if it was because it needs a driver installed or something. I don’t know. I had to switch my computer off and remove the device to get myself back to windows, and I’m not sure I was supposed to do that with the device still being inside the port. Has anyone else had this issue?

I’ve changed my bios settings obviously to allow me to boot from USB as the primary option, I won’t bother changing this because when I install on my second (2TB) device which should arrive on my doorstep within the next couple of weeks, I am using this method as the means of choosing which OS to boot into. That makes it quick and easy for others who use this computer to just load windows up as they usually would if they find it too difficult to adjust at first. They have until next Jan to get used to Linux because once 8.1 comes to it’s end of life I do not intend to use Windows any more, and the HDD will be replaced.

All in all, at first glance this looks like a nice OS, it doesn’t seem like it is going to put any strain on my computer whatsoever (which was my main worry, I needn’t have worried), and as an added bonus, there isn’t a deluge of bloatware to uninstall! Seems my 4GB RAM is more than enough, although I have discovered that I can buy 8GB RAM chips for this computer, and it’s not as expensive as I feared it might be, although I am not sure if it is possible to upgrade the processor, I’d like to because having the extra power would be handy. I’m thinking about the video editing work I want to do, which my computer struggles with currently (at least with windows it does), but it might be different when running Linux. Eventually I want to have a better computer altogether, but at the moment I can’t afford it so I’ll stick to upgrading what I have to be the best it can be.

I know a lot of people recommend Etcher, and it was the very first one I tried. What happened was it told me that the burn had 'failed' despite the fact it was a brand new USB device.
I know a of of people recommend Etcher, and it has many useful facilities, but perhaps not the best one for a beginner. Anyway, you have RMPrepUSB which you are happy with, except that the "extraction failed" message is probably important. Significantly; RMPrepUSB does not appear in the Linux Repositories, but UNetbootin does which makes it a recommended application.
What worries me though is that it suddenly froze. I don't know if this is because I was looking around without installing yet, or if it was because of the extraction failed message I got at the end of the burn
Running any OS from a USB will always be slow but freezing looks like it might be related to your "extraction failed message" message.
I eventually got to RMPrepUSB, by which time 200MB had inexplicably vanished from the maximum capacity of my device, don't know how, I formatted the device between each attempt
No, it hasn't disappeared. When you delete files from a USB device, it puts them in Rubbish Bin [b]on the USB device[/b] not the one on your computer. (Why this is the case is left to the student as an exercise). To see what's happening, start Windows, insert the USB device and in the file manager select View Hidden Files. You should then see a directory named something like [b].Trash[/b]. Open this and you might find two sub-directories called something like [b]files[/b] and [b]info[/b]. These contain your deleted files which are occupying your lost space. To delete them, highlight them as usual but now press [b]Shift+Delete[/b]. Not just Delete, or they will simply re-appear.

Incidentally, 200MB does seem rather a small amount of memory for an operating system, so the warning message you had is probably real!
If you have any doubts, I recommend that you install Unetbootin for Windows and use it to download Ubuntu (it offers many Linux OSs) and burn the USB all in one go.

I’m pleased that you like Ubuntu and hope that you persevere.

Well, I just ticked the box to show any hidden files, and according to Windows there aren’t any at all, not even a .trash bin.

I also think you misunderstood what I meant. The OS isn’t taking up 200MB, I’d know immediately that there was a serious problem given that even very old operating systems such as 98SE and XP take up more than that. The 200MB is space that is missing, not space taken up by the OS.

There is 883MB free of 3.72GB (should be 4GB here, not 3.72).

This means that the OS is taking up a little less than 3GB of space, and that out of the original 4GB that the USB device originally had, 280MB is unaccounted for and just… gone. Is this the correct size of the install or do I need to re-do things? I did try UNetbootin, and then tried to use the drive and it sadly my computer booted me straight back into windows (this was after I’d changed the order in bios, so I know it wasn’t that kind of silly mistake). After examining the USB stick, I noticed that all of the files and folders were there, but contained 0B. No wonder it booted nothing, there was no data there to boot!

Honestly, I’ve had loads of problems trying to burn this thing properly, and I don’t like making mistakes, or programs not working as they should. Could it be a problem with the iso itself? I ask because for a few programs to fail me is unusual. Perhaps I should re-download to be sure, just in case there was any issue with the original download. I can’t see why there would be, but anything is possible and I suppose I should rule that out.

Could it be a problem with the iso itself?
Yes, it could be. Did you check the MD5SUM after downloading it?

No, I didn’t. What is that? and how would I check it?

You can get the Ubuntu file’s checksum from the site from which you got the iso. The checksum is calculated from the iso and it’s a pretty reliable way of seeing if there’s an error in the download. Windows 10, like Linux, will generate a checksum, but the old versions of Windows will need a small program to do it: MD5 & SHA Checksum Utility - Free download and software reviews - CNET Download

Okay, just run the program, and the string of letters and numbers for MD5 (and the other three rows) all say ‘hash matched’ when I copy and paste them into the box provided. I take it this means that the iso is good?

If everything says “hatch matched” that would suggest the ISO is ok. Regarding the size of the USB, it shows the exact size of how much data you can put on it. 3.7Gb is about average for a 4Gb USB stick, 7.3Gb for an 8Gb stick, etc. Nothing has actually disappeared. Also don’t worry about the “trash” bin, not all systems create that, some do, some don’t.

As for burning software I’ve used both Balena Etcher and Rufus on Windows, and haven’t had any problem with either. If I remember correctly didn’t you previously comment on how cheaply you could get a USB stick? What brand is it? Could the USB stick itself be not up to scratch?

The freezing I’m not sure about, depends on what you were doing at the time. The thing with running a system live from a USB stick is that you’re running the whole thing from RAM, and sometimes it can be not enough, although I would have thought 4Gb RAM as sufficient.

Also, as you’ve had to make a number of attempts to burn the USB, how have you deleted things between each attempt? Formatting doesn’t always work properly.

I found a program that showed me what Windows couldn’t… there are invisible partitions. So my space hasn’t vanished at all, it’s still there but hidden from view (even with the show hidden files box ticked) I think what happened was that when I was flashing the drive, each time it made a new small partition for some reason. I now have the option of deleting these and formatting the whole thing to begin again. So like, when I was formatting it, I was only formatting the big partition and the small ones remained there.I didn’t realize that could happen, or that Windows would be unable to see partitions. At least that confusion is now cleared up. I don’t know why windows couldn’t see it…

Yes, my USB stick was cheap (around £3), and it isn’t any particular brand, just a generic device. I don’t tend to pay the extra for branded stuff because its generally only paying for the name and wasting money (much like branded clothing or food that costs more, than the supermarkets own make). My big one that’s on the way (to function as my second hard drive) was only £7. I don’t think my price point is the issue, it was just invisible partitions causing missing space.

That makes sense. As the previous partitions were for Linux they’re probably EXT4 format, or something like that, and Windows won’t recognise such things. Probably best to clear everything and start afresh, and see if the issue with freezing has gone away. If it hasn’t and it freezes again, make a note of exactly what you were doing at the time, it may help in diagnosing the problem.

By the way, I agree with your comments on branded goods, although no doubt there’s the odd exception.

Okay, that makes some sense why Windows doesn’t recognise partitions on the USB, it can’t tell me about what it is unable to see.
So yes, I’m going to do total clean wipe and start again. Hopefully I will not get the same error. I also think I might have made a mistake in the first place. I should have formatted the drive BEFORE trying to flash it for the very first time, because I have no idea if it was in the FAT format or not.

I might also take a closer look at Linux Mint this time, because I’ve seen the general layout of Ubuntu now. Main reasons, The recommended system specs for Mint cinnamon desktop are lower than for Ubuntu, which would leave me more system resources for video editing and actually running programs. I’m planning to upgrade my RAM to 8GB from the current 4, however this will be a few weeks away, and so far as I know, there is nothing at all I can do about my processor. It’s a dual core 2.1GHZ which is decent, but again it’s nothing special but perfectly fine for general use. I also think that others will find the transition easier with the desktop layout, because it’s a very windows-like environment where everything is just where you’d ordinarily expect it to be. I’d be absolutely fine using Ubuntu given a few days getting accustommed to where things are, but my daughter and my ex partner might find it confusing. I need them to get used to Linux in some form, because once Windows 8.1 comes to end of life, I do not plan to continue having Windows, my hard drive (if it is still functioning) will be wiped and Linux installed there too.

It’s my understanding that because Mint is a derivative of Ubuntu, most of the same apps are available, is this correct? Like, I’d still be able to install steam and use WINE for the one program for which I need it? I’m beginning to wonder what the smartest move here actually is. I thought I’d decided, but then discovered I haven’t made up my mind as solidly as I thought I had. I never thought choosing would be so hard.

I can’t speak from experience as it’s a long time since I used Ubuntu, but from what I’ve read on various forums I get the impression that Ubuntu has become a little bloated and heavyweight in recent times. Not heavyweight when compared to Windows 10, but certainly heavyweight when compared to other Linux Distros. Mint I have used recently, and I would say it is definitely lighter than Ubuntu, and therefore less strain on your PC’s resources. And yes, you should be able to run all the same apps in Mint as you can in Ubuntu.

Choices? I know, there are loads, and I got a bit overwhelmed with it all at one point. If you search for “Linux suitable for beginners” you’ll find that Mint is often near the top of the list, so a good starting point. In fact there is a post somewhere that lists a number of reasons as to why Mint is more suitable than Ubuntu for beginners, but unfortunately I can’t remember where I saw it.

A few replies.

You don’t need to format the USB before converting it into an installation medium. The iso file is an image of n optical disk and it’s dumped onto the usb stick regardless of how it’s formatted. The result is that the usb now has the ISO 9660 format and to your computer it looks like an external DVD.

Mint generally has the same things available as Ubuntu — it’s been described as “Ubuntu done properly”. The chief exceptions are that Mint removes anything that it considers spy-ware or a possible security risk.

The Gnome GUI used by the standard Ubuntu is the most demanding one available, which is a bit odd considering it has fewer facilities that its competitors. Mint’s Cinnamon, Mate, or Xfce are far less heavy. You should not need 8 GB in Linux, unless you are going to do things like editing large videos. I have 4 GB and currently, with a browser and office suite running, 1 GB is used for software, 1 for caches and buffers, and 2 are unused.

To be fair, I will be doing some video editing, but nothing too extreme. The kind of videos I am doing is basically putting a short intro first (around 8 seconds), followed by screen recorded footage and the audio for the remainder of the video is me talking. Basically I’m doing pixel art tutorials to show people how to make their own tilesets (and eventually the music) for RPG Maker instead of using the runtime package which comes with the program. The videos are going to be quite variable in length, and I do know that windows suffers when I try to do the screen recording and do the actual final version of the video in an editor. I’m not doing anything too fancy and no special effects, just splicing my intro onto each video, and maybe cutting out some little pieces such as me opening and closing the screen recording program. So, I only need quite a rudimentary video editor, which is why I so miss windows movie maker (last seen in windows XP as part of the optional live essentials pack) and ended up using minitool moviemaker because it was the lightest option available and worked just like the old movie maker. Screen capturing software also packs a punch RAM wise, I went with OBS studio, which I know also exists for Linux, so it is definitely worth me upgrading it. If it is more than I need it doesn’t matter, so long as I don’t have less than I need. I need to find a video editor for sure, but for screen capture I know I am going to be fine.

I wasn’t sure if I had done something wrong with my USB, but all things considered I am better off removing the partitions, format, and start again. I want to put Mint cinnamon on it so I can more properly explore that one. I’ve seen a lot of videos about this one in youtube and to be honest I think it might be the better option for my family due to the layout of the desktop being so similar to what we’re all already used to, and and better for my computer considering what I would like to use it for. Ubuntu looks great too, but for video editing I want as much RAM and CPU available to me as possible on my limited resources, so Mint might be the better option. I might just about get by with my 4GB RAM, given that it’s going to be significantly lighter than Windows is. I’ll see how I get on with it, because only experience is going to tell me whether I am going to actually need the extra RAM or not. If I do, it should be easy enough to install it, all I have to do is remove the old chip and insert the new one, can’t go wrong.

I can’t wait for my 2TB stick to arrive, if everyone else in the house gets along with Mint just fine, I can go ahead and say bye bye to Windows 8.1 and install it on my main hard drive (or I might just get a proper SSD because I am unsure about my hard drive health, and SSDs are supposed to be less fragile than traditional hard drives anyway), no more blue screens of death ever again.