Install Firefox 4 on an Acer Aspire One running Linpus Lite Linux

This topic is now outdated… there are now instructions for installing Firefox 7 here:

Install Firefox 7 on an Acer Aspire One running Linpus Lite Linux


If you HAVEN’T already installed Firefox 4 by following the instructions AFTER this EDIT, the full instructions for the newer Firefox 6, can be found here:

If you HAVE already installed Firefox 4 following the instructions below, you can miss out most of the steps… all you should need to do to upgrade FF4 to FF5 is:

wget -O firefox-6.0.tar.bz2 ""


sudo tar -jxvf firefox-6.0.tar.bz2 --directory /opt


sudo chown user -R /opt/firefox

Close all instances of Firefox 4, and restart it… it should now be Firefox 6


WARNING - DO NOT uninstall Firefox 2 prior to installing Firefox 4… on Linpus Lite this will break your system, removing Firefox 2 will also remove a lot of necessary dependencies, including half of your desktop… simply reinstalling Firefox 2 will NOT fix this… so leave Firefox 2 alone, and just follow the instructions below… none of which are irreversible :slight_smile:

Instructions modified and updated to Firefox 4.0.1… thanks to gecko_03 :slight_smile:

To install Firefox 4.0.1 on an Acer Aspire One that is running Linpus Lite Linux as it’s operating system…

All commands given need to be entered into a terminal… to open a terminal, hit Alt+F2 … in the input field enter terminal and click the Run button… a terminal will open.
(also remember Linux commands ARE case sensitive so enter exactly as shown, or even better copy and paste)

First, just in case you already have a newer version of Firefox installed than the version that came pre-installed on your AA1, run the following command to back it up:

sudo mv /opt/firefox /opt/firefox-backup

(don’t worry if the above command fails, it just means you don’t have a newer version)

Now use wget to download Firefox 4:

wget -O firefox-4.0.1.tar.bz2 ""

(you can change the en-GB language variable on the end to any of the other language codes for FF4 that can be found HERE)

Extract the just downloaded file to /opt … create a plugins directory … change the /opt/firefox directory owner … rename the original firefox shell script (just in case you need to start the original firefox from the command line)… and add a symlink to point to Firefox 4

sudo tar -jxvf firefox-4.0.1.tar.bz2 --directory /opt


sudo mkdir /opt/firefox/plugins


sudo chown user -R /opt/firefox


sudo mv /usr/bin/firefox /usr/bin/original-firefox


sudo ln -fs /opt/firefox/firefox /usr/bin/firefox

Now, link all old plugins to the new firefox/plugins directory:

sudo ln -s /usr/lib/mozilla/plugins/* /opt/firefox/plugins

Next you need to put a copy of in the /opt/firefox directory… Firefox 4 requires this file to be installed on your system but it isn’t available in the linpus lite repos… so use wget to download it from my dropbox:


and unpack it directly into the /opt/firefox directory:

sudo tar -jxvf libstdc++6.tar.bz2 --directory /opt/firefox

Launch Firefox’s profile manager:

firefox -profilemanager -no-remote

Create a new profile… you can name it anything you like… and select it.

As a bonus you can also change the icon to the official Firefox icon. (though this isn’t necessary)

sudo sed '/Icon/ s/acs_//' -i /usr/share/applications/linpus-web.desktop

Finally reboot the AA1 to make the desktop aware of the new icon and browser location.

Most of the credit must go to macles.blogspot:
I’ve just modified the instruction slightly for FF4, and added the file (from fedora 10 32bit) which is needed by FF4.

For instructions on how to upgrade the flashplayer plugin, see here:

Also see:

:slight_smile: what a great and easy to follow step by step guide thanks. if a newb like me can follow it then it must be good

Thanks for the feedback… it’s always good to know these things helped someone. :slight_smile:

I try’d firefox 4 on windows XP.
and things that I use’t to use are gone?
and it is acting up.
got look at the firefox forum.
it is still a Bata I think.
and Microsoft has there claws in to firefox!
god help us!
so if I was you I would wait till they fix it.
I am Staying with firefox 3.6.0

Firefox 4 has been out of beta for a while now, and the final release seems every bit as stable as 3.6 and MUCH quicker…

Rather than being alarmist, it would be helpful if you told us what problems you DID have ?

If the issues were ONLY in the beta ?

If it was ONLY in Windows ?

If it was on an AA1 ?

and what you mean by -

“Microsoft has their claws in to firefox! … god help us!” ?
“things that I used to use are gone” ?

Do you mean some of the plugins were incompatible with FF4 when you tried it ? … if so, which ones? and how long ago?.. so people can check to see if they have been updated yet.
Now Firefox 4 is a final release, most plugins will be quickly updated if they haven’t been already.

These instructions were brill. I have 2 Aspire one netbooks for my kids which we’ve been unable to use since January as the browser was out of date. We clicked on the icon and the wheel just turned and did nothing. Using these instructions - I’ve now updated both machines and kids are able to get on the internet on their favourite sites once again. Thanks so much for the step by step guide… really really useful!

I’m happy the guide was a help… there is a separate fix for Firefox 2 refusing to start:
But as Firefox 2 is a bit long in the tooth and has trouble with some sites now, you’re probably better off with Firefox 4 anyway.

BTW, if anyone has problems with websites that contain flash video, let me know and I’ll post instructions to install or update the flash player to the latest version.

I tried to upgrade from 3.6 to 4 simply pressing the upgrade key on the Firefox web site, result - disaster, web browser would not start and reported I/O Error. Being Linux ignorant, (my ferreting finished with CPM) it was a case of throw the Aspire away or find an expert. Found your solution via Google on my Windows desk top, copied the lines of code into a text file on a memory stick and plugged it into the Aspire, executed the code line by line and it was fixed, wonderful. You saved my bacon, many thanks keep up the good work.
PS I registered simply to be able to thank you.

You are more than welcome… and thanks for letting me know it helped :slight_smile:

Many thanks to you for the instructions. My wife’s netbook is up and running and she has the Firefox 4 to work with. A great Mother’s Day gift.

Always happy to help a mom :slight_smile:

Also for me the instructions proved very helpful…thank you!

Just two small amendments:

  • the download link for Firefox does not work any more as the newest version currently is 4.0.1. I have used
wget -O firefox-4.0.1.tar.bz2 ""

to download the German version.

  • in order to be able to link all plugins to the new Firefox directory, I first had to manually create the /opt/firefox/plugins directory

@ gecko_03

Thanks for the info… much appreciated ;D … instructions updated … but with the GB (English - British) version of Firefox 4.0.1

Again, many thanks.

Many thanks for the code to make this work. I copied and pasted as suggested by another member and it worked a treat. I had to do the same using Macles’ code when moving from version 2.4 to 3.1. What is it with Linpus and/or Mozilla that makes a simple version change so complicated? I’d have been completely stuck without your help. Just as well I only use Linpus Linux for the netbook and had a Windows PC to find your site. Don’t know what we newbies would do without experts like yourself willing to help. I guess the user unfriendliness of Linux is the price we pay for the excellent security of the Linux O/S that is so poor by comparison in Windows.

Firstly… You’re welcome :slight_smile:

Secondly… It’s NOT that Linux “as a whole” is unfriendly… IMHO, nowadays it’s just as user friendly as Windows (more so if you take into account that you don’t spend half your time wrestling with malware), just different… but Linpus Lite is based on a very old version of Fedora (FC8 which is no longer under active development or support) so software moves on, but Linpus Lite doesn’t.

Installing FF4 on most other distro’s such as Ubuntu or Mint, or even Fedora 14 is as simple as a few mouse clicks.

Linpus Lite has Fireefox 2 intertwined with the desktop as it uses a custom desktop, which means if you remove it, you will also remove half of your desktop… not clever :wink: … so Firefox 4 has to be installed somewhere else, then have all the links pointed to the new FF4 directory rather than the old FF2 directory … that way you don’t loose your desktop.

It wasn’t overly clever of the Linpus Lite devs to build it this way, but it is NOT a Linux issue, it’s a Linpus issue :slight_smile:

Please don’t think for one minute that Linux = Linpus Lite.

I’m not really sure why Acer decided on Linpus Lite when their are MUCH better Linux distributions available. ::slight_smile:

Yes, I’d heard that Linpus Lite was pretty limited, but I’d never had any problem with updating Firefox version 3 once the Macles code gave me a working “check for updates” button. I didn’t expect version 4 to be any more complicated to install than updating version 3 but obviously a new version is rather more than an update so this was perhaps a rather naive view on my part.

Incidentally, what has happened to the update button in version 4? It used to be under the “Help” tab in version 3 but seems to have disappeared.

WARNING - Linpus Lite users that are still on Firefox 2, DO NOT attempt to upgrade Firefox in the following way, use the instructions at the top of this topic, here:

This posting is JUST a response to the above question, and should NOT be used as a means of updating Firefox 2 to Firefox 4 on Linpus lite… it may even break your system.

No idea… but from “now on” (once you’ve first installed Firefox 4 using the instructions at the top of this topic) when a new version of FF4 comes out, you can just download it, and unpack it directly to the /opt/firefox direcory (letting it overwrite the files that are already there) and you’ll be good to go :slight_smile:
(this should not erase your bookmarks/passwords/plugins etc. as those databases aren’t contained in the download, so can’t overwrite the ones currently in the /opt/firefox directory… but as usual, backing them up first is always a good idea)


In FireFox 3 there was a “Check for Updates” menu item under the “Help” menu.

In FireFox 4 that menu item is gone.

To update (an already installed version of) FireFox 4:
Click the Help menu.
Select About FireFox… This should automagically check for updates and prompt you if there is an update available.

Or so I gather… I more of a Chrome user myself :wink:

Apologise i am a real novice - tried to follow your excellent instructions to install Firefox 4 and failed miserably.
Now my browser doesnt work at all. this is what happened:-

1st command - ‘connection refused’

2nd command - firefox4 appeared to download ok

the next 5 commands up to ‘link all old plugins to the new/plugins directory’ all gave ‘connection refused’ response

At this point I closed the terminal and shut down.

now I have the desktop, things like Skype work ok, but no browser!

is there a way to get back to Firefox 2? or maybe start again?

would appreciate your guidance, may thanks

Go through the instructions again, and let me know what happens… you can’t do any damage going through them again if that’s what you’re worried about. :wink:

It was a good idea to ask first though :slight_smile:

But WHATEVER you do, DO NOT uninstall or reinstall Firefox 2… worst case scenario, we should be able get Firefox 2 back, though I’m a bit puzzled by the “connection refused” errors.

For information (this is straight from the macles.blogspot) -

“In some cases a connection refused error message may be triggered by sudo, which is not an error but a bug in sudo and can be safely ignored.”

thanks for the reassurance - following instructions as follows

1st command line - this is what happens:-

audit_log_user_command(): Connection refused
mv: cannot overwrite non-directory ‘/opt/firefox-backup/firefox’ with directory ‘/opt/firefox’