Install Firefox 7 on an Acer Aspire One running Linpus Lite Linux

Those who have ALREADY upgraded your version of Firefox 2 to Firefox 4, 5, or 6 by following the instructions here:
see the “How to UPGRADE FF4, FF5, or FF6 to Firefox 7” section at the bottom of this posting.

[u][b]For those who HAVEN'T upgraded to Firefox 4, Firefox 5, or Firefox 6, and are still running Firefox 2 ... read on.[/b][/u]

WARNING - DO NOT uninstall Firefox 2 prior to installing Firefox 7.0.1 … on Linpus Lite this will break your system, uninstalling Firefox 2 also removes a lot of necessary dependencies including half of your desktop… simply reinstalling Firefox 2 will NOT fix this… so leave Firefox 2 alone, and just follow the instructions below… none of which are irreversible :slight_smile:

To install Firefox 7.0.1 on an Acer Aspire One that is running Linpus Lite Linux as it’s operating system, and Firefox 2 as the web browser…

All commands given need to be entered into a terminal… to open a terminal, hit Alt+F2 … in the input field enter terminal and click the Run button… a terminal will open… When the terminal opens, enter the following commands (hitting Enter after each command to ‘run’ it)
(also remember Linux commands ARE case sensitive so enter exactly as shown, or even better copy and paste).

First, just in case you already have a newer version of Firefox installed than the version that came pre-installed on your AA1, run the following command to back it up:

sudo mv -v /opt/firefox /opt/firefox-backup

(don’t worry if the above command fails, it just means you don’t have a newer version)

Now use wget to download Firefox 7.0.1:

wget ""

(Non en-GB versions can be found here:
but you’ll have to adjust the wget command accordingly … if you’re unsure how, just ask)

Extract the just downloaded file to /opt:

sudo tar -jxvf firefox-7.0.1.tar.bz2 --directory /opt

Create a plugins directory:

sudo mkdir /opt/firefox/plugins

Skip the next command, and continue after the “END EDIT” if you don’t want Firefox to automatically update itself … most people have reported major issues with Firefox 8 and above in Linpus Lite.

Change the /opt/firefox directory owner to user:

sudo chown user -R /opt/firefox


Rename the original firefox shell script (just in case you ever want to replace it):

sudo mv /usr/bin/firefox /usr/bin/original-firefox

Add a symlink to point to Firefox 7.0.1:

sudo ln -fs /opt/firefox/firefox /usr/bin/firefox

Finally , link all old plugins to the new firefox/plugins directory:

sudo ln -s /usr/lib/mozilla/plugins/* /opt/firefox/plugins

Ok that’s Firefox 7.0.1 installed :slight_smile:

As a bonus you can also change the icon to the official Firefox icon. (though this isn’t necessary)

sudo sed '/Icon/ s/acs_//' -i /usr/share/applications/linpus-web.desktop

Finally reboot the AA1 to make the desktop aware of the new icon and browser location.

Don’t forget to upgrade the flashplayer following the link below or pages that contain flash may take forever to load.

For instructions on how to upgrade the flashplayer plugin, see here:

How to UPGRADE FF4, FF5, or FF6 to Firefox 7

First try this … In Firefox, go to Help > About Firefox and see if you are offered an automatic Update … if not, read on.

If you already have a working Firefox 4, Firefox 5, or Firefox 6 installation at /opt/firefox … All you need to do to upgrade it to Firefox 7 is to open a terminal and run these 3 commands:

wget ""


sudo tar -jxvf firefox-7.0.1.tar.bz2 --directory /opt

Close all instances of Firefox, and restart it… it should now be Firefox 7.0.1

By FAR the best piece of advice I can give AA1 users who are still using the Linpus Lite operating system would be …

It would be a good idea for readers of this topic to give seriously consideration to switching from the AA1’s default OS (Linpus Lite) to something like PeppermintOS (Three), which is a more up-to-date OS that is still (unlike Linpus Lite) receiving security and software updates … it also has access to ALL the latest software (as it’s based on the Ubuntu 12.04 Long Term Support release) and will receive automatic updates for 5 years, it also has a desktop environment more like the Windows one.

Click the following link for further information, and an installation tutorial:
Tutorial - Installing PeppermintOS Three on an Acer Aspire One AOA110L ZG5

It’s my OS of choice for an AA1, and beats Linpus Lite “hands down”.

This tutorial was written and tested on an AA1 kindly donated by Kath C so it could be used to help other AA1 users … thanks Kath :slight_smile:

Hello Mark
Your step by step instructions on upgrading firefox seemed to be the godsend I have been praying for these past 5 or 6 months.
After the prompt
[user@localhost ~]$
I typed in the code, checking carefully to make sure I made no errors. However, when I pressed ENTER after sudo tar -jxvf firefox-7.0.tar.bz2 --directory /opt I got this message:
audit_log_user_command(): Connection refused
However, a lot of lines followed, starting with
and ending with
I typed in the next line, after the prompt sudo mkdir /opt/firefox/plugins and I got the reply
auit_log_user_command(): Connection refused

What am I doing wrong? What does this Connection refused mean?


You are doing nothing wrong … this is a well known bug in the version of sudo used in some versions of Linpus Lite (as used on the AA1).

The good news is that for the vast majority of people the “Connection refused” error can be ignored, as the command is carried out anyway … so just carry on with the instructions.

If they don’t work, come back here and I’ll help you through it :wink:

Hi Mark.
I ignored the Connection refused comments, and carried on, and to my utter delight Version 7 of Firefox has been successfully installed. Thank you so much. I was beginning to despair of ever getting my favourite apps back working on my AA1. I’m really grateful to you.

You’re most welcome :slight_smile: … be sure to upgrade the flashplayer to version 11 too … instructions linked to in the Firefox 7 tutorial … or here:

Then things like Youtube videos, BBC iPlayer, and Flash games (Facebook etc.) should work in Firefox too :slight_smile:

Oh my goodness, thank you so much for this! I thought I was going to have to throw my much loved & elderly aspire one in the bin after FF8 & my attempts to get rid of it very nearly killed it!!!

Yuo’re very welcome :slight_smile: … and thanks for letting me know it helped.


Thanks for your brilliant instructions. I have installed Firefox 7 and Flash Player but now my shutdown won’t work. When I click on the icon, nothing happens. Please help.

I’ve solved the problem! I used the shutdown command in terminal and re-booted. I now works!


Have you got any room left on your SSD ?

open a terminal and enter:


hit enter, and post back what is returned in the terminal:

also send the output from

df -i

and the output from:

ls ~/

[user@localhost ~]$ df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sda1 152799040 3130988 141906252 3% /
none 252364 0 252364 0% /dev/shm
none 152799040 3130988 141906252 3% /mnt/home
[user@localhost ~]$ df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/sda1 19415040 87502 19327538 1% /
none 63091 1 63090 1% /dev/shm
none 19415040 87502 19327538 1% /mnt/home
[user@localhost ~]$ ls ~/
? ?? Downloads
amsn_received ff.tar.bz2
beas picture.png firefox-7.0.tar.bz2
DataCardGKU flashplayer11-32bit.tar.gz Music
Desktop Image_00000.jpg Pictures
Documents Image_00001.jpg Videos
[user@localhost ~]$

Although I think I’ve solved the problem, this is what came up after your instructions.

So is the problem solved ? … what was it ? … just in case it helps others in the future :slight_smile:

The shutdown icon wouldn’t respond after the installations. I searched for a solution and found the shutdown command shown below.

I copied it into the terminal and it shutdown.

I re-booted and all was normal again.

Thanks anyway for your swift response.,

sudo shutdown -h now

Oddly enough I was going to suggest that next … believe it or not :wink:

Thanks for that though … even though I’m confident the Firefox 7 installation and your shutdown issue are unconnected, it’s worth having the solution here just in case it helps any future readers who find themselves in the same boat :slight_smile:

Hello again Mark


  • like it has completely screwed up my browsing experience
  • which is such a shame after all the help you gave me to rescue my Acer from the bin!

Will your instructions work for a fool like me who upgraded to 8?

(Pity the Forum won’t let you search for ‘Firefox 8’ - it insists in a min of two characters in a search item)

The forum will search for the TERM “Firefox 8” if you surround it with quotation marks, otherwise it searches for two separate words, ‘Firefox’ and ‘8’ and the word ‘8’ is too short :wink:

Yes, just follow these instructions again and Firefox 8 will be replaced with Firefox 7 … and if you skip the “chown” command it will not auto update in the future :slight_smile:

:frowning: i have followed the code to update ff2 to ff7 on linus lipus (on an acer aspire one), intially I got to the bottom of the code listing ok, but ff would not start when clicking on the desktop icon. I attempted to re type the code in, but know after sudo tar -jxvf firefox-7.0.tar.bz2 --directory /opt I get the following:
bzip2: (stdin) is not a bzip2 file.
tar: child returned status 2
tar: Error exit delayed from previous errors

Can you advise? thanks

Did you reboot before testing Firefox from the desktop icon ?

Can you open a terminal and run the following commands, and post back the output from each of them.



ls -a /opt


ls -a /opt/firefox


ls -al /usr/bin/firefox


ls -al ~/firefox-7.0.tar.bz2


Thanks Mark. I hoped that would be the case but thought I had better check before I dug myself into a hole…

Worked brilliantly. I am now back to slick Firefox 7 browsing and no more system hangs with Firefox 8. Must remember never to upgrade without checking here first!

Hi Mark, I tried to follow your instructions and everything semed to go as expected but after re-booting and hitting the browser icon. nothing happens. I tried to repeat the process and the same thing happens. Any ideas? or could you guide me through backing out the upgrade process to get back to ff2? Any help would be much appreciated.

Rgds, Joe

@ Joe45

Can you too open a terminal and run the following commands, and post back the output from each of them.



ls -a /opt


ls -a /opt/firefox


ls -al /usr/bin/firefox


ls -al ~/firefox-7.0.tar.bz2

Then I should be able to tell where things went wrong with the Firefox 7 installation … it would be better to fix Firefox 7 than go back to Firefox 2

if it will make things easier, you should still be able to run Firefox 2 by entering this in a terminal:


But if you REALLY want to go back to Firefox 2, this can be achieved with the following command:

sudo ln -fs /usr/lib/firefox- /usr/bin/firefox