Install meross AC600 usb wi-fi adaptor.(resolved)

Running pepermint 8 64bit. this adaptor comes with a CD inclueding drivers for Linux.

Instalation instructions are a little vage.

Using Script for PC-Linux
For driver compilation and installation in PC-Linux, we provide an
script to do the duties automatically. If you want to use our Wi-Fi solutions to access
network on PC-Linux, you can just run script and then control Wi-Fi with
utilities such as Network Manager. For further information about Wi-Fi station mode,

Q. how to run script?

I take it this is a USB wireless adapter ?

Before we go attempting to install any (possibly unnecessary or wrong) drivers, can you plug in the device and post the output from:



sudo lshw -C network


iwlist scan


rfkill list

usertwo@usertwo-R59P-R60P-R61P ~ $ lsusb
Bus 001 Device 003: ID 0bda:a811 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
usertwo@usertwo-R59P-R60P-R61P ~ $

usertwo@usertwo-R59P-R60P-R61P ~ $ sudo lshw -C network
[sudo] password for usertwo:
description: Wireless interface
product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 01
serial: 00:1b:9e:66:a1:b6
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath5k driverversion=4.10.0-37-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:17 memory:d8100000-d810ffff
description: Ethernet interface
product: 88E8039 PCI-E Fast Ethernet Controller
vendor: Marvell Technology Group Ltd.
physical id: 0
bus info: pci@0000:05:00.0
logical name: enp5s0
version: 15
serial: 00:13:77:5c:61:02
size: 100Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 duplex=full ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:27 memory:d8200000-d8203fff ioport:a000(size=256)
usertwo@usertwo-R59P-R60P-R61P ~ $

usertwo@usertwo-R59P-R60P-R61P ~ $ iwlist scan
lo Interface doesn’t support scanning.

wlp2s0 No scan results

enp5s0 Interface doesn’t support scanning.

usertwo@usertwo-R59P-R60P-R61P ~ $

usertwo@usertwo-R59P-R60P-R61P ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
usertwo@usertwo-R59P-R60P-R61P ~ $

We could attempt to install the drivers that came with it, but I doubt they’ll be dkms which means they’ll likely break whenever you get a kernel update (if they install at all).

So let’s try some dkms packaged drivers first eh ?
(the dkms version of the drivers should recompile automagically when you get kernel updates)

Connect to your router with an ethernet cable and run these commands in sequence:-

sudo apt-get install dkms git


mkdir ~/RTL8812AU


cd ~/RTL8812AU


git clone


cd ~/RTL8812AU/rtl8812AU_8821AU_linux


sudo make -f Makefile.dkms install

then load the driver with:

sudo modprobe rtl8812au

did wireless spring to life ? (you’ll need to disconnect from the ethernet cable and set up wireless from the networkmanager system tray icon).

Or REBOOT and see if wireless now works ?


I’m not suggesting you do this yet, I’m just posting the instructions to uninstall this driver “just in case”

cd ~/RTL8812AU/rtl8812AU_8821AU_linux


sudo make -f Makefile.dkms uninstall

then reboot.

OK worked like a dream…

Many thanks for your help.

You’re most welcome Tramlink :slight_smile:

Even working on 5G network.

Great stuff :slight_smile:

Any chance you can link to where you got it in case anyone else wants one ?

is this the adapter:

Yes this is the adaptor I installed.

Thanks Tramlink :slight_smile:


or if it needs elevated privileges:

sudo /full/path/to/

Hi, I followed the instructions to install the abperiasamy/rtl8812AU_8821AU_linux.git package but get this error when I try to build:

make[2]: *** /lib/modules/4.4.38-v7+/build: No such file or directory. Stop.

I’ve tried installing the headers several times but there’s no ‘build’ directory:

martin@pi/rtl8812AU_8821AU_linux$> ls /lib/modules/4.4.38-v7+/
kernel modules.builtin modules.dep.bin modules.softdep
modules.alias modules.builtin.bin modules.devname modules.symbols
modules.alias.bin modules.dep modules.order modules.symbols.bin

Any suggestions? TIA!

Is this a RasPi ? … which distro/version ?

Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial

oh, and Raspberry Pi 3 model B V1.2

what’s the output from:

uname -a


ls -a /lib/modules


ls -a /lib/modules/$(uname -r)