Install peppermint 3 on acer aspire 3050

hi for all and sorry for my bad english…

I have install peppermin 3 on acer aspire 3050 and at the end of this proces I’ ve reboot my pc but… black screen :frowning:

I’ve reboot on live usb and mount /dev/sda, reinstall grub but when restart I’ve this error

The screen that was blank and shows the following information:

error: file not found.
grub rescue>

what’s the problem?

In live mode when mount sda in the left colum (file manager) I’ve one folder called “peppermint”

OK, chances are you’ve broken the GRUB bootloader

We can fix it, but it may be quicker just to reinstall Peppermint 3.

The black screen after installation may have been caused by the graphics driver … adding nomodeset as a kernel boot parameter would probably have fixed the issue.

Now GRUB is broken, it may be easier just to reinstall then set momodeset.

How do yyou want to go about this ? … reinstall, or try fixing GRUB ?

reinstall no problem… I’ve just attempt reinstallation but during installation at “hardware check”, I’ve gray screen and pc are frozen… force reboot and grub error

edit I’ve try installation with nomodeset parameter… now at “hardware check” black screen with a color square in the center :frowning:
probably video driver… workaround?

and why the live mode is perfect ?

You’ve confused me now :wink:

Boot to the LiveCD/LiveUSB, and select “Try Peppermint” … once at the desktop, click the “Install Peppermint” icon.

When installed, restart … THEN add the nomodeset kernel boot parameter.

I’ll post how in a sec.

Once you have Peppermint 3 installed …

OK, the following instructions are for a single boot ONLY … so you’ll have to do this EVERY time you boot … but if it works, we can automate the procedure.

Turn ON your laptop, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu … SIMILAR to this:
(you won’t have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST … ie. immediately after turning on your PC)

Select the ‘default’ kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… so add nomodeset as in the above screenshot … so it now reads:

[b]quiet splash nomodeset[/b]
(doesn't matter if it moves down a line, as long as there is a space between splash and nomdeset)

Now hit Ctrl+X to boot.

If nomodeset doesn’t work … try replacing nomodeset with:-



radeon.modeset=0 blacklist=radeon

If this works, it will only work for a single boot and will need re-applying at the next boot … but if it solves the issue, we’ll make it permanent :slight_smile:

Thx for your replay… Now the problem is during installation when the systems “check the hardware”… Black screen with color square and pc frozen :cry:

You’re not setting any kernel boot parameters during the install are you ?

it installed before … so what are you doing differently ?

could it be the LiveCD or CD drive ?

could this be a hard drive issue ? … have you tried formatting the hard drive (from the LiveCD) before installation ?

I’haven’t set any parameters during the install, also during the FIRST installation some problem (the installation was not completed successfully… in the FIRST installation I’ve force reboot on black screen… then error grub), installation has never been successful…

I’ve start live session and start install with the desktop icon, I’ve test 2 CD and 2 USB key some problem (md5 iso is ok)… I think this isn’t a hardware problem because the other distro (lubuntu, debian, arch…) work correctly and I’ve tried formatting hard disk before install (whith gparted from live cd peppermint and other distro)… I think is a problem with video driver during installation (black screen during the step called “hardware check” approximately 90 percent installation bar progress)… there is another way to install this distro or some kernel parameters to set for pass this step?

Which version of Lubuntu worked ?


Can you try the install again, and when it hangs at “Checking hardware” can you hit Ctrl+Alt+F2 to drop to a console.

if the console asks you to login … try

Username: peppermint

Once logged on, run:


are there any clues about what’s causing the installation to stall ?

[EDIT 2]

After googling for a while, the Aspire 3050 used to need the acpi=off kernel boot parameter … setting this may get Peppermint installed, then we can either upgrade the kernel to whichever kernel the working Lubuntu version used, or set acpi=off permanently.

fantastic!!! installation is successful but I did not understand why … the only different is that I have installed without network cable plug…

but… now when boot peppermint logo appear (oh yeah) but after black screen :cry:

more help? kernel parameters?


yes yes yes ;D I’ve added nomodeset in grub menu with your istructions and work !!!

now, how do I make the change permanent ??

OK, to make it permanent … open a terminal (Ctrl+Alt+T) and run:

sudo cp -v /etc/default/grub /etc/default/grub.backup


sudo gedit /etc/default/grub

Find the line that reads:-


Change it to read:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset”

SAVE the file and exit gedit.

Now back in the terminal run:

sudo update-grub

When that’s finished … reboot to test.

ok work perfect !!! many many thx