Installing Laser software on Linux Peppermint (Solved)

Hi Mark ,
I added this post to another that I had made but I thought it better to start a new thread.
I was told this is how to get the T2 laser engraving software to work in Linux.
I don’t seem to be getting anywhere with it and would like to know if you can have a look ?
I really need simple (really simple) instructions as I would dearly love to run on my Linux computer, at present I am running on a Win 10 computer and I am sure I am breaking out in spots and boils :wink:
I have purchased the software to run on the Windows machine but I will purchase another copy if it will run in Peppermint.
Can you help ??

Don W

I don’t know about T2, but have you looked at Laser Web 3?

Thanks for the info arochester. I will have a look at those in the meantime.

I had a look at the LaserWeb site and it looks ok.
I have been using the T2 software on a Win 10 computer and it does what I want in Vector mode only.
When I try a Raster drawing the results are useless, even worse than useless. >:( >:(
The image in the X axis takes some major shifts and I feel that the Y axis doesn’t move in the correct increments all the time, major problems.
I really would rather have the software on Linux as I am happier using this computer. My Win 10 computer only has 1 working USB port and it has to be dedicated with the laser driver so I have to use the touchpad, something I totally abhor.
I am waiting on a new 5A power adaptor for the laser as the present 3A is maybe a bit weak in power to drive 3 stepper motors and the laser. That should arrive today from Amazon.
I will have another look at Laserweb while I am waiting and let you know, but I hope Mark will arrive soon and save the day (again)

Don W
EDIT I have already made a muck up by having 2 threads around the same subject. I have been to the other thread and marked it (Solved)
Confused ?? you will be.

Running this in WINE will likely mean it has no access to USB … is USB necessary ?

Yes Mark,
It needs a dedicated USB to drive the Arduino board, it uses a CH340 driver that is supplied with the software.
Does this help. ? If this is a problem I can I get a copy from someone who runs the programme in Linux albeit with a lot of manipulation I don’t know much about. I could get a copy of his instructions forusing Linux if that will help. No rush, I am looking into setting and using LibreCad at the moment.

Don W

I’ve personally never had much any luck getting USB to work in WINE … that said it’s been a long time since I tried, I haven’t used WINE in ages.

Have you got a link to the Linux native instructions, so I can take a look ?
(if they’re private, PM them to me)

Thanks Mark,
I have set up the laser engraver using my grandsons Win 10 computer.
Unfortunately it only has 1 usable USB port so I have to use the touchpad, something I hate.
It is working ok but needs a lot of setting up to get the engraving just right.
I am going to close this thread and add the Solved to the start.
Thanks for your help

take care
Don W
PS I am about to start another thread :wink:

Okay Don :slight_smile: