Installing new printer

I have a new Epsom printer XP 3155 that I wish to add to my Linux Mint desktop. I tried add printer, but it does not show up, so I contacted Epsom help and they stated that they do not have a specific driver/software for Linux, but they could give me a generic package. epsom-inkjet-printer-escpr-1.7.18-1lsb2.i.486.rpm. I have downloaded this but the link they gave me also states this;
In order to install these drivers, you need to install LSB package (version 3.2 or later) beforehand.

Ubuntu: # apt install lsb
Fedora: # yum install lsb
openSUSE: # yast --install lsb

I entered “apt install lsb” into terminal but it did nothing
Am I being completely dumb, is this something already installed or have I not entered the correct command.

After installing the lsb package, is installing the Epsom package straight forward?

I have now installed the lsb package through terminal. Now how do I install the Epsom package?

What you’ve got is a package for Linux distros which use rpm packaging, which Mint doesn’t. Luckily, there’s a solution. The package alien will convert your rpm into a deb, which you can then install:

I suppose we should be grateful that Epson provides anything for Linux, but it does show why most of us but HP instead!

Hi David, thanks for the reply, I have installed the alien essential build package but now unsure how to convert it. I have entered;
sudo alien epsom-inkjet-printer-escpr-, pressed enter typed in password and it states package not found.
The package is on the desktop, what have I done wrong?

I used to have an HP printer, got so fed up with it, refused to remember the network, printed one document then opened another tried to print but it kept printing the previous document, had to run HP repair tool before every use. In the end decided to ditch it and get an epson.

I guess Alien is looking in a default location for the .rpm file (possibly Downloads or Temp).

sudo alien Desktop/epsom-inkjet-printer-escpr-

but David will know the right answer.


It depends on where your downloads wind up. Mine, and I suspect yours, go to the Downloads directory, so you’d need

sudo alien Desktop/epsom-inkjet-printer-escpr-

Hi guys, I noticed I spelled epsom instead of epson, but either way when I type in the command terminal states fille cannot be found

I think Dave intended to write

sudo alien Downloads/epson-inkjet-printer-escpr-

Worth a try.


Not working, but I have now found an online file converter and have converted it to a deb file. So it is on my desktop, so how do I install it?

Hi guys,

Well, someone suggested right clicking on the package and selecting open with GDebi package installer, tried this, entered my password all seemed to be going well then I get the error message “Packet operation failed” then I get “Failed to completely install all dependencies”.
prompted to run sudo apt-get install -f, I run this and it removes the package. Where do I go from here?

Hi Guys, I’m getting there, got the epson package installed, added the printer then pressed print test page. The dialogue box came up saying that the page had been printed, but it did not print. Hope there is an easy fix now I have got everything installed. Any suggestion guys?

If you run a web-browser and enter the address localhost:631 that gets you talking to CUPS — the Common Unix Printer System. There you can sometimes get useful explanations of what’s happened to a job when nothing came out. It’s also worth reading the trouble-shooting section of the printer manual.

PS Sorry about the mistake earlier: I copied Keith’s entry to correct it and forgor to do so :-[