Internal mic not working in my UBUNTU 11.04 (64bit) in my DELL STUDIO 1435

I have UBUNTU 11.04 installed in my DELL STUDIO 1435.
I am facing problem with internal mic,it is not able to capture any sound.It was not working in 10.10 as well. I i have been using the external mic for the voice recording and video chat/ skype.
I read a solution by Mark where it was suggested to to make some adjustments in volume control (pavucontrol) making left 75 and right 0. I tried it but still intenal mic cannot capture any sound.
I have attached few files.
Also i have modified the alsa-base.conf as:
options snd-hda-intel model=dell-m6-dmic

Please let me know if u have any solution for this. If u want any report or screen shot let me know again.

Thanks in advance for your time.

Try changing the line you put in /etc/modprobe.d/alsa-base.conf from:

options snd-hda-intel model=dell-m6-dmic


options snd-hda-intel model=6stack-dell

(You may also want to put your volume controls back where they were in pavucontrol… If memory serves, that fix was for an acer aspire one)

If it doesn’t work, can you send the output from:

sudo lshw -C multimedia


sudo aplay -l


cat /proc/asound/card0/codec#* | grep Codec


lsmod | grep snd

Hi Mark,
options snd-hda-intel model=6stack-dell worked.
Thank a lot for the fix.
Finally i can get rid of my external mic…
Once again thanks.


You’re welcome, and thanks for letting us know it worked… feedback is always helpful to others that may come across the same problem :slight_smile:

Hi I am using ubuntu 11.04 in my laptop lenovo G570.
My internal mic is still not working… Please help me…

Hi ssindiya, and welcome to the forum :slight_smile:

OK, a quick Google suggests a possible fix so we’ll try that before getting the codec info and searching for Intel HDA options.

Open a terminal and run:

sudo gedit /etc/modprobe.d/alsa-base.conf

Gedit should open a text file with a ton of stuff in it … if it opens a blank fille, close it WITHOUT saving and try again, you must have made a typo.

In the file that gedit opens … scroll to the very bottom, and create a NEW line that reads:-

options snd-hda-intel model=asus

SAVE the file and exit gedit.

Now REBOOT and test yourt internal mic. (it’s important that you reboot before testing).

If that doesn’t work, open a terminal and run:

cat /proc/asound/card0/codec* | grep Codec

and post the output back here

and remember Linux commands ARE case sensitive.