Keyboard and mouse problems [solved]

Hello Folks,

I’ve been running Xubuntu 18.04 for a very long time with no problems, but recently the mouse and keyboard keep freezing and I have to push the reboot button on the case to get them back.

Any ideas please? Is anyone else experiencing this? Could it be a recent update?

Thanks for any suggestions. Seems weird to be here knowing that Mark won’t be among the first responders…


Do you know if its a Kernel panic (completely unresponsive), or can you do the shutdown key-combs?

Press and hold the Alt and SysReq (aka PrntScr) keys and then slowly type r e i s u o

But I’d also consider running a memory test - you should find MEMTEST during the bootup sequence, or part of most/any live distro - or just download the free copy from


Do the mouse & KB freeze at boot-up or later? If the latter; how much later?


Hello folks,

Sorry about the delayed response - life keeps getting in the way!

They usually freeze just after boot up but in time to stop me from inputting my user password. I seem to remember it happening once after I’d been working for a while but can’t remember how long it took.

I think it’s completely unresponsive but I didn’t know that combination caused a shutdown. I’ll try it next time.

By the way, I upgraded to Xubuntu 20.04 but it’s still happening.

Why r e i s u o?
This article explains it well:

Upgrading to Xubuntu 20.04 might not help an existing s/w fault, so no surprises if the freeze is still happening. Have you considered a complete re-install?


Thanks Keith,

I’ll try memtest first, complete reinstall as last resort.

If the problem doesn’t happen too often I can sort of live with it, at least for a while. I just wondered whether it was a known problem.

Come to think of it, it could also be a motherboard problem. One of my front USB ports has stopped working, and the mouse is USB (plugged in at the back). I’ll dig out a PS2 mouse or a PS2/USB adapter and try that route…

A friend once had a problem with wired contacts dropping off the motherboard when she mistreated her desktop. Might be worth checking, although USB cables are generally very tight.


Hi, could be hardware, but it’s always worth checking /var/log/syslog and /var/log/kern.log around the time the machine crashed to see if there is anything system or hardware related mentioned in any context. That aside, memory is always a good thing to check, but in this weather, also temperature. Internal fans are always subject to failure which can result in overheating.

If you don’t have it already installed, “lm-sensors” is a good package to have, once installed “sensors-detect” will set things up. Then you should get something like this, which should give you an idea of whether your machine is running hot;

$ sensors 
Adapter: PCI adapter 
Tdie:         +33.5°C  (high = +70.0°C) 
Tctl:         +33.5°C  

I’ve just noticed that Ubuntu isn’t installing “smartmontools” by default, this is also a good one to have. Unlikely to cause this issue but it’s always worth keeping an eye on your storage, for example;

$ smartctl -A /dev/sdc 
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.4.0-80-generic] (local build) 
Copyright (C) 2002-19, Bruce Allen, Christian Franke, [url=][/url] 
SMART Attributes Data Structure revision number: 16 
Vendor Specific SMART Attributes with Thresholds: 
  1 Raw_Read_Error_Rate     0x002f   200   200   051    Pre-fail  Always       -       1 
  3 Spin_Up_Time            0x0027   178   170   021    Pre-fail  Always       -       4058 
  4 Start_Stop_Count        0x0032   100   100   000    Old_age   Always       -       172 
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0 
  7 Seek_Error_Rate         0x002e   200   200   000    Old_age   Always       -       0 
  9 Power_On_Hours          0x0032   004   004   000    Old_age   Always       -       70656 
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0 
 11 Calibration_Retry_Count 0x0032   100   100   000    Old_age   Always       -       0 
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       172 
192 Power-Off_Retract_Count 0x0032   200   200   000    Old_age   Always       -       85 
193 Load_Cycle_Count        0x0032   200   200   000    Old_age   Always       -       86 
194 Temperature_Celsius     0x0022   106   098   000    Old_age   Always       -       41 
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0 
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       0 
198 Offline_Uncorrectable   0x0030   100   253   000    Old_age   Offline      -       0 
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       0 
200 Multi_Zone_Error_Rate   0x0008   100   253   000    Old_age   Offline      -       0

Again, in this weather, worth keeping an eye on #194, different drives have different temperature tolerances and best-case for running ‘hot’ is that it’s likely to decrease you drive’s life expectancy.

I still have memories from the early 90’s of responding to a technical support request listing an apparent CPU lockup which wouldn’t correct itself with a power cycle. On opening up the machine I found that the CPU fan had failed (well, my best guess) which had caused the CPU to get so hot the entire plastic CPU assembly (and fan) had melted and become a puddle of plastic covering the middle of the motherboard. Heat kills! :frowning:

Thanks again guys for the useful information.

I’m waiting for the problem to re-occur so I can try some of your ideas. So far the system is behaving itself…

I doubt it’s heat related though. There’s a single SSD in the box. No HDDs.

I’ll install im-sensors and smartmontools though, and check.

Sure, if all your fans are running, heat shouldn’t be an issue … but chips typically don’t run from cold for more than a minute or two without a working heat-sink / fan, so any sort of failure in that department can easily be terminal … :slight_smile:

Me again!

The fans are running fine, but I had a re-occurence of the problem yesterday. It seemed to be a kernel panic. Keyboard shortcuts didn’t work.

I ran Memtest which showed no errors.

Just now I booted up and the keyboard didn’t work, although I could move the cursor, but clicking had no effect. A restart got me running but my ethernet connection was resolutely offline. A change of cable fixed that and cast doubt over the faulty motherboard theory!

It’s an old rig and I’d hapilly replace it with a nice new SFF box, but the thought of all the research into which combinations support Linux makes me want to sit in a corner and rock… I used to enjoy that kind of stuff, but these days I’d just like the hardware to work!

Anyway, I’m monitoring the situation.

Ok, for what it’s worth;

I’m still using this unaltered … probably average of 8h/day but runs 24x7 … had exactly zero problems with it … using KUbuntu :slight_smile:

Hello Mad Penguin,

Thanks for that and apologies for the late response. Truth is, everything has been behaving itself recently so it slipped my mind.

The rig in your link looks interesting. I’m tempted to replicate it as closely as possible and hopefully have a faster, more reliable computer. Mine dates back to 2007/8 so it’s done it’s bit. I fancied a smaller form factor than ATX but I can live without it. I’ll try to source the components and let you know what happens…

I built the Mad Penguin’s combination for a friend and was very impressed. A bit slower to boot up than I expected but everything else was fine. I would have been better to buy a new box for it (skinflint) but chose to use the old one, so the front-panel audio had the wrong plug types - and I had to buy a new PSU as all plug types have changed in the last 20 years. Starting again, I would replace everything.


Hello Mad Penguin,

I’m now shopping for the motherboard and processor you recommended. The processor is available on amazon but says 6 cores (12 threads). Is that the same one you used?

Also, which of these motherboards would you say is the one you have? Search results for "asus rog strix b450-f gaming atx motherboard, amd" |

Thanks for any help…

Keith, can you throw any light on this please? Mad Penguin seems to be otherwise preoccupied. I hope he’s OK…

Hi Mike.

The motherboard is the first one: AMD B450 - Motherboards AMD |
And yes; that’s the processor -
I built up a PC to MP’s specs using these components and was very pleased with the result. The cooler is silent! but the flashing LEDs on the board are for boy-racers.


Thanks Keith,

I think I’ll go ahead with this, but what’s with the single PS2 keyboard/mouse connector? And are there onboard graphics? Either the tech specs are a bit garbled or I’m a bit older and dafter than I thought.

I haven’t built a PC for over a decade and everything seems to have changed…

I actually bought the Ryzen 5 2600 rather than the Ryzen 5 2600X. I don’t think there is any practical difference but you might like to look at AMD Ryzen 5 2600 vs. AMD Ryzen 5 2600x: Which CPU is best for you? | Windows Central.
This CPU does not come with built-in graphics so you will need a separate graphics card. I bought the Nvidia Geforce GT710 - not that I know anything about graphics boards - but it works very well. CPUs with built-in graphics tend to prevent you using one of the two m.2 SSD slots on the motherboard, though I can’t remember why.

Don’t bother about the PS2 business - I suggest you buy a wireless mouse/keyboard combination that uses a USB dongle. I bought a Jelly Comb K041 Ultra-Thin 2.4Ghz Wireless Keyboard/mouse because it had the same layout as one I am familiar with. It is a joy to use and I recommend it. There is one on eBay today for ~£17 - bargain: Jelly Comb’s website is

I haven't built a PC for over a decade and everything seems to have changed...
Don't tell me about it! When building this PC I discovered that all the connectors have changed since I last built one and I had to buy a new PSU, and the front audio block had the wrong connectors, too.

Do let us know how you get on.

As far as I know, all AMD Ryzen processors have Radeon graphics. Personally, I’d say they are overkill if you aren’t a games player. The computer I got last year has an AMD A6-9500, with a Radeon 5 core, and is fine for me. If your are a gamer, steer clear of Nvidia — not Linux-friendly.

The single PS/2 connector is there for hard-core gamers with expensive keyboards which still use it for for multikey-rollover. These days most mice and keyboards are usb. I’d never get a wireless keyboard — the fewer batteries I have to buy the better. If you are short of usb ports — not a common problem these days — you can get an adapter to run a usb keyboard or mouse off a PS/2 port for £3.