Kinda desperate for help/advice etc...

Hi each,

I really have no idea where to start! other than I just want to have Linux on one of my laptops.
I have a few laptops all have win (lose) XP on them, sadly (but probably quite well known to you all) XP doesnt let you do much in the way of "Cool stuff", and the only platforms that seem to are DOS and Linux. Im not exactly Dense in the head, but I program in Machine code for the Z80 cpu, and have learned a little C++, as well as being competent in ASM and BASIC (I prefer machine code though).
so now having said (typed) that, I confess to being a complete and utter dunce when it comes to Higher level langs and OSs. Right, now all that backgrounds out the way, Ill try explain my plight to you, please dont make fun of me though, I really want to learn some More!

I realised last night that I needed Linux (to do the afore mentioned"cool stuff"), Unbuntu was suggested to me, so I tried it.

yeah, I`m here!

what the Duece went wrong???

every single thing Iv tried has screwed up royally, and now I have 3 laptops with files everywhere, errors galore, and only a part success on machine that wasnt even intended! (it got some sort of “hd 0,0 blah blah error” after I selected unbuntu).
currently Im waiting 40+ minutes for "installing CD boot helper" on the intended machine. its already altered my DLs (downloads) folder icon to a 4 colored square thingy, all my ISO images off my other laptop when copied onto mem stick to put on the target machine Magically" turn into Winrar packed files again? Non of my 3 tried laptops will recognise a blank CD, so I cant do the burn CD thing.
the USB bootable exe thing only has “Quit” as an option, and WUBI, asks for a reset (I oblige) and it also does nothing, well… other than change my DL`s icon.

I`m having a Really bad day here!

all I want is All trace of windoze GONE! and a Brand new Linux installation, and Id like to do it myself, rather than give it to my mate (hes good at this sort of thing).

Sigh as I type, “an error occurred: Could not retrieve the required installation files”. This is what I`m up against :frowning:

Ok, step by step;

  1. Download Ubuntu 11.04 desktop edition, burn to CD
  2. Insert into Laptop, boot, select “Try” rather than install, just to make sure it works on your laptop before you wipe it
  3. If it looks Ok, double click on the “Install” icon on the desktop

If you can do this, then tell us at which stage it fails and specifically what error you get, we should be able to help …

OK, let me get this right…

a) you can’t use CD’s or DVD’s.
b) these laptops can’t boot from USB stcks.
c) WUBI is doing funny things to your Windows directories.
d) WUBI is failing to download the ISO image, so cannot continue.

a and b … Erm, that’s certainly going to make installation difficult … have you got an external USB hard drive, and can your system boot from that ? … or have you got a USB hard drive “enclosure” you could put the laptop hard drive in, then attach it to a system that DOES have a working CD drive ?

c … Where did you get WUBI ? … the ONLY changes it should make to Windows, is to create a directory, append itself to the windows boot menu, leave a single file in the root of your C: drive, and make a single edit to the registry… so if it’s changing “other stuff”, it’s either infected (from your machine, or from source), or you have MAJOR Windows problems.

d … If WUBI is having problems downloading the Ubuntu ISO image, it is possible to manually download the image yourself, then put it in the same directory as wubi.exe… then run wubi.exe… now WUBI should use the local ISO image rather than download it.

A WUBI installation isn’t going to get rid of Windows though… it installs Ubuntu INSIDE Windows.

Indeed, that about sums it up nicely, but yes, I DO have an external HDD, and in fact it was installing linux to it last night that got me the nearest success! well… at least up until the hd0,0 something 32 error, that I since learned is something called grub?
yeah, i`v no idea what that is it either.

Ill be completely honest though, im not entirely sure that i want something that only works Inside of a windoze box, Im really hoping for a complete fresh install of a linux ONLY system, Im mentally committed (oK, that didnt quite come out right!) to Installing rather than "trying" it, in for a penny, in for a pound kinda thing. and the only way to learn is jump in at the deep end, So its Linux or Bust :wink:

no seriously, im getting really rather jaded with billy gates and his rubbish, its time for a change!

Edited to add: I got the WUBI file from the unbunto site packed in a winrar file.

Did you do a “proper” (non-wubi) install to the external drive, or was it through wubi ?


Is there anything on the external drive you can’t afford to loose… I’m wondering if we can somehow find a way of using it as an installation disk.

Not quite sure how yet though… I’d know how to effectively turn in into a bootable CD drive in Linux, but need to do some homework if we need to do this from Windows.

all I remember is that it wanted to install to C: drive, and I selected D: (the external drive) instead, I didnt know what I was in for, so I figured it was safest that way as its replaceable.
and that it Part worked when I rebooted, with an option to select my OS (Unbuntu or windoze).
naturally I selected unbuntu and then I got the hd0,0 error, having said that, it was on a machine that I had no intention of putting linux on, and subsequent attempts of replicating this on an intended machine using its own internal HDD have failed misserably :frowning:

Im asking here before I cock anything else up, as it is this machine (and unintended) is now asking for passwords to boot into windows, and has a totally different set of boot screens as its doing it, I never needed to do a thing before, now I have to click stuff to get in (albeit there are no passwords set and I`m now known as “Administrator”")???

also, how I stop the colored letters and lines through at the bottom before I post? I can hardly see some of them and have to spend ages figuring them out (eyesight not great).

Coloured lines (Captcha) will disappear after yo make a few more posts… it’s to stop spambots.

If it mentioned "C:" drive at all, it was a WUBI installation, as Linux doesn’t use that form of drive (lettering) assignment.

The changes WUBI made to the Windows bootloader, can be undone… see here:

OK, give me a while, and I’ll see if I can find a way to use the external drive as a Linux installation medium, using Windows applications.

I’m going to guess/hope your laptops can boot from an external USB hard drive (even though they cannot boot from a USB stick)

How old are these laptops ? … what happened when you tried booting from a LiveUSB stick ?

these are quite old laptops, probably 10+ years I should imagine, DELL latitude C400.
the thing is, I didnt even get to burn a bootable copy to the USB stick (only 1.86Gb). I tried the make bootable usb option and it was ghosted out to burn one, as I couldnt sellect an ISO image, because that turned back into a WINRAR package again, even though I copied it across from my IBM laptop (even older than these) as an Image file???
Im Truly lost here as what to do, its like some huge conspiracy thingy, in fact if you wrote it no one would believe it!
so Im really sticking my neck out here by doing so, as I KNOW it sounds mad, and theres NONE madder than me at this point, I
can assure you!
so… fact is I have no Idea if I can select USB as a device to boot from, I have a CD/dvd external device that Should be able to burn CDs (not DVDs) but I can`t get anyone of them to work either?

I also have a concern about Drivers when I get Linux installed, how will my Wi-Fi (internal thingy) work, and Mobile Internet dongle?
still, I guess one thing at a time eh! :wink:

An idea…

I wonder if something like this:

Could be used to add the Ubuntu ISO image to the USB hard drive, and use the GRUB4DOS bootloader (which it will install for you) to make the drive bootable, and boot the ISO.

If it works, it will allow you to boot the Ubuntu LiveCD image from the external hard drive, then use it to install Ubuntu to the “internal” hard drive.


If the CAN boot from the USB HDD using this method, you’ll be able to test the driver support… but most wireless devices (and mobile dongles) can be made to work.

If you CAN’T boot from the external USB HDD, the ONLY way I can see that you could install Linux would be to take the drives out of the laptops, put then in an external USB enclosure, attach then to a computer that CAN boot a Linux LiveCD, install Ubuntu and the GRUB bootloader to it, then put the drive back in the laptop.

This will work for Linux, but not for Windows… Windows NEEDS to be installed on the same hardware or you will run into all sorts of driver issues… linux on the other hand will be more than happy to be installed on different set of hardware… it will then adjust the drivers automatically.

Somewhat at a loss to see the “conspiracy” in the fact that old hardware refuses to boot from external devices… standard fare 10 years ago I’m afraid :slight_smile:

BTW, The winrar/iso image “issue”, isn’t really an issue… you’ve just got the winrar program associated with the .iso file extension in Windows :wink: … they are still usable.

ok, I just had a quick look at that site, and still really have no idea what Im doing, but I gather that I need to Have an ISO image to start with, and I dont.
where do I get and ISO file from as a simple DL? (pref unbuntu).
also This computer is Not the target machine, so will I have to do it all on that one?
I seriously need a bit more Step-By-Step guidance I think.

Im really quite Rubbish when it comes to all this "modern" software stuff, sorry bout that! :frowning:

Quick question… how have you been trying to burn the ISO images to CDROM ?

I put a blank CD into the drive, and try drag and drop, but it always keeps saying theres no CD in there, and you can hear the laser lens tapping the platter every couple of seconds trying to find a focal point, all 3 drives do the same. I tried using NERO and even that didnt work, and yet I`v burned many a DVD with it in the past?

None of them seem to be working at all now, unless I want to play music or something, but the Write function of each when presented with a blank CD seems non operational?

See my next posting first

OK get an Ubuntu ISO image , by clicking the BIG orange button here:

Once you have that, you’re either going to have to burn it to a CD using something like ImgBurn (see next posting), or use one of the many available applications to transfer it to a USB stck (but I doubt if your older laptops will boot from “removable” media" such as a USB stick), or use the XBOOT application:

to add the Ubuntu.iso image to the external hard drive… when it asks which bootloader to use, select GRUB4DOS.

Now set the external hard drive as the first boot device in the system BIOS, and boot to the external drive.

if it boots into Ubuntu… use it to install Ubuntu to the internal drive.

OK, dragging and dropping the ISO image to a CD WON’T work… all you’ll end up with is a CD containing an iso image file, rather than a bootable CD with Ubuntu on it.

Read this post to see how to use ImgBurn to burn the ISO image to CD:

Yeah, Im kinda with you here, Iv got the pendrive s/ware that you pointed to before DLd here now, so that should all work ok when I unpack it, so now I get the ISO from the orange button link (sounds a lot like the ones I already tried that come as WINRAR files though?) but Ill give that link a shot, and then all being well its just a case of marrying the 2 bits of s/ware together on the USB stick! (Im trying to sound Confident here! :))

also I will add, that the external HDD is also a USB device, so if the mem stick doesnt work, I don`t think the ext HDD will (I could be wrong though?).

either way, at this point, Thank You!

Hmmm… Oh dear! seems thats the orange button thingy comes with a default DL setting of "Open with WINRAR", I should have clicked just Save File instead, its highly probable that on at least 5 occasions so far, i`v just gone the Winrar way DOH!

The reason the iso image is displaying as a WINRAR file, is just that you have WINRAR associated with the .iso file type… it’s NOT a problem.

get the ISO image from Ubuntu, ignore that it looks like a WINRAR file, fire up that XBOOT application, point it at the external HDD, tell it to install GRUB4DOS, drag the Ubuntu ISO file you just downloaded into the XBOOT window, and let it do its thing.

Now try booting from the external HDD.

Just because the system cannot boot from a USB stick, DOESN’T mean it cannot boot from a USB HDD… a USB stick is considered a “removable media” by older BIOS’s


STOP the download, and start it again, and select “Save as file”… you could let it finish and open in WINRAR, then select “Save As” from within WINRAR, but probably easiest just to start again.

Oh, and I hope you accepted the default 32bit version of Ubuntu, and didn’t go for the 64bit version.

Youre brilliant you are! no I havent got it working yet, in fact the ISO is 41 mins remaining to DL, but at least Now I have some semblance of confidence that this may work :wink:

and honestly, Im really NOT dense, its just that this sort of stuff leaves me cold/dead in the water, and I see it all as SOoooo unnecessary! and needlessly complicated.

I like that last link you posted to, about the clean install from a CD, windows not included :slight_smile:

I really miss the Amiga days. when computing was Fun!, Im kinda hoping that Linux will bring that back again, its a shot in the dark I know, but I live in hope :wink:

The Linux world is FULL of ex Amiganauts :wink: … me included.

You must remember though that Workbench and AmigaOSx.x was designed to run on known hardware… Linux like Windows must take a LOT of hardware into consideration, so the install is a more complex affair.

Would be VERY simple if you had a working CD drive though… it’s your hardware that’s making it difficult, not Linux… as a matter of fact, you’ll have a MUCH bigger problem if/when you try to install Windows without a working CD drive :wink:

Typical, Both pieces of s/ware are now DL`d, but when I try to run the xbootsvs1.0 is says I now need some version of .NET framework as well!???

and gives me no link or usable means of obtaining it.

I wouldnt mind, but after installing AVRstudio some weeks ago, it spent the best part of a Day DLing .NET rubbish!

I just can`t win :frowning:

Which version of .NET does it want ?