Laptop crashed & won't boot. (solved)

Here I am again folks. I’m running Ubuntu 18.04. Laptop is:

HP 15 notebook pc mod no 2213
kernel; 4.40-185generic x86_64 (64bit gcc; 5.4.0) console; tty 1 distro ; [nothing here]
bios; Insyde v;F.39
Quad core intel pentium n3540 cache;1024 kb flags; (-) bmips; 4326
network; card-1; realtek rtl8188ee wireless network adapter driver; rtl8188ee IF; wlp2so state; up speed; n/a duplex; n/a
mac; 9c;ad;97;36;21;a7
card-2; realtek rtl810ex pci express fast ethernet controller IF; p3p1 state; down mac; 38;63;bb;84;74;7a
drives; HDD; 500 gb (18.2% used) ID-1; /dev/sda
partition; id-1; / size; 451G used; 78gb (19% used) fs; ext4 dev; /dev/sda1
id-2; swap-1 size 8.47gb used 0.00gb fs; swap dev; /dev/sda5
raid; no raid devices; /proc/mdstat, md_mod kernel module present
sensors; none detected - lm-sensors installed and configured?
Info; processes; -1 uptime; 5 min memory; 144.2/7875.5MB Init; systemd Gcc sys; 5.4.0 Client; shell (bash) inxi; 2.2.35

Updated it yesterday evening. worked OK on booting this morning but gave the usual crash after about an hr. Has done this most times after an update but has been Ok for a couple of months now. Worked fine after hard shutdown & reboot. Came to use it again about an hr ago & found it wasn’t wanting to rename any files so I went for a restart & it hung up on a plain purple screen. CTRL/ALT/DEL gives the following :

/dev/sda2 contains files system with errors, check forced
Inodes that were part of a corrupted orphan linked list were found.


fsck exited with status code 4
the root file system on /dev/sda2 requires a manual fsck

Am I screwed again?

You could try to run fsck manually:

fsck -fy /dev/sda2

then reboot

@SeZo Direct hit there. Easiest fix I’ve ever had. Had a bunch Inode orphans fixed & dev/sda2 reported clean. Wasn’t too keen to reboot but it did. Shutting down & restarting OK.
Thank you !

I’ve not used fsck so looked it up when Sezo suggested it.
Everywhere I looked was a warning that one must unmount the device before using fsck - not doing so may result in corruption of the file-system.
I’ll remember that!


Ubuntu wasn’t booted so that means it wasn’t mounted ?

I haven’t a clue about partitions but as I understand it, sda1 is the main Ubuntu partition and sda2 (the one your system complained about) is an extended partition (at least on mine), although it’s interesting that your system info mentions only sda1 and sda5.

7 Free Online Fax Services says:
An extended partition is a primary partition that subdivides into logical partitions. Operating systems have no problem managing physical and logical partitions, so you’re free to subdivide an extended partition into as many logical partitions as you need to install as many different operating systems or separate virtual hard drives as you like.

I am guessing also that as your computer complained: “/dev/sda2 contains files system with errors” it must have been mounted.

Not that all this matters as you have solved the problem. Just saying… :wink: