Latest updates broke my pc

Just installed the latest updates and restarted the desktop and it booted to this

I expect this from Windross but not Linux.
What happened and how do I fix it?
Will the same happen when I update the laptop too?

I’t looks like the initrd image didn’t get built for a new kernel that was installed during the updates.

If you hold the Shift key at bootup … do you get to the GRUB boot screen … if so select the old kernel and boot to that.

Let us know if that works, and we’ll go from there.

Also which distro/version are we talking about ?

was this an “update”, or an OS “upgrade” to a later version ? … such as 11.04 → 11.10

The latest updates seemed to work fine for me. There was a couple of new kernel things in there. Headers, image, and a couple of modules as well. I guess this is just one of the, “unlucky” moments. Best bet is that the initrd image didn’t get built like Mark said.

Will try the shift at boot when I get home.
Version is 1010.

This was an update not an upgrade Mark.
Tried booting from Grub and none of the kernels work.
Tried booting to safe mode and got,

OK, weird but it looks like the file system has become corrupted …

Can you boot to an Ubuntu LiveCD, then open a terminal and run:

sudo fdisk -l

and post back the output.

For clarity, that’s SUDO FDISK -L but it MUST be lower case.

First see if you can access the hard drive from the LiveCD, if you can, backup any user files, just in case.

then REBOOT to the LiveCD ← this is IMPORTANT to make sure no partitions are mounted before running fsck

Once rebooted to the LiveCD, don’t do anything that might attempt to mount the drive/partitions … just open a terminal and run:

sudo fsck /dev/sda1

hit enter, and password when asked … and hopefully this will sort out the file system.

Tried to access the hard drive but nothing happened so rebooted to the CD run the command and get.

Gotta go to bed now, will pick this up in the morning.

Which LiveCD is that ?

I’ve just been reading that there is a bug in e2fsprogs in (at least) the version that comes with 10.04 and 10.10 … dunno bout Natty or Oneiric.

Apparently the bug does EXACTLY what your system is doing when you run fsck on a drive where both the primary and backup superblock or block group descriptors look corrupted.

I hadn’t heard of this bug till now … you learn something every day.

See the bug report here:

Apparently an older LiveCD such as Karmic (9.10) works perfectly … maybe a newer version such as 11.04 or 11.10 might work.

But if I were you, I’d download this:

Burn it to disk … boot to it …

Then read the instructions here:

Hopefully it will repair the file system for you … it did for the guy in comment #20 on the bug report page.

Short of that … get a different Ubuntu version or another distro entirely’s LiveCD, and run
sudo fsck /dev/sda1
from that.

CD is 10.10, just my luck.
Have downloaded the boot repair but can’t burn it till the weekend (no cd’s) so will get back to you then.

Please do … I’d like to know how good it is at its job :slight_smile:

Would knowing if it will work from a LiveUSB help ? … I’ll check if it can be put on a USB stick if you want ?

Well bu**er me.
Burned the ISO to disc (Tesco (4x) 10 for £3.50), took about 4 minutes.
Put it in the PC and booted to it. Now if I had thought about it I would have filmed the process but alas it didn’t occur to me and it happened quite quickly too.
It asked if I wanted to run the software >yes (lots of script) >splash screen >please connect to internet and continue( wireless not active so tried anyway) >could not update software, continue? >yes >recommended repair or advanced?

recommended >repairing please wait.
Three minutes ish then,
Eject cd and press enter to restart.
Did that and it booted to Grub (never did before) but then continued to boot and hey presto.
Haven’t had a good look around yet but as my wireless dongle is working I can only assume that everything is ok.

Good news indeed … must have a look at it myself sometime … Hmm, how best to bugger up GRUB :slight_smile: … just kidding.

Well I think I can tell you what happened.
I run the updated and when it restarted I went out of the room and as it turns out the other half came in and thought it was turned off because the screen was black and she pressed the start button which turned it off, she pressed it again to turn it on and that’s when it didn’t boot (Keystone cops anyone).

hehehe … I’d run a:

sudo apt-get update && sudo apt-get upgrade

just to check it got all the updates … and to see if there are any problems.