LIBRE OFFICE - how big? Urgent

I’ve got a translating project due tomorrow and Open Office is going nuts- not reading things, pages disappearing, crashing on saves. How big is Libre Office- just want to install Writer by itself - I only have 450 Mb left. Maybe I got a macro- was using docx which OO doesn’t fully support.

Please tell me how to remove OO, and install LIbre Office, really only WRITER at first.

The CLAM was damaged- I really need to scan these doc files lest I send people viruses. What are instructions for reinstalling or deleting and installing it.

Which distro/version/architecture ?

You could try …

sudo apt-get remove --purge*


sudo apt-get install libreoffice-writer

Obviously that’s only going to work if libreoffice is in your repos

Ubuntu 10.4.1 with all updates
Turion 64 AMD 1.8Gh, 1 gb 400Mh ramm

Open Office 3.2.0
OO 320 m12 Build 9483

How much bigger is it than Open Office?? What’s a reinstall OO command. Why do you use the .org* ending? Since when does a program be named as a website?

Can I just install the Libre Writer/processor without the other stuff??

Just got that new RAM but it’s in America for 2 weeks.

Wish I got the netbook kicking- didn’t take off of the motherboard this time and was bending the cable a bit, but using some superglue to fasten the ferrite may have been fatal to connections. Then ther was the drop of bleach on the motherboard… don’t ask.


OK, I doubt if Libreoffice is in the 10.04 repos.

OpenOffice has always been called OOo =

Command to reinstall is probably:

sudo apt-get install --reinstall openoffice

Size … I doubt if there’s much in it one way or the other as LibreOffice was a fork of OpenOffice anyway.

what repo is it in + how do I add it (maybe I know that in Synaptic); But they don’t just add all compatible software to older repos? Maybe the Peppermint repo- that has got to be a light version (actually it sucked 400-500 mb of RAM, i think).

Second time I’ve heard this fork business, a friend w for Google in NYC says Oracle owns OOoooo. How can they buy open source program?

DOes probably mean it sometimes doesn’t work and will just destroy the installation you have? Better to UN , reboot, + then RE Install, eh?

Ah I see- you are saying just install Writer- that would have support for any Tables, right?

Any ideas how to remove Clam- that’s got so many other aux programs I installed- it ain’t working- hurt it by forcing close in process manager 60 times,I guess.
sudo apt-get remove --purge clam (clamav)? you need the * with removing OOo because it doesn’t say that to reinstall

This PPA

to install libreoffice-writer:

sudo add-apt-repository ppa:libreoffice/ppa


sudo apt-get update


sudo apt-get install libreoffice-writer
DOes *probably* mean it sometimes doesn't work and will just destroy the installation you have?

No, it means I’'m not 100% sure the name of the package is “openoffice” in 10.04 … if it’s not, nothing will get installed.

for clamav, try:

sudo apt-get remove --purge clamav

Second time I've heard this fork business, a friend w for Google in NYC says Oracle owns OOoooo. How can they buy open source program?

OpenOffice was originally owned by Sun Microsystems, who open sourced the code … Oracle bought Sun, so now own OpenOffice … now whilst Oracle can’t exactly “close” the original source again, they have a reputation for -

a) being open source hostile
b) being control freaks
c) dropping development of acquired open source projects

and theoretically, they could take the project off in a new “closed” direction … though they’re more likely to just drop it altogether.

Anyway … a good chunk of the developers that worked on the OpenOffice project didn’t get on with the new owners, or just didn’t trust them, so took the open source code for OpenOffice and created LibreOffice from it.

The first release of LibreOffice was basically just the same code as OpenOffice but with a different name, but no longer controlled by Oracle, the code in the two branches has since diverged more and more … that’s the definition of a “fork”, where the original project forks into two distinct separate projects.

And that’s the beauty of open source in a nutshell … don’t like the direction a projects leaders are taking it … grab the freely available code, and fork it into your own project with YOUR direction.

Is there a way to remove or reinstall only the OOo WRITER, or is it all too integrated. Would then installing only the Libre Office writer be OK.

You think Libre is better or only more free- development has continued? Did Oracle do anything esp. bad to OOo, bring it closer to MS programs or something.

Removed Clam programs w Synaptic, and reinstalled it, but still want to shut off background scanning.

LibreOffice is definitely recieving a greater development effort than OOo

Remove just OOo writer:

sudo apt-get remove


sudo apt-get install

I wouldn’t like to try mixing LO and OOo … as they may both use some of the same config files etc.

but up to you if you want to give it a go.

It’s not that Oracle are “close to Microsoft” … it’s more that they behave in the same way … they are now pariahs of the FOSS world too.

Sun had a lot of open source projects that Oracle acquired when bought Sun … they then proceeded to either drop them, or force their will onto the devs, or sue anyone that that they thought were using the code … such as trying to sue Google over Android.

Oracle are as much just a money making machine with no scruples as M$, they have no interest in the OSS projects they own, or the FOSS community in general … if it can’t be made to make money, they drop it.

even OpenOffice has been handed to Apache … but too late … everyone (including the devs) has already moved to LO.

Something that always confused me was maybe half the time, for no apparent reason my OOo document(s) would have to be “recovered” before I could use them. It always worked but I found it disquieting when there was no problem in saving or closing them.

I got really bizarre behavior from Libre Office- when I clicked on a doc file, it would also open SeaMoney (web editor-browser), though not if I opened program directly + opened file inside it. Also the spell check didn’t work at all- did nothing. ANyway I seem to have trashed it removing Libre Office packages w Computer Janitor- now it doesn’t open, get this: “FATAL ERROR. The application cannot be started. Loading component library failed.” I reinstalled the Libre ppa but when tried to reinstall it, got this below: (Did I make mistake?).

root@mak4-laptop:/home/mako4# apt-get install --reinstall libreoffice-writer
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reinstallation of libreoffice-writer is not possible, it cannot be downloaded.
The following packages were automatically installed and are no longer required:
Use ‘apt-get autoremove’ to remove them.

Also I tried to remove evolution- figured it would warn me if there was anything terrible- just 4-5 evolution programs along with main, but got a screen freeze and had to do hard shutoff. Only simple evolution was still marked for removal + undid it (size didn’t change). Have been trying to make space to upgrade to 10.10 thinking that might fix some of my junk. Pep3 + 4 don’t read from my (or 2 other) lappys, but they do from a more modern desktop. Maybe marginal CD- RIData.

What do you suggest, Master Jedi Mark? Need the writer- I’m doing translations every day.

This was exact message:
The application cannot be started.
loading component library failed: file:///usr/lib/libreoffice/program/…/program/

The LibreOffice PPA (above) no longer contains a version for Ubuntu 10.04

But this one does:

Open a terminal and run:

sudo apt-get autoremove


sudo apt-get clean


sudo add-apt-repository ppa:libreoffice/libreoffice-4-0


sudo apt-get update


sudo apt-get install --reinstall libreoffice-writer

Didn’t work- restarted and still get that file missing warning after starts to load.

I tried purge-removing the writer only, then installing it, but still get that warning. Guess next step is to reinstall all libre office- it’s the same command?

So different versions of Ubuntu are so different that each needs it’s own version of software- that seems like alot of work. It did look like that new repository had an older version, but since was getting % and other trash characters, not sure.

It’s the fact that older versions of Ubuntu will have older libraries … yet the newer software may depend on the newer versions of those libraries.

Now considering Ubuntu 10.04 (desktop) is nearly end of life, they’re unlikely to update those libraries … so LibreOffice have no choice but not to support 10.04 in newer versions.

Kinda like trying to install Software for Vista in Windows 98 … the supporting framework just isn’t there.

You could try purging the LibreOffice PPA’s you have added … then go back to the original version of LibreOffice from the 10.04 repositories.

or a better idea would be to move to 12.04, or Mint, or Peppermint, or …

Well I gotta get this working- have any idea where repositories for that library would be- how do you force it to install them? I thought they support LTR for 5 years. Open Office should still work OK though, right? Actually had a bunch of frightening freeze-crashes right after I read of some new Linux virus (Hand of smtg, though it was just financial theft)- the second I get a Pep3 disc working, I’m wiping this partition- already backed up everything. This is 7 years old- I don’t think it can handle the requirements of 12.4 (which I put on a landlords lappy). I’m also constrained by partition’s tiny size (7.5gb)

What’s with that damn Computer Janitor? (In admin-standard prog?). I thought packages means installation packages, which can be removed. What programs RUN from packages or have libraries on them. It gave me about 5 Libre packages to remove, then after I did it 10 more appeared, which looked strange (now that you’ve destroyed it, might as well remove everything). I’d already removed them with Tweak, so I shoulda been more cautious.

OK if I remove Libre completely, that other repository must have the associated libraries, mustn’t it???
What good is the main program without the libraries that it needs?

I thought they support LTR for 5 years

Erm, they support LTS’s NOW for 5 years … but they didn’t when 10.04 came out … that got 3 years

See here:
Support for the desktop edition of 10.04 finished in May this year.

Apparently one of the versions of LibreOffice 4 had issues with that library … known bug … You must have that version, and there’s AFAIK no way to get a later version in 10.04

There’s a known issue that renders the entire Office suite unusable and nobody in this massive community just posts that library somewhere? Well any other different libre repositories that you know? The libre office was reading docx etc, but not having the spellcheck was a huge pain

How about this one 4.0.4

or the next lower one: 3.6.7
Since I had 4 something, 3.6.7 must be old enough to work