LibreOffice 4.0 now opens Microsoft Publisher files

One of the things I see repeated a lot on my travels around Linux forums and websites is “if only I could open Microsoft Publisher .pub files in Linux” …

Well I’ve just installed LibreOffice 4.0.1 in Peppermint 3 from this PPA:

And LibreOffice Draw had no problem opening .pub files … I must add, I’ve only tried a few, and I have no idea which version of MS Publisher they’re from … but things are looking good :slight_smile:

I’d also like to add that LibreOffice 4.0.1 seems quite a bit quicker than 3.5 was, and opens nearly instantly on my PC ;D

Amongst other things there’s supposed to be better compatibility with .docx and .rtf files.

You can check out the new features here:

and at The Document Foundation Blog here:

So far I’m liking what I’m seeing …

LibreOffice Draw had no problem opening .pub files ..

God to know. Though I could have done with it 2 years ago. But as they say better late than never.
Have been using version 4 for a while (sneaked in one of the updates) but never actually loked at the release notes.
You are right it does appear to be a bit quicker (than 3.6) to start up but that never bothered me aniway. :smiley:

So this is the end of the road for Publishers exlusivity?

It’s looking that way :slight_smile:

OK so how do I get the most up to date version. I presently have version 3.5 is there any way to get the update manager to do this automatically?

In which Linux distro ?

If it’s Ubuntu based -

sudo apt-get install ppa-purge


sudo add-apt-repository ppa:libreoffice/ppa


sudo apt-get update


sudo apt-get upgrade

should do the trick.

I am running mint 13 32bit. This did not result in my Libre Office upgrading to version 4.0…Would I be better to download the Deb files from there website?

Odd … it should have ???

the same instructions are also online:

You could try:

sudo apt-get update


sudo apt-get dist-upgrade

Could this be the reason no upgrade?

W: Failed to fetch 404 Not Found

W: Failed to fetch 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

Yeh, that’s exactly the problem. (and one of the PITA moments you get with Mint)

You have 2 options …

  1. edit your sources to say

Distribution: precise
Components: main

For both libreoffice PPA’s (sources and binary)

instead of

Distribution: maya
Components: main


  1. as you say, download the .debs and install

If you decide to want to go with option 1 … post the output from:

ls -a /etc/apt/sources.list.d

and the if it exists, the contents of:

gedit /etc/apt/sources.list.d/libreoffice-ppa-maya.list

went with option one and all is OK now have version 4 looks good.

Will post the info you requested next time I am on that computer.

As a matter of interest I had no problems with upgrading to version 4 on mint 13 64bit system everything was done automatic.

As with other issues seems they are mainly in the 32bit version of mint 13.

Thanks Mark

upgraded to version 4 on peppermint 3
your reply 4 code did not work but the code on reply 6 did.

again thanks


The version at #6 also worked for me. However, did I just purge all the repositories? If so, how do I go back to the normal ones for updates?