Linksys AE1000 driver installation in Ubuntu

OK, I’ve modified a driver from Ralink (RT3572USB) to include the ID strings (13b1:002f) for a Linksys AE1000, and support for WPA(2).

With your PC connected to your router with an ethernet cable, run these commands in a terminal:-

To install the packages you’ll need to build the driver:

sudo apt-get install linux-headers-generic build-essential

then to change directory to you Home directory:

cd ~

then to download the modified driver from my dropbox:


then to unpack the driver archive:

tar -xvf 2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000.tar.gz

then to change directory to the directory you just unpacked:

cd ~/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000

then to change to a root prompt (this is IMPORTANT, using sudo alone will not build the driver correctly):

sudo su

then to build the driver:


then to install the driver

make install

then to exit the root prompt:


then to load the driver:

sudo modprobe rt3572sta

Now check if your wireless has sprung to life … and that it survives a reboot.

Can someone with a Linksys AE1000 please provide feedback on whether these instructions work … So I can modify them if/as necessary … TIA.

Hello from America. I just used your suggestion but I installed the adapter in Mint 13 64 bit. It did survive 2 reboots and still connected right away. Well done sir. Thank you for all your hard work.

Hi bmills74, and welcome to the forum :slight_smile: … you’re more than welcome, and thanks for the feedback, it’s nice to know it worked as I had no way to test it myself.

No problem. I am really thankful for fine folks like yourself who even consider linux a priority. I little hick-up that I discovered is that if I change from Mate to Cinnamon the adapter gets rejected and the screen goes to a black screen with a IRQ errors. If you want the exact error let me know. Or I probably should just post it huh. I’ll see what I can do.

Well you “can”, but ATM I don’t have a Mint setup nor that adapter to test it on … not to mention I’m somewhat baffled by why that should be the case … you’ve ended up with an installed and working kernel module (driver), and swapping desktop shouldn’t have any bearing on the loaded modules ???

Mint’s doing something mighty odd if it messes around with loaded kernel modules whilst changing desktops.

Will it work in Cinnamon at all ? … maybe if you boot directly to Cinnamon rather than switch to it ?

Sorry. Disregard that last statement. The wireless at the house was going through an update. I’m in Cinnamon now and no problems. I thought it was weird at the time myself but I didn’t know about the wireless. :slight_smile: I really like Mint 13. I have a high-end system I built with a 6 core AMD 1090T and 16 GB ram. It doesn’t slow down for nothing. But anyways, it runs Linux so nice and smooth and without any aggravation. Even with an NVidia card in it. Take care and thanks again.

No problem :slight_smile: … and playing the jealousy card has worked a treat :wink:


If you ever have any problems with your system, post it to me and I’ll be happy to fix it and post it back … honest :slight_smile:

Well, I didn’t post all that for any reaction like that but oh well. (lol) ;D But now there is a problem. I double checked the router before I sent this so I know its something with the adapter, but now during boot, the computer screen says waiting for network configuration to finish. Then it says “waiting another 60 seconds for network config to finish loading.” Then it says booting without full network service started. While it was working, it was having trouble recognizing the correct passphrase. I double checked that to confirm. Don’t know what to do now. Thanks again.

is this the first time you’ve rebooted ? or is this a new issue ?


do you know what type of encryption the wireless router is using ?

[EDIT 2]

Can you open a terminal (Ctrl+Alt+T) and run:

dmesg > ~/dmesg.txt

you’ll then find a file in your Home drectory called dmesg.txt … can you attach that to your next posting.

Hi there again. Ill do those things you requested as soon as I get back. Out of town right now. Wanna know something kinda weird? I have 2 USB adapters. One, of course, is the AE1000, and the other is a Samsung module for my theater system. I don’t have to install any drivers for the Samsung in Linux, but it’s almost impossible to find drivers for Windows for it. But Windows will load the drivers for the Linksys right away without having to go and find them. Don’t get it.


I follow the steps you mention but I can make the device been recognized.

I’m using OpenSuse 12.1 with Kernel 3.1.10-1.16-desktop

ifconfig ra0 up
ra0: unknown interface: No such device

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 003: ID 13b1:002f Linksys AE1000 v1 802.11n [Ralink RT3572]

Let me know if you need more information.

And thanks for this tutorial

I have no idea if these instructions work with opensuse … I would have expected the first command to fail, as I don’t think opensuse uses the APT tools … did the driver compile and install ?

What’s the output from:

modinfo rt3572sta

Thank you very much for detail instructions. I am new to Linux and this kind of detail instruction is very helpful. I followed instruction and got the error on “make” command. appreciate any help:

root@zia-HP-Pavilion-dv7-Notebook-PC:/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000# make
make -C tools
make[1]: Entering directory '/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/tools'
cp -f os/linux/Makefile.6 /home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/Makefile
make -C /lib/modules/4.4.0-34-generic/build SUBDIRS=/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-4.4.0-34-generic'
  CC [M]  /home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/../../sta/sta_cfg.o
/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/../../sta/sta_cfg.c: In function ?RTMPIoctlShow?:
/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/../../sta/sta_cfg.c:4926:85: error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time]
             snprintf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, __T
/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/../../sta/sta_cfg.c:4926:95: error: macro "__TIME__" might prevent reproducible builds [-Werror=date-time]
     snprintf(extra, size, "Driver version-%s, %s %s\n", STA_DRIVER_VERSION, __DATE__, __TIME__ );
cc1: some warnings being treated as errors
scripts/ recipe for target '/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/../../sta/sta_cfg.o' failed
make[2]: *** [/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux/../../sta/sta_cfg.o] Error 1
Makefile:1403: recipe for target '_module_/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux' failed
make[1]: *** [_module_/home/zia/2011_0427_RT3572_Linux_STA_v2.5.0.0.AE1000/os/linux] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.4.0-34-generic'
Makefile:243: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2

Hello from Poland :wink:
I also thank you for the instructions - they were very useful.

You’re most welcome lin780, though I’m a bit surprised these instructions still work because the dropbox link no longer works.

BTW, welcome to the forum :slight_smile: