Linpus Lite messed up file system

OK, how do you want to play this ? … here’s the options:-

a) (may or may not work) see if running fsck from the Ubuntu LiveUSB will sort out the file system

b) (may or may not work) Edit a file to get the AA1 to prompt for a logon/password … create a “newuser” account and add it to the same groups as the “user” account … reboot to the “newuser” account (from what I gather on the AA1 not all services will work in the newuser account, but doesn’t really matter) … move /home/user to /home/user.backup … delete the original “user” account … recreate the “user” account with the original UID … add the "user account back to the same groups it was originally in … reboot to the “user” account … copy your files from /home/user.backup to /home/user … test everything works … remove the newuser account … delete the /home/user.backup directory … set the system back to not prompting for a loon/password

c) (unless there is a problem with the drive, this should work) copy your user files to a USB stick, then reinstall Linpus Lite

d) (unless there is a problem with the drive, this should work) copy your user files to a USB stick, then install a more up to date Linux distribution, such as Ubuntu, or Xubuntu

While you’re thinking… can you send the output from:

id user

Hi Mark,

Output from id user as follows:

uid=55(user) gid=500(user) groups=500(user),10(wheel)

Thanks for the pen drive resources, was much more straightforward to create than I was expecting :slight_smile:
I have booted from the pen drive, could you tell me how I direct fsck to the internal drive please. Do I just need to run exactly the last set of commands you posted last night? Sorry, feeling out of my depth again. Tried the man page for fsck, but it isn’t clear to me what I have to do.

After that, I’m certianly willing to have a go at creating a new user and if all else fails I can reinstall with the AA1 image I downloaded last night and if that doesn’t work, fall back will be the latest version of Ubuntu I guess.


Can you send the output from:

sudo fdisk -l

run from the liveUSB (Ubuntu) terminal

Just occurred to me that I can now connect the netbook to the net and cut and paste output directly ::slight_smile:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       14462   116165983+  83  Linux
/dev/sda2           14463       14593     1052257+  82  Linux swap / Solaris

Disk /dev/sdb: 4207 MB, 4207935488 bytes
255 heads, 63 sectors/track, 511 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0d0c0b0a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1         511     4104576    b  W95 FAT32

OK, reboot to the LiveUSB (important to make sure no drives are mounted) then without doing anything else that may mount a drive… open a terminal and enter:

sudo fsck /dev/sda1

When it’s done, and you are back at an $ prompt

Reboot to the AA1’s internal drive, and see what happens.

I have a had alot of messages saying ‘Deleted inode nnnnn has zero dtime. Fix,y>?’ To which I have said yes to. The utility is on pass 2 and I now have a message that states:

Entry ‘.ICEauthority’ in /home/user (2637826) has deleted unused inode 2640585. Clear,y.?

Thought I had better point that out and ask if I should respond yes to it, as it seems pertinent?


Hmm… I’d say NO at least this time… but I’m guessing the file system is too screwed to fix, and no matter what you choose it isn’t going to work.

Thanks for the advice.

Immediately after there was anotehr message that says:
Entry ‘saved_state’ in /home/user/.gconfd (2638036) has deleted/unused inode 2640583. Clear?

Should I answer no to all such messages?


Do you think it isn’t worth continuing with this tactic and I should concentrate on recovering files and trying the recovery?

OK, I said no and it has asked to fix 'Free inode count wrong for group #nnn … ’

I said yes to all of those and am back to $ prompt, but I got a message at the end that said Warning: File system still has errors.

erm… you SHOULD have backed up anything you needed BEFORE running fsck, just in case it screws up the files that you needed to keep.

just try booting and see what happens… then if it doesn’t work, reboot the LiveUSB and backup what you need … then reboot the LiveUSB and try fsck again, but this time answer yes.

but be sure to backup FIRST.

OK, Thanks.

Still not booting, so I’ll try answering yes to everything after backing up.

After booting the LiveUSB and backing up/copying your user files to an external drive… be sure to REBOOT before running fsck, to make sure no drives are mounted.

Copying the files WILL mount the drive, and running fsck on a mounted drive will mess the file system even more.

OK, will do.

LOL. I fully understand why you wanted this away from the upgrade topic :smiley:

I just don’t want people to think they are related… it’s more a problem with the file system, that could have happened at any time… Firefox is coincidental, and this isn’t a Firefox issue.

But YES, I’d rather not have people scared by my Firefox 6 instructions, which are no more likely to cause this issue than any other file operation such as copying a file.

But I’ve left a link for people who may want to follow this thread too :wink:

I know the damage was done before I arrived on this board, but do you think it was still me using sudo su that caused these problems with the file system, or maybe it was a previously unnoticed problem with the file system? I suppose it’s probably quite hard to say definitively, especially when you don’t have the netbook in front of you.

I am trying to backup files at the moment, but I keep getting errors (‘permission denied’ normally) for jpegs and personal files. Is there some way I can change the permissions for the whole /home/user folder to ‘everyone’ to make this process easier? Would that cause problems later on?

Also, do you know where Linpus stores the Thunderbird files, as I can’t see them in [edit]/home/user?

I take it you are using the nautilus file manager in Ubuntu to move the files ?

If so… just start nautilus with root permissions, that way you’ll be able to move anything anywhere:

gksudo nautilus

you can change ownership once you replace them if necessary.

YES, I do think it was the sudo su… using sudo su rather than sudo -s will still leave your home folder as /home/user … so if anything gets changed in there it will now have root as the owner:group. (so you can see how the system might get confused, it will attempt to change the owner:group to root, but using the “user” credentials)

99 times out of 100 you’ll get away with this… changing password with sudo su is obviously the 1% :wink:

Not to mention the fact that you could easilly mess up permissions as you are using 2 sets of credentials… sudo uses your “user” password, but su should use the root password, so sudo su is somewhat twisting the rules, if you see what I mean.

If you read up on what .ICEauthority is, you’ll understand how the system became confused… really for changing passwords you want to su to root or sudo -s … so if changes are made to .ICEauthority, they’ll be made to the copy at /root/.ICEauthority

Ideally you would use su … and the Linpus Lite default root password of 111111 … but if not, (in most cases) I would think sudo -s would be a better option.

Or even just:
sudo passwd <user_whos_password_you_want_to_change>

NOT a good idea to change the root password in this maner on an Ubuntu/Mint system … on Ubuntu or Mint system the root account is disabled by defualt … changing its password will enable it, and may lead to permission issues.

I had read after somwhere else that the default password was 111111, but I had already done damage. I have made a mental note about the way sudo and su works and will be MUCH more careful in the future when I am managing files.

Yes, it is nautilus, I know that because it looks the same when I open it with the command you just gave me and it has worked a charm in allowing me to copy files, thanks :slight_smile:

Should Thunderbird store the mail fodlers/address book in /home/user, as I’m not seeing it. Mozilla say it should be in ~/.thunderbird/xxxxxx.default am I right in saying that ~ is home?

Thanks again

Yes… in nautilus go to your home directory and hit Ctrl+H to see the hidden files.

All files and directories that start with a “.” are hidden by default.

Another way would be to use the nautilus menus View>Show Hidden Files

If I remember correctly (but I could be wrong about Thunderbird), the Thunderbird and Firefox user and config files will be in /home/user/.mozilla directory.

(folder called .mozilla in your home folder)


Oh, and yes ~ = the current users home folder.