Linpus Lite messed up file system

I unfortunately removed the original Firefox directory when having problems installing 6 before I arrived at this post and I now have a black screen with a white cursor on my Aspire One. Is this situation recoverable or would it require a fresh install??

As you may have already inferred, I am a bit of a Linux novice :-[



Hi teebee, and welcome to the forum :slight_smile:

When you say “removed the firefox directory”… do you mean you uninstalled firefox 2 from within the package manager, or with yum.

Or do you just mean you just deleted the /usr/lib/firefox- directory ?

When you say you have a black screen… is the search bar showing at the bottom ?

If you uninstalled firefox 2 without using the nodeps option (as opposed to just deleting the directory)… You may want to read this thread:

The bad news is that if you UNINSTALLED firefox 2 (without using the nodeps option)… the system CANNOT be fixed and you will have to do a complete system restore, either from the DVD that came with your AA1, or by downloading the disk image from the above link, and using it to create a USB installer… instructions are on the above link.

Before doing that… do you understand what I mean by UNINSTALLED firefox 2, as opposed to just deleting the /usr/lib/firefox- directory ?

The (semi) good news is that if it does require a complete reinstallation of the OS… there is a way to backup any files you may want to keep… again, instructions are in the above link.

If you have any further questions, feel free to ask… preferably BEFORE attempting a fix :wink:

Hi Mark,

No, I hadn’t used any uninstaller, I had deleted a directory. I think it was /home/opt/firefox. I feel more than a bit stupid now that I wasn’t paying proper attention to what I was deleting, but at least I won’t forget in a hurry not to be such an idiot :-[

I had previously installed VLC following this page.

I had then tried to update firefox following this guide.

Ran into a problem from this bit

sudo chown user -R /opt/firefox

which seemed to be a permissions problem (the firefox folder had owner as root)

Tried to su root, but didn’t know the password. Read something that said I could change it by entering sudo su and passwd. Did so, forging ahead like a bull in a china shop. That had no effect so I deleted the firefox directory (/home/opt/firefox I think) and rebooted, when it all went Pete Tong. Reading that back I guess it could have been the passowrd change that caused the problem… I am to green to have a clue though.

There is no search bar, just a black screen and a cursor.

Thanks for the url’s. I’ll have a read through and be sure to post back here for advice before I have another attack of stupiditis.



Does the AA1 normally require a password entering to login, or does it just boot to the desktop without asking for a password ?

When you say you are at a black screen with flashing cursor… can you enter text ? … is it at a command line prompt?

I’m not sure attempting to change the root password with sudo su, was a good idea… you’re effectively attempting to gain root permission with your user password, then change the root password.

Can you get to a command line:-

To get a command prompt when starting the AA1, when the blue splash screen appears hit Ctrl+C, repeatedly, until you get a command prompt (white text on blue)

and send the output from this command:

ls -la /home/user

If you deleted the firefox folder from your home folder, this shouldn’t have done any harm… it certainly shouldn’t stop the system from booting.

So I agree this is a password, or permission issue… so can you send the output from the above command.

Sorry, shouldn’t have said cursor, it is a black screen and a pointer. No cursor, nowhere to enter commands.

And yes, I see how changing the password in that fashion may not have been prudent now… I am learning all of the time!

I can get a command prompt from the spalsh screen. There is quite a lot of files listed from the ls command you asked me to type, plenty of which have gone off of the top of the screen. The last two lines were:

drwx------  2 root root  4096 2011-09-16-16:01 .wh..wh.plink
-rwxr-xr-x  1 user user  2616 2008-08-19 19:28 .XHKeys
[1]+ Done                 startxfce4

Would you like the rest of the output? Can I pause the listing to the screen length?



What is the output if you run:



If you use

ls -la /home/user | less

you should then be able to use the enter key to display the next line… till you reach [End]

I was particularly interested in anything that is owned by root

If I run startxfce4 the full output is as follows:

xsetroot: unable to open display ':0.0'
xrdb: no such file or directory
Smart common input method 1.4.7

xrdb: Can't open display ':0.0'
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module...
Creating backend...

(xfce4-session:1868): Gtk-WARNING **:cannot open display: :0.0
[1]+ Done              starttxfce4
[user@localhost ~]$ Loading socket FrontEnd module ...
Launching SCIM as daemon ...
Launching a SCIM process with x11 ...
Loading socket Config module...
Creating backend...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
Failed to launch SCIM.

see the edit above.

OK, all of the entries listed as root are (there was one with a bunch of question marks which I thought may be relevant):

drwxr-xr-x  3 root root    4096 2008-06-09 04:31  ..
drwxr-xr-x  2 root root    4096 2009-05-19 12:05  DataCardGKU
drwx------  3 root root    4096 2009-01-30  14:22  .dbus
drwxr-xr-x  2 root root    4096 2011-09-16 23:15  gsynaptics
-????????  ? ?    ?           ?                        ?  .ICEauthority
lrwxrwxrwx  1 root root      22 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      20 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      19 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      22 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      19 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      20 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      21 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      23 2010-06-08 20:52 -> /usr/
lrwxrwxrwx  1 root root      19 2010-06-08 20:52 -> /usr/
-rw-r--r--  1 root root     104 2009-01-30 14:11  .mailcap
-rw-r--r--  1 root root     230 2009-01-30 14:11  .mime.types
-r--r--r--  1 root root       0 2011-09-16 16:01  .wh..wh.aufs
drwx------  2 root root    4096 2011-09-16 16:01  .wh..wh.plink

That’s all that are listed as root.

Hmmm … don’t like the look of that .ICEauthority file … seems corrupt.

Can you post the output from

ls -l /home/user/.ICEauthority

Oddly enough, I was wondering if it was .ICEauthority, but was expecting it just to have changed owner, not become completely corrupt.

Can you also try running:


and tell me what the output is

I get:

(xfce4-session:1924): Gtk-WARNING **: cannot open display: :0.0

and the output from:

ls -l /home/user/.ICEauthority


ls: cannot access /home/user/.ICEauthority: Input/output error

I’m guessing the file system is corrupt, as .ICEauthority should be readable.

Try this:

sudo touch /forcefsck

hit enter, and your password if/when asked.

then run:

ls -l /forcefsck

and hit enter… what is returned should be similar to:

-rw-r--r-- 1 root root 0 2011-09-17 00:45 /forcefsck

If that is what is returned, enter:

sudo shutdown -r now

and hit enter (and your password if asked) to reboot… when the system reboots, it should automatically run a file system check.

Wasn’t asked for my password at any time, but I did get the output you were expecting from the ls -l /forcefsck

However on reboot I have gone back to the black screen with the pointer, didn’t see any sign of any file checking going on and the HDD activity light is not active?

OK, I think your only options are to either:-

a) create a Linux (ubuntu, or similar) LiveUSB stick, boot to it, and run fsck from the command line (terminal), and hope it fixes the file system.


b) to do a full wipe/reinstall of Linpus… or a different Linux distribution such as Ubuntu or Xubuntu or Lubuntu etc.

If you need instructions, let me know… Have you got access to a Windows PC ?

OK, I have a Windows PC, having been posting here from it.

I downloaded an AA1 recovery disk linked to in one of your other posts from if it comes to that… I need to recover some files first, assume a bootable flash drive with a LiveCD image on it will be the easiest way to gain access to my files? Do you have any links to resources for making such a bootable flash drive?

Thanks very much for your help and your patience, much appreciated.

Yeh… get an ubuntu LiveCD ISO image from here:

Then follow the instructions from “Step 2” on this page:

(will work for 11.04 too)
Just make sure you set a “persistence” file during creation of the LiveUSB… see pic below

Then all you have to do is boot from the USB stick, by either setting USB as the first boot device in the BIOS, or hitting the “boot device selection key” when you switch your PC on then selecting the USB stick… usually the F10 key but varies from manufacturer to manufacturer… and when asked, select “Try Ubuntu” rather than “Install Ubuntu”.

Go ahead and create the Ubuntu LiveCD… meanwhile I’ll look into ways to repair the .ICEauthority file… so once you’ve created it, before doing anything with it, come back here and check to see if I’ve found an easier solution to a full reinstall.

But it will be handy to have the LiveUSB anyway… at the very least it will give you access to the files you want to back up, and allow us to run fsck.

You’re going to need 2 USB sticks… one to boot Ubuntu from, and another to copy your files to.

I’m looking into creating another user on your AA1, so the new user has its own home folder and therefore its own .ICEauthority file.

Thanks very much once again.

I’ll post back tomorrow once I have a bootable drive working. ADSL is a bit slow, so it will take me a while to downlaod necessary files!



No problem… see you tomorrow then :slight_smile: