Linux 64 bit installation problem [Solved]

I’m having the same problem with 4 very different distros. I always follow the same procedure, download ISO, verify checksum, and create bootable USB. Give it a spin in live mode to check if any immediate issues arise, then assuming all is well install it. I always choose “erase disk”, and don’t interfere with anything else, just leave it to run it’s course. Then remove the USB stick and boot it back up. Or try to, in fact I get “No bootable device” across the screen, and I’ve had this with all 4 distros. But, when I install 32 bit versions of exactly the same distros, they boot up fine and everything works perfectly.

So what’s going wrong with 64 bit? I have never had any issues running any Linux distro (32 or 64) in live mode from USB sticks, so I doubt there’s a problem there. Is something going haywire at the installation stage? Or could it be something to do with hardware/firmware?

The machine in question is a little Acer B113 netbook, 1.5Ghz processor and 2Gb RAM. All I use this for is experimenting and trying out different things. I have spent an awful lot of time searching the net for similar cases, and although I couldn’t find any simple solution, I couldn’t help notice that the issue of “No bootable device” appeared to crop up with Acer laptops/netbooks far more than any other brand. Coincidence?

Bearing in mind the low spec of this netbook I may well be better off sticking with 32 bit, but I would like to get to the bottom of it for 3 reasons:

  1. If a similar situation rears it’s ugly head in the future on another machine I will have some idea where to start looking
  2. Some distros have already dropped 32 bit support, and I believe a lot more will be doing in the next year or 2 (a sore point with me, but I won’t ramble about it just now)
  3. Last, but not least, I really don’t like these issues to get the better of me

Any thoughts or suggestions anyone has will be much appreciated, and as I said previously, I only use it for playing around with, so happy to try out more or less anything. Better point out that although I’ve been using Linux for a year or 2 I still regard myself as a novice.

Thank you

Hi Steve - and welcome to the Forum.

Just clutching at straws - is this a 32 bit machine? If so then that could well be the problem and, as you say, Acers do seem to be particularly susceptible.

For everyday work, 32 bits is fine and I would recommend installing one of the several 32 bit versions of Linux available: Top 10 Linux Distributions that Support 32-Bit Architecture

If you need to run very modern software that is available only in 64 bit then a “new” PC might be in order.


Sorry Keith, but no, it’s definitely a 64 bit machine, I checked at a very early stage. Besides, if it was only a 32 bit machine surely the 64 bit distros wouldn’t have run in live mode from USB stick?

One small detail I didn’t mention in my original post is that when this machine first came into my possession I found it had already got a 32 bit version of Linux Mint installed. Initially I thought this was a bit strange, but now I’m thinking the previous owner probably had the same problems.


The web info I found wasn’t very specific about 32/64 bit for your Asus so, as I said: just clutching at straws.
I seem to remember from the distant past that when 64 bit was the new thing some 64 bit computers would run 32 bit operating systems but not the other way round, although one can do it in a virtual environment, apparently: linux - Run 64-bit app on 32-bit Ubuntu system - Unix & Linux Stack Exchange.

If the previous owner had the same problem, then it looks like you are in trouble unless you go to a lot of effort with Virtual Machines. It’s very odd, though.
Perhaps other Members can offer some advice.


I’ve not optimistic about sorting this problem. Had a look at the Acer Community forum, typed “No bootable device” into the search box, hit enter and promptly got 4,500 hits! Of the handful that I looked at in detail there wasn’t much in the way of solutions either, generally they were just advising to do some pretty obvious checks. If the issue is so common but with no sensible solution it makes me wonder if Acer themselves know what the problem is. Or perhaps they do, but aren’t letting on?

My research also confirms what Keith has said, i.e. that some of these machines although equipped with 64 bit processors weren’t really designed to run 64 bit systems, especially at the budget end of the price scale. Let’s face it, a budget Acer is hardly what you’d call cream of the crop is it?

One further experiment I intend to try is to install something convenient (probably Mint) onto a spare portable HDD I’ve got lying around, just to see if that’ll boot up. But that’s going to be one of those “when I get round to it” jobs. Maybe in couple of weeks when I’ve got week off work.


Your assessment sounds about right, Steve. I don’t know anyone with an Acer so can’t canvass opinion.

If a 32 bit installation works OK, is there any need for a 64 bit OS? I grant you that most modern s/w is designed for 64 bit but if all you need is everyday applications then you should be fine.
Sources of 32 bit Linux OSs will provide suitable extra software that will be guaranteed to work. Mint, which you have, is a good example.
In the long term, though, you might need to £upgrade.

Good luck.

Hi Steve

Have you had a look at your cpuifo file, I’ve no reason to doubt your machine is 64bit but if so then I can’t understand why it will install a 32bit system and not a 64bit system

So if you haven’t already done so in the terminal type the following


and in the flags section check “lm” is listed

Good luck


…or better:

sudo cat /proc/cpuinfo


Thanks Keith

Sorry about that I think it’s an age thing :-[

Join the club, Graeme.
I’d forgotten about cpuinfo which is exceptionally informative.

Steve; you can find more info on the flags here:


Absolutely, definitely 64 bit. All the 64 bit distros I tried ran fine with no issues in live mode from USB stick. It was only when they were installed everything went haywire. I’m going to try another couple of experiments in the next week or so, and I’ll keep you posted.


A bit of an update. I installed the latest Linux Mint 20.1 to a portable HDD, then booted it on two different laptops. In both cases it was a bit slow to boot, but boot it did and everything worked fine, which confirms the installation was ok. Came to try it on this silly little Acer netbook - No chance! Wouldn’t even recognise the HDD was there.

I’m still baffled as to how it manages to run 64 bit distros perfectly well in live mode from USB sticks but for some reason just won’t have it from an installation. So I will continue with 32 bit installations, unless somebody comes up with a “miracle cure”.

My final word on the netbook? Absolute rubbish! When new in 2013 it was close to £300, so considering it’s limited resources and only 11" screen, I can only sympathise with anyone that bought one new.


Hi Steve57,

I’m just as perplexed, because what you’re describing (running 64bit OK, unless it’s on the local drive!) doesn’t make sense to me either I’m afread :frowning:

Therefore, the only 2pence I can throw into this thread, would be to look through all of the BIOS options, Sure I agree, I can’t imaging anything saying “Boot Local Device in 32bit only”…but perhaps its worth a peek before you throw in the towel - also you could check if there is a BIOS update.

Ah!.. I just found this: English Community-Lenovo Community which suggests “Secure boot” and “UEFI Legacy” - although that thread does end with it ultimately being a Motherboard failure…

Sorry - but, that’s my out of thoughts!

Well I’ve got to the bottom of what’s been causing the problem, but it still leaves some questions. At various stages during this ongoing saga I have checked the BIOS settings, and it has always showed the boot mode as Legacy BIOS. I’ve never changed this or messed with secure boot or anything else. However, it now transpires that 64 bit distros are automatically booting up in UEFI mode. Why or how I don’t know, and I haven’t found any way to stop this either.

So if the live USB has booted in UEFI it follows that the installation will also be UEFI. Then of course it won’t boot because the boot mode is set to Legacy BIOS, this doesn’t change at any point. Following yet another installation of Linux Mint 20 I went back into the settings and changed the boot mode to UEFI. Then of course I had to jump through all the hoops associated with UEFI. Hey presto, Mint booted up fine.

Yet again my (endless) research indicated that this business of getting the BIOS to behave and do as it’s told is more of an issue with Acer laptops than any other brand, as was the issue of “No bootable device”. So the moral of this story is…

One final note, if booting from a USB stick completely ignores the BIOS settings, doesn’t this make a mockery of secure boot?


I’m pleased that your patience and tenacity has solved the problem. And many thanks for keeping us up-to-date with your various tests.
To assist other people looking for the solution, please edit the title of your first post on this topic as [SOLVED].

Thank you.

Sorry Keith, forgot about that. Done now

Many thanks.