Linux friendly motherboard and CPU? (solved)

Can anyone recommend a fairly recent Linux-friendly motherboard/processor combination please?

Preferably one which doesn’t cost the earth, but obviously one which is likely still to be available.



You’ll have to give people more than that if it’s to go in a case you already own, and work with other hardware you already own.

Which board is it replacing ? … so we can figure out the form factor.

Which HDD bus (IDE / SATA) ?

Which graphics card and slot type ?

Which power supply (and connectors) do you have ?

and just as importantly, what’s your price range ?, and what are you going to use the PC for ?

Hello Mark, thanks for replying.

Current board/case are ATX. Abit IP35 Pro and a Coolermaster something or other. I wouldn’t mind getting a new case anyway, since I trod on the side panel recently while it was off and bent it a bit !

Mixture of IDE/SATA drives, although I’m getting fed up with the old, small capacity, IDE ones and their bulky cables so will probably copy off the data and go for just SATA.

The graphics card is an AMD Radeon HD 6450 - PCI-E. If I have to upgrade it I will, although I’m not a gamer. Onboard graphics would probably suffice.

The power supply is a Seasonic Bronze 520 watt with a range of SATA and IDE connectors. There’s a Coolermaster 600w Silent Pro Gold available at a pinch (currently in another box). I don’t trust cheap PSUs.

The price range is flexible, although as the machine will be used only for internet, office, a bit of streaming (audio and video) and running Virtualbox, I’d quite like to keep it under about £200 for the board, CPU and 4gb of RAM. I was thinking of keeping it simple and buying a motherboard bundle from Novatech to save time and effort, but Linux compatibility isn’t one of their priorities, unfortunately.

Thanks again…

Personally I wouldn’t go less than an i3, and as this bundle from Novatech:

uses the Gigabyte GA-H110M-S2H motherboard with intel H110 chipset (neither of which I can find anyone having problems with in Linux), I’m as sure as one can be that you’d be fine with it.

In fact I can find plenty of evidence that chipset works well, such as:

But as I’d now not get less than 8GB (even though you can), I’d give consideration to calling them and asking for another 4GB stick in dual-channel configuration … I’d also be looking to replace the HDD with the OS with an SSD which if you haven’t experienced the performance difference yet, YOU REALLY SHOULD :wink:

BTW, if you get one of these, I’d suggest you ditch the Radeon HD6450 and rely in the i3-7100’s onboard Intel HD 630 graphics:

i3-7100 spec:

Motherboard overview:

Motherboard spec:

Or you could buy the components separately on ebuyer for £223.91:

Gigabyte Gigabyte GA-H110M-S2H motherboard:

Intel Core i3-7100 retail boxed:

8GB (2x4GB so will run in dual-channel mode) Crucial Ballistix Sport DDR4 2400 RAM:

Though you’d need to add an LGA1151 CPU cooler, so it’d may be cheaper if you can get Novatech to add another 4GB RAM module (in dual-channel configuration).

Cheapest LGA1151 coolers start at around £12 at ebuyer


Thank you very much for the time and effort you obviously put into this.

I’ve just ordered the Novatech bundle. When it arrives, I’ll check the RAM and order another 4gb stick of the same. I’ll be running in single channel mode, but only for a week or so. I couldn’t understand why they were selling bundles without dual channel RAM until I started shopping and realised that anything under 4gb sticks don’t seem to be available anymore. I suspect 8gb will be overkill for my needs, but what can it hurt?

I like the motherboard bundle idea because I should be able to connect it, test a Linux installation, then return it if it doesn’t work. If I simply bought the parts and assembled them myself that wouldn’t be possible. I expect it will work though. If manufacturers got on board and supported Linux, maybe we wouldn’t need to resort to these tactics. Should come in for about £240 altogether.

This motherboard failure has really alerted me to the fact that those applications I like which rely on XP are on borrowed time. The old board hosted a dual-boot (xubuntu and xp), but the new one probably won’t support xp… Cue Virtualbox - but one of my applications requires specific hardware, so running in VB might be a challenge.

Thanks again. I’ll await the MB bundle then mark this solved…


I’ve just installed the new motherboard bundle and am running a Ubuntu live cd, but there are some things baffling me…

First, the PC took ages to get past the initial screen (which offers options to choose a boot device, enter setup etc). The keyboard seemed not to be responding, but after 2 or 3 minutes, it displayed the option I’d chosen (enter setup). There were 2 possible boot devices, DVD or HDD. I selected DVD and after a bit of restarting, finally booted into Linux.

However, in file manager, under ‘Devices’, all I can see is ‘Computer’ - no sign of the HDD or the DVD.

What’s more, there are actually 2 HDDs and even setup only detected 1 of them. They’re identical Samsung 1Tb disks. One is completely encrypted and the other partially encrypted with an unencrypted partition on which I’m intending to install Linux.

Any ideas folks?

What’s the output from:

sudo fdisk -l


sudo blkid

Hello Mark,

Output follows.

ubuntu@ubuntu:~$ sudo fdisk -l
Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xdefdf602

Device Boot Start End Blocks Id System
/dev/sda1 63 1953520064 976760001 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 15.5 GB, 15518924800 bytes
32 heads, 63 sectors/track, 15034 cylinders, total 30310400 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000c45c

Device Boot Start End Blocks Id System
/dev/sdb1 * 63 30308543 15154240+ c W95 FAT32 (LBA)


ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE=“squashfs”
/dev/sr0: LABEL=“Ubuntu 14.04 LTS amd64” TYPE=“iso9660”
/dev/sdb1: LABEL=“TOSHIBA” UUID=“202C-CC4E” TYPE=“vfat”

How is the other HDD attached … SATA I presume ?

Have you tried a different SATA port or cable ?

Yes, SATA.

This is weird, Mark. The same cable, in the same port, sees one disk but not the other (in file manager, under Dev-Disk-By Id). Nothing under ‘devices’.

The ‘unseen’ disk works perfectly well in a USB caddy, so it’s not the disk the cable, or the port.

I’m thinking motherboard or bios (uefi)…

I’m now getting an error during boot, which says “ATA1 comreset failed. Giving up” or “ATA2 comreset failed. Giving up”.
The boot process carries on, but I assume this is at the heart of the problem. The question is, is it a hardware or a software issue?

Likely a failing HDD, but could just be some kind of formatting issue so try reformatting the drive (attached externally) then attaching it internally.

Personally I’d (whilst connected externally) copy off any data I need to keep … then use GParted to create a new partition table on the drive (which will also effectively wipe the drive) … then shut down, attach the drive internally and see if it’s detected and you’re then able to use Gparted to create a new partition.

I wish it were that easy Mark.

I can’t get it to boot directly from the CD anymore, whether a HDD is connected or not. It immediately displays the “American Megatrends” screen, inviting me to enter setup. After about 30 seconds it says it can’t find “fallback.efi” and goes into Grub. When I select the option to try without installing it loads Ubuntu - slowly.

However, now it offers a choice of one screen resolution - 1024 x 768, which is wildly wrong for a 23 inch widescreen. Also, the reset button has stopped working.
And by the way, the DVD drive doesn’t show up under Devices in File Manager. Sometimes, if I hot swap hard drives, one might appear…

All in all it looks to me like an RMA job. Would you agree? If so would you consider a direct replacement, or would you write this board off?

Are you sure it’s not just the CD ?

Have you tried a LiveUSB or another LiveCD/DVD ?

Try booting the LiveCD with no HDD’s attached … maybe that drive is stopping everything else.

The CD has worked previously - including with this board, yesterday. I have tried a live DVD but nothing happens at all. I did wonder why such a recent board wouldn’t boot from DVD.

And I’ve tried booting with no HDDs attached - no luck.

Could it really be the DVD drive? If so, why would the error messages have differed (ATA1, ATA2) when I hadn’t swapped the DVD drive around? Also a bit of a coincidence if a hardly used DVD drive or a hardly used HDD have failed at the same time as the old motherboard…

You might be right, specially if they work on the old board … RMA it.

I think I will. Just created and tried a live USB. No improvement. It works on our laptop though - I’m typing this in it. So much for Novatech’s testing…

Would you risk a direct replacement, or go for another board? If the latter, I’m back to square one (or worse, since I don’t much feel like reassembling the PC around the old motherboard in the meantime).

This highlights why I hate giving hardware advice, when something goes wrong it’s impossible to say where the fault lies.

IMHO the info I gathered from my initial searches still stands, but I have no way of being 100% sure without buying one myself … I’m afraid at the end of the day that decision is yours my mate.

The chipset is “supposed” to work with Linux, but if you wanted you could look for the EXACT board that article mentioned:

with the same i3-7100 CPU

and the same DDR4 2400/2133 MHz RAM

But I can see no reason why that bundle shouldn’t work.

Just to round this thread off…

After a lot of swapping and changing (and crawling about under the desk), the culprit seems to have been a faulty PSU.

Ironic, as I always buy decent PSUs. Two hard drives and a wi-fi card paid the ultimate price… Thankfully I had two surviving backups. In future I’m going to favour external drives over internal ones, as each has it’s own dedicated power supply, so one failure shouldn’t destroy the most important component of any PC - the data.

Thanks for your help.