Linux Lite and printing

Hi Guy’s. Thanks for letting me in here. I have an OS set-up with Win XP and Linux Lite v2.0. I also have a Cannon Printer. ip3600. Strange thing is I can print perfectly from Gimp or Photoshop when I am in XP, but although LL 2.0. will let me do all the set up and anything else with the ip3600 it just will not actually print. It makes all the noises as though it is going to print, but never does. I get a flashing orange light, which usually means out of paper or ink low. But there is no shortage of either. Obviously I think there might not be a driver for Linux Lite. Can anyone advise me on this? Regards Walt.

What have you done so far ? … ie. where did you get the drivers from ?

And what’s the output from:

uname -a

Apart from trying to locate a way to download a Linux driver, nothing much, except sweat. Ok so I did what you asked and got the following. Linux Optiplex -GX260 3:13.0.24 Generic Ubuntu SMP Fri May 2 23:31 UTC 2014 i686 i686 i686 GNU/Linux

Is this what you expected? Hope iot helps? Regards Walt

OK, I’ve made modified versions of the drivers from Canon (replacing references to libcupsys2 with ones to libcups2) and included the 32 bit version of libtiff 4 from Debian (which is a required dependency) … compressed them and uploaded them to my dropbox.

Open a terminal and run these commands in sequence:

mkdir ~/ip3600-driver


cd ~/ip3600-driver


wget [url][/url]


tar xvf ip3600-driver-plus-libtiff4.tar.gz


cd ~/ip3600-driver/ip3600-driver+libtiff4


sudo dpkg -i *.deb

Once they’ve installed you can close the terminal

OK, now DELETE any printers you’ve already set up.
Add a new printer, and when you get to the part where you select a driver, select
Canon > iP3600 Ver.3.00 > Canon iP3600 Ver.3.00 [en] (recommended)

This link is only here for my reference:

Hi Mark. Thank you for taking the time to help me out here. I am really trying, but every time I type in Code: [Select] I get the response CODE: Command not found. Cannot fathom out why it is doing that. Any ideas? Regards Walt

You dont need to type it in.

Just left click on “select” the box will highlight.

right click on the highlighted box and copy then open terminal and paste in


Ignore the “Code: [Select]” it’s not part of the command … they’re only for forum formatting (ie. to tell you what follows is code, and an option to select it all for copying)

You only need to run what’s in between the lines.

You can copy/paste the commands (one at a time) into the terminal if you wish.

Be aware, you need to enter the command into the terminal, then hit the “Enter” key to run the command … then when that command finishess and leaves you back at an “$” prompt, run the next command.
(DO NOT close the terminal between commands … these commands need to be run one after the other in the SAME terminal)

Also be aware, if you are prompted for your password in the terminal … just type it in and hit the “Enter” key.
Whilst typing your password into a terminal, nothing will be echoed to screen, not even ******, but it IS going in … just type it and hit enter)

Hi Mark. Many thanks for all the patience you have shown me in this. I am pleased to be able to tell you that I am now up and running. What a nightmare it all was, until you came along and showed me the way. Again…Many thanks Mark. Regards to you and yours. Walt

You’re most welcome :slight_smile:

If you’re happy the provided solution solved the problem, please remember to mark the topic (SOLVED) … you can do this by editing the FIRST posting in the topic and changing.

Subject: Linux Lite and printing (SOLVED)

Thanks in advance :slight_smile: