Linux Mint on Sony Vaio


I’m trying to install linux mint on my vaio. I have 2 hard drives, so it seemed natural to keep the C drive for windows and make the D for linux.

Since formatting the D drive and installing linux, the D drive is no longer recognized, for example, I only have one hard-drive option to boot from now. I do get an option as to whether I want to boot Linux Mint or Windows when I first start the computer.

If I choose Linux, it eventually leads me to:
‘unable to find a medium containing a live file system’.

Some research indicates that I need to enable ACHI because windows sets the default to IDE. I followed the instructions here:

The weird thing is, I don’t get any options to configure SATA as shown in the image between point 6. and point 7. via the above link.

I thought - “perhaps I’m not in BIOS”…and indeed, I am in Aptio Setup Utility in which I can change my boot priotity, but not configure SATA as I desire. Suspiciously the Advanced tab here has nothing in it. I read that Sony locks people out of making this change - is this true? Otherwise, any ideas on how I can change this?

Also, I’ve tried pretty much everything F11, F12, Ctrl-F8, F1, F2, F3, Del… and the only ‘BIOS’ menu I can get is the one I’m getting which doesn’t give me the option to change the SATA hard disk mode.

Any help?

Many thanks,

Best wishes,

Hi megboyar, and wecome to the forum :slight_smile:

Can you give us the model number of your Sony VAIO ?

I take it the VAIO has no problem booting to a LiveCD ?

Hi there,

Thanks for your quick reply.

The Vaio is model name: VGN-AW390C, purchased in North America. Actually, it says also Model PCG-8152L

No problem booting from a live CD and I checked the MDSum thing and the numbers/code all matched. The install seems to work beautifully from within Mint.

Thank you!

Did you install from a LiveCD or LiveUSB ?

can you boot to Mint on your Live media, then open a terminal and run:

sudo fdisk -l

and post the output.

Is the menu that offers you the choice at boot time the Linux/grub boot loader, or is it the windows loader?

Sent from my Nexus S using Tapatalk 2

Thank you!

In reverse order for the above 2 postings:

  1. The menu that offers me the choice between Linux Mint and Windows Vista at boot time is the Windows loader. For ‘advanced options’ I press F8 from that menu and can do all the windows things like ‘Start Windows in safe mode’, etc.

If I jump in before this menu loads by pressing F2 I get the Aptio Setup Utility, but basically all I can do there is change the boot order. And it only detects one hard drive.

  1. I am not sure of the final character in the code you asked me to type into terminal. I used a lowercase letter ‘l’ (as in L for Letter.)
    Here is what it returned:
    mint@mint ~ $ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x9ead65fd

Device Boot Start End Blocks Id System
/dev/sda1 2048 20379647 10188800 27 Hidden NTFS WinRE
/dev/sda2 * 20379648 625140399 302380376 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00003747

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 29296639 14647296 83 Linux
/dev/sdb2 29298686 625141759 297921537 5 Extended
/dev/sdb5 29298688 33202175 1951744 82 Linux swap / Solaris
/dev/sdb6 33204224 625141759 295968768 83 Linux

So it’s NOT the GRUB bootloader that’s offering you the choice ?

Here’s a pic of the GRUB boot screen:

You’re saying you DON’T see a screen similar to this (it may have a background picture) ?

Nope! I never see that. Just a Windows thing - see attached.

The second menu I can see is attached - by pressing F2 at startup I can get here - but all I can really do here is chance the boot order…I don’t even think its seeing my second hard drive.

Thank you.

OK, how many times did you attempt to install Mint ?

Did you at some point attempt to install Mint from “inside” Windows with Mint4Win ?

If you boot into Windows, is there a directory C:\mint (or similar) ?

Now can you boot to the Mint LiveCD, and run these 4 commands:

sudo mkdir /mnt/partition-sdb1
sudo mkdir /mnt/partition-sdb6
sudo mount /dev/sdb1 /mnt/partition-sdb1
sudo mount /dev/sdb6 /mnt/partition-sdb6

Now can you post the output from these 2 commands:

ls -a /mnt/partition-sdb1


ls -a /mnt/partition-sdb6

This looks like a WUBI install? In which case I’m thinking the best solution might be a clean / proper install. If Linux boots grub from drive c, even with a tiny boot partition, it should be able to use D: for a root as Linux doesn’t rely on the Bios … as to recovering a broken WUBI install … if you use the installer to put another Ubuntu install on drive c (it’ll repartition it for you) it should (!) Automatically see the install on drive d and add it to the boot menu …

Sent from my Nexus S using Tapatalk 2

WUBI/Mint4Win wouldn’t have created the Linux partitions on /dev/sdb … it would have left them formatted NTFS (or whatever) it installs Ubuntu/Mint into a virtual drive in a directory on a Windows file system.

So my guess is he’s tried both ways …

WUBI/Mint4Win would explain Mint being listed by the Windows bootloader … the Linux partitions on /dev/sdb would be explained by a “proper” installation.

So I’m thinking he just needs to install GRUB to the MBR of /dev/sda … then point it at whichever partition on /dev/sbd contains /boot

then boot to Mint, and update-grub to pick up Windows.

I’m a bit baffled however why the installer would create 2 Linux partitions on sdb … which is why I want the output.

make sense ?


The downside of this strategy is Windows will be unbootable without the Linux drive attached … so we need to know if the Linux drive is an external (removable) drive ?

It may be a better option to use the Vista bootloader to boot Mint on /dev/sdb

Mmm, if the proper install is on drive D, and the BIOS won’t see drive D, getting it to boot might be a problem. Wheras Linux doesn’t use the BIOS for hard drive access, to get to Linux you have to use the machine’s BOOT process … which does use the BIOS …
(just MBR’ing may not help as it still needs to use the BIOS to load the kernel …)

Ahh :frowning:

Sony are making some weird a** BIOS’s lately

Thinking about it … even using the Windows bootloader won’t work if the BIOS doesn’t see the drive.


So your thinking a small /boot partition on sda ? … he’d have to be VERY careful where he puts that, shrink the Windows partition from the wrong end and both OS’s will be unbootable.

What kind of BIOS looses a drive just because of the file system ???

I’m still wondering if this (sdb) is an external drive … and therefore just being listed by the BIOS as “External Device” (so not lost at all) ?
(this is a laptop after all, and they don’t usually have 2 internal HDD’s, unless as in a recent VAIO I’ve seen on the Peppermint forum they’re set up for RAID (those were 2 128GB SSD’s though)

Crazy! Yes, I originally clicked on the Linux CD from within Windows(where I created it)…Out of curiosity so see what would come up. It gave me options to:
-install inside windows
-demo & full installation

I selected demo & full installation and it asked me if I wanted to reboot now? I said yes, thinking that it would simply restart the computer for me and I would be independent from there.

I NEVER tried to install from within Windows, but still, I checked as you suggested and there is in fact a folder C:\linuxmint with folders titled:
disks, install, winboot, Linux Mint and uninstall-wubi

To answer your other question: I have installed mint on the D drive 5 or 6 times. I have also been able to revert the D drive to a pure data/external drive so that I can see it again from within Windows (It disappears when it’s partitioned for mint)

Someone has a point that the D drive may be seen as an external drive because it’s a laptop…I agree with this as a possibility.

So, maybe the Mint I’ve been booting is a mint in windows C:\ that I never installed? which would explain why it doesn’t work properly.

Thanks for all your help.

I will boot the live CD now and run the commands you suggest below.

Thank you!

Best wishes.

Can I suggest at this point to start with a clean slate?
Get rid of the Mint install from your C drive with uninstall-wubi.
Then clean up the second drive (/dev/sdb).From the LiveCD with gparted delete all partitions.
Then install Mint to the second drive (/dev/sdb), let the install do the automatic repartitioning
Make sure during the install when it ask you where to put the grub boot loader you specify /dev/sda
Reboot and then you should be presented with the grub picture Mark posted earlier on.

IF BOTH hard drives are internal (and you haven’t said if they are yet ?), and the BIOS is only seeing the first hard drive … here’s another suggestion …

Physically remove the Windows drive so you can’t harm it

Physically connect the Linux drive to the SATA port the Windows drive was connected to.

Install Linux.

If Linux works … leave that drive where it is … and reconnect the Windows drive to where the Linux drive was originally.

Boot into Linux.

Open a terminal, and run:

sudo update-grub

Linux should now be able to chainload Windows without making any changes to the Windows drive.

If Linux still won’t boot … just physically swap the drives back to where they were, and Windows should work again.