Linux mounting with MTP devices

I have an Motorola Xoom running Android and am trying to mount it onto my Linux system. It is seen as a MTP device therefore I have installed mtpfs. (It mounts fine with MS Windows - which I wish I could ditch but…). I have searched the web for solutions and following them only allows me to see a folder /Playlists on the Xoom.

in /etc/udev/rules.d/51-android.rules
SUBSYSTEM==“usb”, ATTRS{idVendor}==“0502”, MODE=“0666”

in /etc/fstab
/usr/bin/mtpfs /media/xoom fuse rw 0 0

and after mount -a

df reveals
mtpfs 30279104 15805724 14473380 53% /media/xoom

ls /media/xoom reveals

I am desparate to be able to transfer files onto my Xoom but am confused with mtpfs, fuse and the (obsure) settings in MTP

Any help would be appreciated.

I have a galaxy s running Froyo and have the option to mount as mass storage, MTP or media player.
Mounted as mass storage I can see everything in the internal and external storage.
Having looked at the user manual it looks like you will find the settings in Settings>Wireless and Network>USB settings
See attachment.

In MTP mode, doesn’t Banshee just see it ?

I don’t understand the fstab line at all … that looks like you are trying to mount a binary executable at /media/xoom

I’m not sure you need to be putting anything in fstab.

Seems to me like it should be handled by gvfs-fuse.

is there anything in ~/.gvfs ?

I started up banshee and;
ls /media/xoom
now shows
Music Playlists

That’s good for music but when I want to copy a .pdf file it’s not so simple.
cd /media/xoom
mkdir Documents
resulted in
mkdir: cannot create directory `Documents’: File exists
OK, so I type;
ls Documents
resulted in;
ls: cannot access Documents: No such file or directory

In response to the easy solution of reading the manual and following the instructions of;
Apps > Settings > Wireless & Networks
there is no sign of;
Tethering & portable hotspot
so cannot progress to USB tethering (the manual seems to be out of date of Android honeycomb 3.1)
I shall have to ask Motorola about this.

Thanks anyway.

Which Linux distribution, version, and architecture are you running ?

Have you seen this:

are you in the fuse group ?


should tell you.

if not I’d add your user through Users and Groups rather than edit /etc/group manually.

Also be sure to read the first comment about the extra space in the fstab entry.

You may also find this worth a read:

Thanks for all your help.

I have solved it at last, I joined the Motorola Owners’ Forum and found this instruction;

mount.mtpfs -o allow_other /media/xoom

df shows;

mount.mtpfs 30279104 15855932 14423172 53% /media/xoom

and now I can see the entire file structure mounted

Glad you solved it :slight_smile:

That will no doubt help others with a Xoom … thanks for the update :slight_smile:

Mmm, works for me without …

Only difference for me is the udev rules;

SUBSYSTEM=="usb", SYSFS{idVendor}=="22b8", MODE="0666"

(different idVendor)