Linux Novice

I am new to Linux and I am having trouble installing Ubuntu 10.10.
My “C” Hard Drive is a 500 gig RAIDED drive with Windows XP installed.
I now have a newly added 500 gig hard drive as my “E” drive.
I am trying to install Ubuntu onto my new “E” drive, making my system dual bootable.
However all my attempts to install Ubuntu have failed to get me past the "Install " dialogue box with
the following messages.
ubi-partman failed with exit code 10 and
Cannot start device /dev/mapper/jmicron_GRAID no such file or directory

From the latter message it seems that it is the RAIDED disc set up that is causing the problem.
I would be grateful for any help with this problem, bearing in mind that I am a novice.

I’m new to Linux myself but try this, it’s how I installed mine.

Can you see your E drive from within windows and is it empty? That is to say, you don’t mind if you format it.
If so try using WUBI.
Boot into windows as normal then put the disc in (I assume you are using a live CD). When prompted choose to install on your E drive using entire disc.

You need to set the nodmraid kernel boot parameter, available from the F6: Other options menu at the GRUB menu screen.

Boot from your 10.10 LiveCD, and as soon as your BIOS POST screen disappears and you see:

displayed at the bottom of your screen… keep hitting the Space Bar (or Shift key) until…

A screen similar to this will appear and ask you to select a language… select English and hit Enter:
(if you get to the purple Ubuntu screen with the 5 or 6 dots, you missed it and will have to try again)

Press the F6 key, and a menu will open similar to the one in the picture above.

Use the arrow keys to highlight the nodmraid option, and the space bar to select it… an X should appear next to it.

Then you can either select “Try Ubuntu” and install from the desktop, or select “Install Ubuntu”.

Though it may be easier to just turn off RAID in the BIOS, and/or try the Alternate install CD.

Available here:

Mark ; Thank you for the helpful information.
I have tried to get in to set the “nodmraid” boot parameter, but having tried many, many times,
I never get to the situation where I have “ISOLINUX 3.xx” in the top left of the screen.
I am always left in the situation with the Ubuntu screen with the 5 or 6 dots. finishing with
CD trial or Install display.

I acknowledge that I don’t really understand what I am trying to do.

I have read a number of the On-Line procedures available and I have come to the conclusion that I
need to ask about amongst my colleagues and maybe find someone to have a face to face
discussion with.

Thank you for your help.

Sometimes the “ISOLINUX 3.xx” goes past that fast that you don’t get to see it…

Turn ON your PC, and immediately start tapping the spacebar (or any other key), until the menu screen is displayed.

ANY key is supposed to interrupt the boot process and display the menu, but timing is everything.

Also try the Shift key instead of the spacebar… or Esc.

I have made some progress, I got as far as installing 808 mbytes onto my E drive, then got the error ;
Cannot download the metalink and therefore the ISO.

Have you any suggestions as to how I get around this problem ?
Many thanks for your help so far.

I take it you are using WUBI to install from a downloaded ISO image ?

Have you tested the ISO images MD5 checksum ? as 808mb is larger than it should be… if it’s Ubuntu.

Is it Ubuntu ? … Which version ?

Did you burn the ISO image to CD, or are you using the WUBI.exe to download the ISO image for you ?

Are you the same person as “Chuck” ?

Yes I am Chuck
The Installation is Ubuntu 10.10, running from a CD. However the installation was not
initiated from the Trial or Install dialogue box normally displayed from this CD.
I was doing as you suggested in an earlier post, I was hitting the spacebar whilst booting
and I was presented with a dialogue box I had not seen before.
I think it had WUBI in it’s title, it asked which Disc drive or Disc partition you wanted to use.
I selected my “E” drive which I have installed just for this purpose.
There is now a Ubuntu Folder containing the following files :
disks, install, winboot, Ubuntu and uninstall-wubi.

From the name of this last file , I must have been using WUBI

I realise that I still have not been able to get “nodmraid” into the Grub screen menu.

I must be confusing you with all this, I know I am out of my depth at the moment.

Thank you for your help.

IGNORE THIS POSTING FOR NOW… see my next posting.

Have you still got the ISO image you downloaded ?

What I want you to try is…

  1. Remove the Ubuntu directories already on your E: drive.

  2. Download the wubi.exe from this page (don’t use the one from your disk)
    By clicking the big orange button maked “Start download Ubuntu installer for Windows”.

  3. Create a folder on your Windows desktop called Wubi (or whatever you want).

  4. Put BOTH the Ubuntu ISO, and the wubi.exe file you just downloaded in the new Wubi directory on your desktop…
    (just those 2 files, nothing else)

  5. Disconnect from the internet <— IMPORTANT

  6. Double-click the wubi.exe file, and follow the instructions to install.

Hope you don’t mind a question from another no0b about this issue, the more I ask the more I learn right. If the answer is a bit complex for a novice feel free to say so.

Q: Why is this install turning out to be such a problem?
When I installed mine on the laptop it was asking about partition sizes etc and I didn’t know what to do, so I installed via wubi without changing anything and it took about 5 mins.
My desktop install on a new HDD was was even easier (had a display issue but that was a different issue altogether).
If the problem is the raided disc set up you’ll have to explain what that is too ::slight_smile:

Try this…

  1. Change the boot order of your drives in your BIOS, so the non-raid drive is the first boot device… save the changes.

  2. Shut down and physically remove (unplug) your raid drive(s)… so it cannot be altered at all during the Ubuntu installation.

  3. Boot to the LiveCD, and install Ubuntu as normal, telling it to use the whole drive.

  4. Once Ubuntu is up and running, install the dmraid package… either from within the Synaptic package manager, or from a terminal with:

sudo apt-get install dmraid
  1. shut down, and re-attach your raid drive, but make SURE the non-raid drive is still the first boot device in the BIOS.

  2. Boot to Ubuntu… open a terminal and enter:

sudo update-grub

Your Windows drive/installation should be automatically detected and added to the GRUB menu… and should be offered as an option the next time you boot.

If it isn’t detected and added to GRUB, you should still be able to boot Windows by just changing the drive boot order in the BIOS, as there will now be a bootloader on BOTH drives… the Windows drive was never altered at all.

To Mark from Chuck
Try as I might I cannot get to the Language menu using the Live CD method, so I have tried the Alternate Install CD method.

Using this method I actually got the screen with the languages shown, in fact it had English highlighted.
with the functions F1 to F6 Others displayed beneath. I thought that I had cracked it , but, my keyboard was inactive. !^(*_&^

I could not select English or F6 to select “nodmraid” .
So I am still in limbo.
Please have you any suggestions ( I have exhausted all the rude ones myself )

Thank you for you patience


Are you using a USB or wireless keyboard ? … it seems like the keyboard isn’t being recognised till drivers are loaded for it… Try a PS/2 keyboard (at least for the initial installation).

What is the make/model of your PC… if custom built, tell us as much as possible, including the motherboard make/model.

Mark, In answer to your questions :
I am using a USB keyboard, I do not at the moment have access to a PS2 version.
My computer is made up of,
4 gigabyte DDR2 667 MHz Ram
Gigabyte GA-P35-DS3 1333FSB
S_Series Intel Core 2 Quad Core 2 2.4 GHz
512Mb 7900GTX XT Video Card
1 RAIDED 500 GB SATA 8MB Cache hard disc ( C Drive ) XP Home
1 500 GB SATA2 Hard Disc ( E Drive - newly installed to receive Ubuntu )

I hope this information proves useful.

I have continued trying to get to the position where I can set the “nodmraid” parameter, by trying just about every
key available with no luck.
Thank again for your patience.


If you read this:

It looks like you need to change a BIOS setting to make a USB keyboard active at bootup.

Problem is, you need a PS/2 keyboard to access the BIOS. :o … So it looks like you’re going to have to lay your hands on one.

Did you remove (disconnect) the original (windows) hard drive whilst installing Ubuntu ?

Are both of these drives internal ?

OK, it looks like GRUB didn’t get installed to the MBR of the primary drive. (probably because it is being controlled by the RAID controller).

Can you boot to a LiveCD/USB and send the output from:

fdisk -l

BTW, don’t panic… it is perfectly normal for Windows not to be able to “see” a Linux partition, as Windows will only read it’s own file systems… When you get Linux working, you will be able to see/access the Windows partitions/drives from Linux, as Linux can read/write to MANY more file systems than Windows.

Think about it… why would M$ include the ability to read *nix file systems… Windows won’t read a Mac formatted drive either (HFS/HFS+).

Your Linux drive is now (probably) formatted using the EXT4 file system… Windows can only “out of the box” read/write to FAT/FAT32 and NTFS… this actually turns out to be a good thing, if Windows can’t “see” the Linux partitions, it can’t screw them up, nor can its viruses/malware.

Thank you for your help so far.
I have been using Ubuntu for about 2 weeks and I decided to upgrade to 11.04 from 10.10.
All went well but when I booted up I was informed that my hardware did not match up with the requirements so
it booted with what looks like 10.10 with slightly different attributes.

So I am left with two problems , 1) How do I find what my hardware is lacking. I did find reference to a problem with nVidia GeForce 8600 video cards which was something to do with the power connection and as I have a nVidia GeForce 7900 GTX card fitted
I wondered if I could have a similar problem. If so is it fixable ?

  1. , I still have not managed to set up the situation that allows me to choose between Ubuntu and Windows XP Home when booting. The two Operating Systems have their own dedicated 500 gig hard discs and at the moment I am changing the BIOS
    to switch between the two.
    It was suggested that I install GRUB by opening a terminal and entering " sudo update-grub " which I did , to no avail.

I would be grateful for any help with these problems.

In Ubuntu, try this…

sudo apt-get install dmraid

which will hopefully discover the fakeraid drive Windows is on… then run:

sudo update-grub

and see if Windows gets added to the GRUB boot menu.

If it does, just set the ubuntu drive as the primary boot device, and make your OS selection from the GRUB menu.

Meanwhile, I’ll try finding more info on what’s causing your graphics issue with 11.04

If you go to System>Administration>Additional Drivers, what is listed there ?

and are they marked as “Active” ?

You will be pleased to hear that ACTIVATING the nVidia driver as you suggested worked, I now have Ubuntu 11.04 up and running. Thank you.
Now the only problem I have is getting the option on booting which will allow me to select Ubuntu or Windows.
I tried sudo input you suggested yesterday but it did not work unfortunately.

I think I have already taken up too much of your time and I will just carry on switching between the O/S’s using the BIOS.

Thank you for all your help.

Okey Dokey… have fun :slight_smile: … if you change your mind, give us a shout and we’ll try to sort the GRUB/Fakeraid issue.