Lite 3.8 Blank Screen After Opening Lid

Hi. I have Lite 3.8 installed on my old Samsung NP-N110 laptop and it seems to work fine. When I close the lid and reopen after a time, it asks for a password. This is fine - although I can’t figure out how to stop this - but when I enter the password, the screen goes blank and remains blank. I am unable to do anything with it except for hitting the power button to shut it off. It seems to close down OK, as when I hit the power button it chugs for a while then shuts down.

So if anyone has an answer to either of the following I’d be grateful:

  1. How do I stop the p/w request from appearing when I’ve closed the lid for a time? (This is on mains as well as battery.)

  2. What’s happening and how do I prevent the blank screen after I’ve entered the p/w?

Thank you.


Hi Matt.

1. How do I stop the p/w request from appearing when I've closed the lid for a time? (This is on mains as well as battery.)
Have you set your PC to ask for a password at boot time? If so then that might be the reason for requesting a pswd when you raise the lid after a while. As for item 2: I can't help you with that - sorry.


Although it is now asked at boot time, it hasn’t been.

I’m not familiar with Lite but as it’s based on Ubuntu you will probably be able to change to “auto login” by going to System-Settings/Details/Users (or the equivalent path in Linux Lite) and entering your password to unlock the switch.
Let us know how you get on.


Sorry, I obviously didn’t make myself clear. When the problem was first occurring, the system was set to auto-login. I have since turned that off due to security, but the problem remains. What I need to do is turn the pw-entry after opening the lid if this is going to be a persistent problem.


Have you tried altering the power settings so that it doesn’t go into hibernate or sleep mode when you close the lid?


In ‘Power Management’, ‘General’ tab, ‘Laptop Lid’ section, ‘When laptop lid is closed:’ is on ‘Switch off display’ on both batt and plugged. In the ‘System’ tab, ‘System power saving’ section, batt and plugged are ‘Suspend’, inactive: never. Is this what you were referring to?

Also, as aside, the numlock keeps turning on. How do I get it to stay off on boot up?


In 'Power Management', 'General' tab, 'Laptop Lid' section, 'When laptop lid is closed:' is on 'Switch off display' on both batt and plugged. In the 'System' tab, 'System power saving' section, batt and plugged are 'Suspend', inactive: never. Is this what you were referring to?
Yes; that's what I meant. You might be able to change the behaviour using one of those controls.
Also, as aside, the numlock keeps turning on. How do I get it to stay off on boot up?
You might find an option in the BIOS to toggle the auto numlock. If not then you could try using a Fn key command. I found the following from [i]Most laptops have a Fn key you can press in conjunction with other keys to turn off the NumLock feature. But the precise way to disable NumLock varies depending on your laptop model. The Number Lock indicator will light up when the NumLock is enabled and will be unlit whenever the NumLock is disabled. Here are the most common keyboard shortcuts to enable/disable NumLock:

Fn + F11 (Acer, Toshiba, Samsung)
Shift + Num Lock
Fn + Num Lock (Sony, Gateway)
Fn + F11 + Scroll lock
Fn + F8 (HP)
Ctrl + F11
Fn + Shift + Num Lock
Fn + F4 (Dell)
Fn + Nmlk (Lenovo, ASUS)

After pressing the keyboard shortcuts to enable the NumLock, press the shortcuts again and it will disable NumLock."[/i]

Fn+F11 works on my Lenovo Thinkpad as well as Fn + Nmlk.



I’ve tried the various options and nothing seems to change. The screen blanks after closing the lid (which I have no problem with) and, after some time, the ‘Enter PW’ comes up. I can’t see anything else to change. The system does not seem to lock itself into one state, as the options I set seem to stay set.

Thanks for the link re numlock. Unfortunately, I have already tried all these options, as well. There is an option for numlock state in the BIOS which is set to ‘off’, and the ‘Restore Num Lock State on Startup’ has been set to both with the same result, that of the numlock being ‘on’ at ‘Enter PW’, at boot up or on opening the lid. Turning ‘numlock’ off is easy, but continually frustrating - particularly, considering I know it shouldn’t be the case.

Any other suggestions would be appreciated.


Not familiar with Lite, but I believe it uses XFCE, so you may have something similar to other users.

Have a look in Power Manager → Security, see if Lock screen enabled when Screensaver is activated.

Also have a look at Screensaver settings, the lock might be initiated by that

Thanks SeZo,

Under the Security tab, the ‘Automatic lock the session:’ is set to ‘When the screensaver is activated’. (The other option is ‘When the screensaver is deactivated’.)
The ‘Delay locking after the screensaver for’ = 1 second.
The ‘Lock screen when system of going for sleep’ is unchecked.

I don’t know where to find the screensaver settings. There’re not in Power Management or Display, or any of the other settings that I can find.


I’ve just been trying Linux Lite. In the menu, the Settings - Power Manager tool has an option to disable locking the screen when blanking it. Evidently your version doesn’t. Looking more closely, I see that the current version is 5.6 and you are using 3.8, so it seems that your problem was addressed. I also see that 3.8 is no longer supported — running an OS past the end-of-life is not generally a good idea and it also means that there are not many people who can help you, since they will have all moved on.

I’ve had a prompt to update the thread - thanks Keith. I have got no further with the problems. I needed the laptop to take away a few weeks ago, so I just worked around it, then. Since then I haven’t used it as such. I did try asking the question on the Linux Lite Forum, but got a bit of a frosty response from the creator, I believe. I think the reason was that 3.8 isn’t supported now and he didn’t want others helping me with an out dated OS. (Understandable, to a point.) It was also suggested that I update it to v5, but the laptop won’t hold v5.


If that had been me I would immediately be looking for an alternative distro, purely on principle. You simply went on a forum and asked a question, you didn’t deserve any sort of “frosty” reception. Although I’ve not experienced it myself, some of the stuff I’ve seen written on forums I think is appalling. I wonder if this is the only response they can manage when they don’t know the answer?

Anyway, now I’ve got that off my chest, what exactly do you mean by “the laptop won’t hold v5”? Lack of RAM, lack of storage space, only 32 bit, processor not up to the job? Or something else? There’s almost always an answer to any problem, we just have to find it.


Mattc & Steve57,

I agree… so, without dwelling on other forums - welcome to a community that will try to help, regardless of warranty periods, etc :slight_smile:

Assuming you may be thinking to switch Distros, I’ve had quick poke about and found a few similar queries - people searching for a suitable distro. this suggest that Lubuntu should be OK.

Unfortunately, the Lubuntu site is having issues so I couldn’t confirm the requirements - but consider also searching for the N10 model too, which I understand has similar specs to your N110.

Not an endorsement - but I’m using Lubuntu at the moment, on my 2008 Toshiba (2gb, dual-core) - it can be slow but it’s certainly functional, although I’m not a heavy desktop user! :slight_smile:

Hope this helps,


The thought did occur to me as well. However, I’ve used Lite 3.8 on and off for the past few years and, generally speaking, I think it’s a good one. I think the reason is not that they couldn’t help, but that the creator (if that’s the correct term) didn’t want to assist with an older version. Considering, though, the distro is free, I can’t see the problem.

All of the above, I think. Without checking through the specs of both again, I’m sure that my laptop fails to come up to the minimum spec for v5 on any of the normal criteria.



I had a feeling I’d looked into that some time ago, but I’ll revisit it.

Not sure whether you’re suggesting getting an N10 instead. The N110, I have.

Thanks for your additional advice. Much appreciated - particularly after the Lite Forum :wink:


P.S. Is there an easier way to insert quotes? I’ve been using ‘Insert Quote’ and deleting what I don’t need. Is this the normal way people do it? Also, I’m not getting notifications for a reply.


I only meant that (and I believe that) the N10 and N110 have very similar hardware specs, so if you’re searching for “Blank Screen N110”, it would also be worth looking for “Blank Screen N10” too (or whatever).

Having an old laptop myself, I often discover something that I don’t like or can’t easily solve, so either simply live with it or move onto another distro - which means that I have a high turn-around of distos on my laptop. But, what I never do is make a note of what I’ve used nor why I don’t use it… I know some of the lightweight distros use a single-click (which just drives me crazy), and that many (including Debian) give me WIFI driver problems, but that’s personal taste and hardware, which may not impact you.

Here is a list of 50+ 50+ Best Lightweight Linux Distros for 2023 – ThisHosting.Rocks - Good hunting :slight_smile:
Does your N110 have 1gb or 2gb RAM? - either way, many of these require less than half of that, so you should be safe!

If you want any advice or even help choosing, perhaps let us know and I’m sure we’ll be happy to help out more (although I guess that should be a new question).

(I’m not very good at formatting my own posts, so I’ll have to leave that to somebody else I’m afraid :))


Your formatting’s fine. Thanks for your contributions.


Good you mentioned this Brian, as it’s a good example of how different distros suit different people/hardware, and why I’m often reluctant to recommend a specific distro, as what works brilliantly for me might not for somebody else. For example, the single click doesn’t bother me, and although I’ve had some wifi headaches with Ubuntu based distros they all disappear when I change to a Debian based distro.

It can often require a fair bit of experimentation until you find something you’re happy with. Having said all that you may like to consider Zorin Lite, it’s not what I’m currently using but when I tried it I found it to be one of the quickest to boot and most responsive in use.


P.S. Is there an easier way to insert quotes? I've been using 'Insert Quote' and deleting what I don't need. Is this the normal way people do it? Also, I'm not getting notifications for a reply.

“Insert quote” is the only way. My method is to select/copy the text I want to quote, click “insert quote” then paste the text. Very quick.

Not getting notifications? I’ve had that a few times, but if you are not getting any I suggest that you check your profile preferences. I doubt that they have become corrupted, but worth a try. If your preference is still set to receive notifications, your email address is correct and you are not getting any then do PM me and I’ll get the management to look into it.